PPPoE stopped working with 19.07

I was using 18.04 and PPPoE in a GPON link and was working fine.

However, upgrading to 19.07 stopped working "Error: Unknown error (USER_REQUEST)":

Protocol: PPPoE
MAC: 78:A3:51:19:45:EA
RX: 2.85 KB (36 Pkts.)
TX: 1.84 KB (25 Pkts.)
Error: Unknown error (USER_REQUEST)

I downgraded to 18.06 and is working again.

Anyone having the same trouble or any hint?

config interface 'Internet'
option proto 'pppoe'
option ifname 'eth0.6'
option password 'adslppp'
option peerdns '0'
option ipv6 '1'
option username 'adslppp@telefonicanetpap'
list dns 'x.x.x.x'
list dns 'x:x:x:x::x'
list dns 'x:x:x:x::x'
list dns 'x.x.x.x'

Did you upgrade to 19.07 keeping settings or starting blank?

Initially kept the settings, didn't worked (it worked that way in all my other routers, but they were not using PPPoE).

Then deleted the WAN interface and restarted, still same problem.

Is that with a SFP module inserted in the router or an CAT cable linking to the GPON device?

That seems copied from the LuCI interface but there is likely more verbose information in the syslog? The above error output is too generic, generated by [1]

Most likely PADI is failing due to the GPON link being in down state instead of up.

For a verbose debug of PPP it is possible to enable the debug flag in /etc/ppp/options

[1] https://git.openwrt.org/?p=openwrt/openwrt.git;a=blob;f=package/network/services/ppp/files/ppp.sh;h=b553effd889e7662f366793665c789ed0d0c0ff2;hb=refs/heads/openwrt-master#l41

1 Like

It is an external ONT, VLAN6 and the switch is properly configured for that.

I've turn on debug in ppp and this is what I get:

cat /tmp/ppp.log -> removed as the problems was not here

If I compare it with the same log using a 18.06, there is no difference!

Any hints ?

Is there an actual connectivity problem?
Where/when does the error message occur? Any event it may correlate to?

No, it never connects with 19.07. If I restart the interface (via Luci), it looks like it is restarting correctly (this is the log I've attached), but shows the error message
"Error: Unknown error (USER_REQUEST"

If I do the same in 18.06, it just works, even if I restart the interface via de same way, still works.

it disconnects frequently

Terminating on signal 15
sent [LCP TermReq id=0x2 "User request"]
rcvd [LCP TermAck id=0x2]
Connection terminated.
Connect time 0.6 minutes.

Does the subscriber line require a VLAN tag? If so is that set in 18.0.6 and perhaps absent after the upgrade to 19.07?

I'm sure that was me restarting again the interface via Luci ...

I tried so many times ...

I've waited several minutes while pinging and nothing.

Strange that it works perfectly with 18.06 (and it was working before with 18.04).

Yes, it requires VLAN 6 tagging, and in both 18.04, 18.06 and 19.07 I used the same switch config.

This seems relevant:

Looks like that script is returning an error condition, and then PPPoE decides to end. No idea why, however...

Since Movistar still does not support IPv6, I would try to disable it.

It's also weird that the server has a private IP address.

Perhaps having a look at that script will give us some clues.

By the way, from 18.04 to 18.06 the backup of the config also works fine, no need to recreate the config from scratch.

Anyway, just in case I also did that and then compared the /etc/config/network (from the backup and from scratch) and they are identical (in all the cases).

Yes, the server has a private address, but always has been like that.

I've tried the 3 options for IPv6: manual, automatic, disabled.

No difference! and again in 18.4 and 18.06 all them work.

I'm wondering if, in addition of /etc/config/network, there is any other file at all that may be related to the PPPoE setup, and may be broken for 19.07 ?

To work out if this is a bug in 19.xx or your configs, take a back up of your config and then flash to 19.07 with out saving your configs and see if it will work. Then use WinSCP to put back some of your configs and see what brakes it! Sorry for this breakage.

Change your name "InternetONT" to something much shorter. Total length of a kernel interface name (including the "pppoe-") can only be 15 letters. Using only lowercase is also recommend.


@jordipalet Please use Preformatted text (Ctrl+Shift+C or </> in the toolbar) to include all code blocks and the likes. It makes it easier to read.

For privacy and security reasons, I would also recommend redacting your MAC address, static public IP addresses (if any), usernames and passwords when posting your configuration online.


This is very strange. I'm sure I tried it before ....

The problem is the length of the interface name.

I used a short name and now it works.

I think it will be ideal to resolve it, unless really it is impossible, otherwise, people with long interface names, will not be able to upgrade ... (at least not easily).


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.