PPPOE no internet

hello
I have a problem connecting to the Internet.
I'm trying to get a pppoe connection on my openwrt router (OpenWrt 23.05.2) but failed.
here is log:

Tue Mar 26 21:06:45 2024 daemon.debug pppd[10249]:  [service-name] [host-uniq  09 28 00 00]
Tue Mar 26 21:06:50 2024 daemon.warn pppd[10249]: Timeout waiting for PADO packets
Tue Mar 26 21:06:50 2024 daemon.err pppd[10249]: Unable to complete PPPoE Discovery
Tue Mar 26 21:06:50 2024 daemon.info pppd[10249]: Exit.
Tue Mar 26 21:06:50 2024 daemon.notice netifd: Interface 'TIS' is now down
Tue Mar 26 21:06:50 2024 daemon.notice netifd: Interface 'TIS' is setting up now
Tue Mar 26 21:06:51 2024 daemon.info pppd[10352]: Plugin pppoe.so loaded.
Tue Mar 26 21:06:51 2024 daemon.info pppd[10352]: PPPoE plugin from pppd 2.4.9
Tue Mar 26 21:06:51 2024 daemon.notice pppd[10352]: pppd 2.4.9 started by root, uid 0
Tue Mar 26 21:06:51 2024 daemon.debug pppd[10352]: Send PPPOE Discovery V1T1 PADI session 0x0 length 12
Tue Mar 26 21:06:51 2024 daemon.debug pppd[10352]:  dst ff:ff:ff:ff:ff:ff  src f0:a7:##########
Tue Mar 26 21:06:51 2024 daemon.debug pppd[10352]:  [service-name] [host-uniq  70 28 00 00]
Tue Mar 26 21:06:51 2024 daemon.debug pppd[10352]: Recv PPPOE Discovery V1T1 PADO session 0x0 length 40
Tue Mar 26 21:06:51 2024 daemon.debug pppd[10352]:  dst f0:a7:31:##########  src 00:50:##########
Tue Mar 26 21:06:51 2024 daemon.debug pppd[10352]:  [AC-name sulu] [host-uniq  70 28 00 00] [service-name] [AC-cookie  5e 13 2e e2 58 6e 9f 26 df 06 32 ac 4f 03 41 f2]
Tue Mar 26 21:06:51 2024 daemon.debug pppd[10352]: Send PPPOE Discovery V1T1 PADR session 0x0 length 32
Tue Mar 26 21:06:51 2024 daemon.debug pppd[10352]:  dst 00:50:c2:##########  src f0:a7:##########
Tue Mar 26 21:06:51 2024 daemon.debug pppd[10352]:  [service-name] [host-uniq  70 28 00 00] [AC-cookie  5e 13 2e e2 58 6e 9f 26 df 06 32 ac 4f ##########]
Tue Mar 26 21:06:51 2024 daemon.debug pppd[10352]: Recv PPPOE Discovery V1T1 PADS session 0x5ab3 length 40
Tue Mar 26 21:06:51 2024 daemon.debug pppd[10352]:  dst f0:a7:31##########  src 00:50:##########
Tue Mar 26 21:06:51 2024 daemon.debug pppd[10352]:  [service-name] [host-uniq  70 28 00 00] [AC-name sulu] [AC-cookie  5e 13 2e e2 58 6e 9f 26 df 06 32 ac ##########]
Tue Mar 26 21:06:51 2024 daemon.debug pppd[10352]: PADS: Service-Name: ''
Tue Mar 26 21:06:51 2024 daemon.info pppd[10352]: PPP session is 23219
Tue Mar 26 21:06:51 2024 daemon.warn pppd[10352]: Connected to 00:50:c2:7f########## via interface wan
Tue Mar 26 21:06:51 2024 daemon.debug pppd[10352]: using channel 26
Tue Mar 26 21:06:51 2024 kern.info kernel: [ 1073.866171] pppoe-TIS: renamed from ppp0
Tue Mar 26 21:06:51 2024 daemon.info pppd[10352]: Renamed interface ppp0 to pppoe-TIS
Tue Mar 26 21:06:51 2024 daemon.info pppd[10352]: Using interface pppoe-TIS
Tue Mar 26 21:06:51 2024 daemon.notice pppd[10352]: Connect: pppoe-TIS <--> wan
Tue Mar 26 21:06:51 2024 daemon.debug pppd[10352]: sent [LCP ConfReq id=0x1 <mru 1492> <magic 0x13901823>]
Tue Mar 26 21:06:54 2024 daemon.debug pppd[10352]: sent [LCP ConfReq id=0x1 <mru 1492> <magic 0x13901823>]
Tue Mar 26 21:06:57 2024 daemon.debug pppd[10352]: sent [LCP ConfReq id=0x1 <mru 1492> <magic 0x13901823>]
Tue Mar 26 21:07:00 2024 daemon.debug pppd[10352]: sent [LCP ConfReq id=0x1 <mru 1492> <magic 0x13901823>]
Tue Mar 26 21:07:03 2024 daemon.debug pppd[10352]: sent [LCP ConfReq id=0x1 <mru 1492> <magic 0x13901823>]
Tue Mar 26 21:07:06 2024 daemon.debug pppd[10352]: sent [LCP ConfReq id=0x1 <mru 1492> <magic 0x13901823>]
Tue Mar 26 21:07:09 2024 daemon.debug pppd[10352]: sent [LCP ConfReq id=0x1 <mru 1492> <magic 0x13901823>]
Tue Mar 26 21:07:12 2024 daemon.debug pppd[10352]: sent [LCP ConfReq id=0x1 <mru 1492> <magic 0x13901823>]
Tue Mar 26 21:07:15 2024 daemon.debug pppd[10352]: sent [LCP ConfReq id=0x1 <mru 1492> <magic 0x13901823>]
Tue Mar 26 21:07:18 2024 daemon.debug pppd[10352]: sent [LCP ConfReq id=0x1 <mru 1492> <magic 0x13901823>]
Tue Mar 26 21:07:21 2024 daemon.warn pppd[10352]: LCP: timeout sending Config-Requests
Tue Mar 26 21:07:21 2024 daemon.notice pppd[10352]: Connection terminated.
Tue Mar 26 21:07:21 2024 daemon.notice pppd[10352]: Modem hangup
Tue Mar 26 21:07:21 2024 daemon.info pppd[10352]: Exit.
Tue Mar 26 21:07:21 2024 daemon.notice netifd: Interface 'TIS' is now down

Works fine on my pc with the same settings (eg username,password, type)


what's wrong with my pppoe?
i tried to reset settings on router but no luck

Looks like PPPoE is reaching the server, but it is refusing to assign you an IP address. Do you know if your ISP limits the devices that can connect, by MAC address?

3 Likes

“No limit” isp said. I tried to connect with another router - same problem, same log

any suggestions? still no internet connection.

Your ISP uses any VLAN? Do you have configured it?

We also need to see the config of your router:

Please connect to your OpenWrt device using ssh and copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

ubus call system board
cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall

Your ISP uses any VLAN?

i dont know. i asked my isp but still no answer
everything went wrong when I switched tariff - 80mbps >> 150mbps

cat /etc/config/network

cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd89########'
        option packet_steering '1'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option device 'wan'
        option proto 'dhcp'

config interface 'tis'
        option proto 'pppoe'
        option device 'wan'
        option username '###'
        option password '###'
        option ipv6 '0'
        option peerdns '0'
        option delegate '0'

config device
        option name 'wan'
        option ipv6 '0'

default wireless


cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option path '1e140000.pcie/pci0000:00/0000:00:01.0/0000:02:00.0'
        option channel '1'
        option band '2g'
        option htmode 'HT20'
        option disabled '1'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'none'

config wifi-device 'radio1'
        option type 'mac80211'
        option path '1e140000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
        option channel '36'
        option band '5g'
        option htmode 'VHT80'
        option disabled '1'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'none'

dhcp:


config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option cachesize '1000'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option nonwildcard '1'
        option localservice '1'
        option ednspacket_max '1232'
        option filter_aaaa '0'
        option filter_a '0'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv4 'server'
        option dhcpv6 'server'
        option ra 'server'
        option ra_slaac '1'
        list ra_flags 'managed-config'
        list ra_flags 'other-config'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

config dhcp 'tis'
        option interface 'tis'
        option ignore '1'

firewall:

config defaults
        option syn_flood '1'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'

config zone
        option name 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        list network 'lan'

config zone
        option name 'wan'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'
        list network 'wan'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-IPSec-ESP'
        option src 'wan'
        option dest 'lan'
        option proto 'esp'
        option target 'ACCEPT'

config rule
        option name 'Allow-ISAKMP'
        option src 'wan'
        option dest 'lan'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'

What ISP do you have, and which country?

@eduperez @Exio0 thanks for your help. it was some isp problem, not openwrt

2 Likes

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.