Pppoe disable ipv6

What is the proper way to disable ipv6 on pppoe wan interface?
I tried:

  • uncheck Enable IPv6 in wan interface options
    It didn't work. A second "wan_6" interface appeared and it's functional and used.
  • delete the wan_6
    Appears back.
  • stop it
    No effect.
  • uncheck every other option related to ipv6 in wan
    No effect.
  • stop odhcp6c in Startup
    It's not listed there!!!
  • kill it from command line
    It gets restarted!
  • manually add "option ipv6 0" to interface wan in /etc/config/network
    Works until I make any change in web ui, then it dissappears and wan_6 is back.
    BTW, there is a "config device" named wan that has "option ipv6 0" set. Is this the place where Enable IPv6 from wan gets set?


What is the protocol type of the WAN_6 interface that appears automatically? If it's "Virtual dynamic interface (DHCPv6 client)", try disabling this and restart the interface:

1 Like

Yes, that's the protocol.
There is no such option for wan and wan_6 Edit page is empty.

Which version of OpenWrt are you on? The screenshot was from the latest stable (19.07.7). WAN_6 should be indeed empty because it's a virtual, dynamically generated interface, you should modify your main WAN interface (the one you set your PPPoE credentials in), make sure you're on the correct tab.

1 Like

Master branch from last week. r16345
Your screenshot looks like a normal ethernet wan, not pppoe.

Master is different then, that option in my screenshot is only present in the 19.07 branch. If you uncheck this and IPv6 is still not disabled on that interface, it's probably a bug and you need to report it.

Note: I have not tested PPPoE on master personally yet, my main device is still on 19.07.

screenshot from master (git-21.086.63453-9ff45c9)

As a last resort (if this was a bug), you can also temporarily drop all ipv6 traffic in the firewall if that's what you wish.

1 Like

Yes, disabling it was the first thing i did. I tried to enable it back, but it seems broken. It stays disabled after save.
Where do I report bugs?

Bug reporting procedures: https://openwrt.org/bugs

The checkbox being broken definitely sounds like a bug.

Please do a clean build from current master and reset all configs on the device before reporting it.

It's a regression in LuCI caused by the recent device config support. I am working on it.


I can't test the latest master right now. It's difficult for me. I'm not using a VM, but a real router that I need to flash and reconfig every time.
If the problem is known, no point in adding another bug report, i think.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.