PPPoE connection fails occasionally, 'Unknown error (USER REQUEST)'

  • The router is a TP-Link Archer C20 v4

  • I'm a new OpenWrt user, I installed it yesterday.

  • The connection type with my ISP is PPPoE

  • I never had such an issue with the stock OS, all I always had to do was just choose PPPoE as the connection type and enter my username and password and that's it.

  • The router is connected to a fiber optic modem (I believe it is called an ONO or ONT?) through an Ethernet cable

  • The error message I get is Unknown error (USER REQUEST) then it changes to connection attempt failed a few seconds later

  • If I delete wan6 or reconfigure it in any way I lose internet connection too (wan fails to connect and I get the same error message)

I'm pretty sure there is something I haven't configured correctly but honestly, I have zero idea what it is as there are A LOT of options and terms and toggles that I don't understand, there is a lot for me to learn, anyway, I tried to figure it out but obviously failed, I looked at the system logs, adjusted some settings in the switches and interface section but to no avail, looked for a solution on YT and here and couldn't find anything helpful, it's pretty clear to me at this point that I'm a total noob at this stuff.

Will my phone lose the wireless connection with the router if I disable the Enable VLAN functionality in the switches settings? I'm asking because I'm pretty sure VLAN was turned off on the stock OS it was right under the PPPoE settings.

I don't know what to hide in the images and what not so hide all.

I figure that the system logs contain some sensitive information but I don't know which, What should I remove from it before sharing?

Another thing unrelated that I have encountered, the entire system crashes and the router reboots if I keep changing settings one after the other

Update #1: I don't know whether it is better to leave VLAN on or not but I disabled it anyway and as I expected I lost the PPPoE connection in the wan interface but selecting another device in its device list (from Software VLAN: "eth0.2" to Ethernet Adapter: "eth0" alongside wan6 restored the connection, I'm learning little by little though I doubt this resolved the main issue

Update #2: I deleted wan6 and lost the connection but then I tempered with the Ipv6 settings sub-menu in the DHCP server settings in the wan interface and it reconnected! How why?! Then I reset things back to the default values and the PPPoE connection didn't fail!!! How!!! What did I do?

Update #3: my tv control app on my phone couldn't find the TV which is connected to the router via Ethernet and the TV started complaining about network status is unstable, I think it is because I disabled VLAN so I just re-enabled it then the PPPoE connection failed so I reset the wan interface back to eth0.2 and it still didn't connect but after some trial and error it connected! Is it because it needed some time to reconnect and get a new IP from the ISP? idk, Anyway let's see if this fixed the issue, Please work😫... a few moments later... it worked! YES, lesson learned VLAN should stay on but now I have a question Are the VLAN default settings the same across all devices running OpenWrt, and are VLAN settings configured so that OpenWrt is ready to use "out of the box"? ie do I need to configure it differently? Take a look at the default settings in the screenshot below and one last question why is OpenWrt not ready to use out of the box same as the stock OS, With stock OS "it just works" I didn't need to tinker and search the internet just to figure out how I'm gonna set the router up I just got into the settings selected PPPoE then entered my credentials then chose the name and password for the WiFi network and that's it, why it is not as simple as this with Open Wrt? Hopefully this finally put an end to this problem

Pretty much yes, the default settings should work 99.9% of times for home users.

The logic behind having 2 VLANs is to separate your LAN from the WAN, so that devices outside your network can't reach your devices that easily.

As far as I know, it is, but it depends on the order of the steps you've done. If you messed with VLANs and interface-device binding 1st (which I think you did - see below* ) and then setting PPPoE credentials, it won't work unless you put things in order.

* I noticed that your wan interface is bound to br-wan, which by the color of it, is either dead, or completely inexistent. You might want to bind your wan interface to eth0.2 (the WAN VLAN). If you do that, it should work

1 Like

I have actually reset everything back to the default and only made one single change, deleting wan6 and now everything works perfectly, no more occasional PPPoE disconnection, so I guess wan6 was the culprit all along.

As I have mentioned in the updates I have set the wan back to eth0.2 after re enabling VLAN

In short:

  • The wan interface is now set to Switch VLAN: "eth0.2" (wan) thus showing pppoe-wan instead of br-wan
  • deleted the wan6 interface
1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.