PPPoE Connection fails consistently with PADO timeout


Despite multiple attempts to connect my TP Link Archer C20 v4 19.07.7 to the VDSL2 Modem of my ISP, it simply refuses to connect with a PADO timeout. This is not the case when it connects to my Windows 7 desktop, where it successfully connects with no issue.

Hence, I can say with certainty that it is the Router's problem. I may have configured something wrong. Additionally, the modem does not have a VLAN ID.

How do I go on about this?

Thank you very much.

Can you show us a screenshot of the configuration on the Windows computer, and a copy of the "/etc/config/network" file on your router?

Can you show us a screenshot of the configuration on the Windows computer

What do you mean, exactly? Do I show you the control panel?

we want to see the PPPoE config of your Windows machine.

I assume this is what you're looking for. Please correct me if ever.


PPPoE Part 3

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr ''
        option netmask ''

config globals 'globals'
        option ula_prefix 'fda0:cd38:80a3::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option ipaddr ''
        option netmask ''
        option ip6assign '60'

config device 'lan_eth0_1_dev'
        option name 'eth0.1'
        option macaddr '70:4f:57:00:4c:74'

config interface 'wan'
        option proto 'pppoe'
        option username 'redacted'
        option ipv6 'auto'
        list dns ''
        list dns ''
        option mtu '1492'
        option keepalive '5 5'
        option peerdns '0'
        option demand '100'
        option password 'redacted'
        option ifname 'eth0.2'

config device 'wan_eth0_2_dev'
        option name 'eth0.2'
        option macaddr '70:4f:57:00:4c:75'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '6t 1 2 3 4'

config switch_vlan
        option device 'switch0'
        option ports '6t 0'
        option vlan '2'

Clone the MAC address of your desktop PC to the router's wan interface.

1 Like

Are you saying that for the most part, I configured the connection correctly sans cloning MAC address? What happens if I disconnect the machine? Will the connection still remain without the Windows PC?

the modem will think it's still talking to the PC, since the Archer have the same MAC.

Thus maintaining the connection, but instead of the windows machine, it's the router that has the MAC. Correct?

Yes, correct.

Sorry for asking a noob question, but how do I do that exactly?

Do I use uci set "MAC address"? If so, I did that and yet LuCI does not show any change. Please advise me on this. I did it in this format when I inputted it in the command line:

uci set network.wan.eth0_2_dev.macaddr='xx-xx-xx-xx-xx-' (Something like this)

AFAIK, It has to me 'xx:xx:xx:xx:xx' for the change to be reflected in LuCI, right?

Seems it's been reported before ...
anyway, read Is the Wan Mac address override working in 19 with Luci? - #5 by bill888

I had a quick read on this. Apparently, overriding the MAC Address for when the connection option is PPPoE is not possible since the option for "override MAC" is not available; this means that I'll have to edit it via ssh.

It seems that the only way I can configure this is to do so manually via ssh;

How do I input this in /etc/config/network? I'll most likely have to input this via uci via "uci set" Is that right?

config interface 'wan'
option ifname 'eth0'
option _orig_ifname 'eth0'
option _orig_bridge 'false'
option proto 'pppoe'
option password 'xxxxxxxx'
option metric '1'
option macaddr 'xx:xx:xx:xx:xx:xx'
option username 'xxxxxx'

I got to solve the problem!

A short summary of the steps for Globe Telecom Philippines VDSL PPPoE Users:

Go to Switch of LuCI;

  1. Change the VLAN ID of the Second to 200 (Globe Telecom VLAN Server), and set WAN to Tagged;
  2. Delete any other WAN interfaces and only keep WAN (DHCP)
  3. Change Protocol to PPPoE, and Enter Credentials from ISP Modem (Username and Password)
  4. Save and Apply

If it does not work:

  1. Get a Desktop that Can Connect to PPPoE via your credentials;
  2. Clone the MAC Address of said PC to OpenWRT Router via uci;
  3. Save and Commit the Changes
  4. Reboot the Router

does your 2nd last post reflect the manual configuration you had to do, to get it to work?
and did it work without cloning the MAC ?

I edited my latest solution. Please take a look.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.