Pppd always terminates

Oftentimes when I write dmesg -c after a download fails or just to check I get this:

[  768.998693] eth1: link up (10Mbps/Half duplex)
[  827.238768] eth1: link down
[  828.279921] eth1: link up (100Mbps/Full duplex)
[  830.429474] eth1: link down
[  830.458367] IPv6: ADDRCONF(NETDEV_UP): eth1: link is not ready
[  830.478775] eth1: link up (100Mbps/Full duplex)
[  831.317811] pppoe-wan: renamed from ppp0
# these are because of traffic shaping scripts
[  838.316984] HTB: quantum of class 10001 is big. Consider r2q change.
[  838.599355] HTB: quantum of class 10013 is big. Consider r2q change.

after some time of searching I was able to get these repeating logs to from pppd:

Terminating on signal 15
Connect time 6.3 minutes.
Sent 5210073 bytes, received 76657905 bytes.
Script /lib/netifd/ppp-down started (pid 2139)
sent [LCP TermReq id=0x2 "User request"]
Script /lib/netifd/ppp-down finished (pid 2139), status = 0x0
sent [LCP TermReq id=0x3 "User request"]
rcvd [LCP TermAck id=0x3]
Connection terminated.
Send PPPOE Discovery V1T1 PADT session 0x3510 length 8
 dst 70:xx:xx:xx:xx:xx  src e8:xx:xx:xx:xx:xx
 [host-uniq  00 00 07 76]
Sent PADT
Plugin rp-pppoe.so loaded.
RP-PPPoE plugin version 3.8p compiled against pppd 2.4.7
Send PPPOE Discovery V1T1 PADI session 0x0 length 36
 dst ff:ff:ff:ff:ff:ff  src e8:xx:xx:xx:xx:xx
 [service-name BNSUF2-R32C-BNS-EG] [host-uniq  00 00 08 73] [PPP-max-payload  05 dc]
Recv PPPOE Discovery V1T1 PADO session 0x0 length 58
 dst e8:xx:xx:xx:xx:xx  src 70:xx:xx:xx:xx:xx
 [service-name BNSUF2-R32C-BNS-EG] [host-uniq  00 00 08 73] [PPP-max-payload  05 dc] [AC-name BNSUF2-R32C-BNS-EG]
Send PPPOE Discovery V1T1 PADR session 0x0 length 36
 dst 70:xx:xx:xx:xx:xx  src e8:xx:xx:xx:xx:xx
 [service-name BNSUF2-R32C-BNS-EG] [host-uniq  00 00 08 73] [PPP-max-payload  05 dc]
Recv PPPOE Discovery V1T1 PADS session 0x3512 length 36
 dst e8:xx:xx:xx:xx:xx  src 70:xx:xx:xx:xx:xx
 [service-name BNSUF2-R32C-BNS-EG] [host-uniq  00 00 08 73] [PPP-max-payload  05 dc]
PADS: Service-Name: 'BNSUF2-R32C-BNS-EG'
PPP session is 13586
Connected to 70:xx:xx:xx:xx:xx via interface eth1
using channel 4
Renamed interface ppp0 to pppoe-wan
Using interface pppoe-wan
Connect: pppoe-wan <--> eth1
sent [LCP ConfReq id=0x1 <magic 0xbdfdc0e9>]
rcvd [LCP ConfAck id=0x1 <magic 0xbdfdc0e9>]
rcvd [LCP ConfReq id=0x2 <mru 1500> <auth pap> <magic 0x1c2f8eeb>]
sent [LCP ConfAck id=0x2 <mru 1500> <auth pap> <magic 0x1c2f8eeb>]
sent [LCP EchoReq id=0x0 magic=0xbdfdc0e9]
sent [PAP AuthReq id=0x1 user="xxxxxxx" password=<hidden>]
rcvd [LCP EchoRep id=0x0 magic=0x1c2f8eeb]
sent [PAP AuthReq id=0x2 user="xxxxxxx" password=<hidden>]
rcvd [PAP AuthAck id=0x2 ""]
PAP authentication succeeded
peer from calling number 70:xx:xx:xx:xx:xx authorized
sent [IPCP ConfReq id=0x1 <addr 0.0.0.0> <ms-dns1 0.0.0.0> <ms-dns2 0.0.0.0>]
rcvd [IPCP ConfReq id=0x1 <addr xxx.xxx.xxx.xxx>]
sent [IPCP ConfAck id=0x1 <addr xxx.xxx.xxx.xxx>]
rcvd [IPCP ConfNak id=0x1 <addr xxx.xxx.xxx.xxx> <ms-dns1 163.121.128.134> <ms-dns2 163.121.128.135>]
sent [IPCP ConfReq id=0x2 <addr xxx.xxx.xxx.xxx> <ms-dns1 163.121.128.134> <ms-dns2 163.121.128.135>]
rcvd [IPCP ConfAck id=0x2 <addr xxx.xxx.xxx.xxx> <ms-dns1 163.121.128.134> <ms-dns2 163.121.128.135>]
local  IP address xxx.xxx.xxx.xxx
remote IP address xxx.xxx.xxx.xxx
primary   DNS address 163.121.128.134
secondary DNS address 163.121.128.135
Script /lib/netifd/ppp-up started (pid 2216)
Script /lib/netifd/ppp-up finished (pid 2216), status = 0x0

This always happens when downloading.
/etc/config/network:

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd3a:f6ed:1ef2::/48'

config interface 'wan'
	option ifname 'eth1'
	option proto 'pppoe'
	option password 'x'
	option username 'xxxxxxx'
	list dns '176.103.130.132'
	list dns '176.103.130.134'
	option peerdns '0'
	option keepalive '5 30'
	option ipv6 '0'
	option service 'BNSUF2-R32C-BNS-EG'
	option mtu '1500'
    option pppd_options 'passive'
    option padi_timeout '30'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '1 2 3 4 0t'

I have TL-WDR3500 V1 with openwrt-19.07.3-ath79-generic-tplink_tl-wdr3500-v1-squashfs-sysupgrade.bin.
What is causing this?

I read it before but I didn't want to believe it ath79 builds have a problem with tp-wdr3500. ar71xx builds work well.

1 Like

Or compile ath79 yourself.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.