PPP and dnsmasq issue

Has anyone encountered any issue after this commit? ppp: Update to version 2.4.9
I filed a bugreport

My internet is using pppoe and dualstack

dnsmasq is spamming the log with this

Wed Mar 17 23:05:06 2021 daemon.warn dnsmasq[2385]: failed to create listening socket for xxx%pppoe-wan: Address not available

The address dnsmasq trying to listen to is the remote link local address.

It doesn't happen if I revert the commit.

root@openwrt:~# cat /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdf2:dd6b:7151::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'lan1 lan2 lan3 lan4'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '64'

config interface 'wan'
        option ifname 'wan'
        option proto 'pppoe'
        option username ''
        option password ''

config device
        option name 'br-lan'
        option igmp_snooping '1'
        option multicast_querier '0'
root@openwrt:~# cat /etc/config/dhcp

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option nonwildcard '1'
        option localservice '1'
        option ednspacket_max '1232'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv4 'server'
        option dhcpv6 'server'
        option ra 'server'
        option ra_slaac '1'
        list ra_flags 'managed-config'
        list ra_flags 'other-config'
        option ra_management '0'
        option ra_default '1'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

so several times an hour?

More than that.
It just keeps trying.

some updates

dnsmasq retries twice every five mins

Sun Mar 21 14:47:21 2021 daemon.warn dnsmasq[9758]: failed to create listening socket for RRLOCAL%pppoe-wan: Address not available
Sun Mar 21 14:47:21 2021 daemon.warn dnsmasq[9758]: failed to create listening socket for RRLOCAL%pppoe-wan: Address not available
Sun Mar 21 14:52:03 2021 daemon.warn dnsmasq[9758]: failed to create listening socket for RRLOCAL%pppoe-wan: Address not available
Sun Mar 21 14:52:03 2021 daemon.warn dnsmasq[9758]: failed to create listening socket for RRLOCAL%pppoe-wan: Address not available
Sun Mar 21 14:56:31 2021 daemon.warn dnsmasq[9758]: failed to create listening socket for RRLOCAL%pppoe-wan: Address not available
Sun Mar 21 14:56:31 2021 daemon.warn dnsmasq[9758]: failed to create listening socket for RRLOCAL%pppoe-wan: Address not available
Sun Mar 21 15:01:06 2021 daemon.warn dnsmasq[9758]: failed to create listening socket for RRLOCAL%pppoe-wan: Address not available
Sun Mar 21 15:01:06 2021 daemon.warn dnsmasq[9758]: failed to create listening socket for RRLOCAL%pppoe-wan: Address not available
Sun Mar 21 15:06:00 2021 daemon.warn dnsmasq[9758]: failed to create listening socket for RRLOCAL%pppoe-wan: Address not available
Sun Mar 21 15:06:00 2021 daemon.warn dnsmasq[9758]: failed to create listening socket for RRLOCAL%pppoe-wan: Address not available

you should probably create a bugreport on flyspray if you are running recent master...

you could also checkout any issues/bugreports for dnsmasq itself... but i'm guessing this isn't directly dnsmasq related...

actually before that it might be prudent to post your network and dhcp config files for a once over...

Done.

I suspect it's because of the PPP.

I've been trying to do git bisect on PPP but ran into problems with OpenWrt's custom patches.

1 Like

Okay I figured out which PPP's commit caused this behavior.

It's this one pppd: Fix setting IPv6 peer address

2 Likes

paste the output of

ip -6 a
ip -6 route

(obfusacting any public ip / mac stuff)... cheers

You have a PM @anon50098793

Mines doing the same thing, every 3 minutes it trys to do something and gives that error twice, like clockwork.

I've done them two commands, and got the output which I've forwarded to you in a PM as I don't know what info is sensitive and what isn't.

root@OpenWrt:~# ip -6 a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 state UNKNOWN qlen 1000
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1502 state UP qlen 1000
    inet6 fe80::3a94:edff:fe15:9484/64 scope link
       valid_lft forever preferred_lft forever
8: wan@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 fe80::3a94:edff:fe15:9484/64 scope link
       valid_lft forever preferred_lft forever
15: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 *::1/64 scope global dynamic noprefixroute
       valid_lft 82654sec preferred_lft 82654sec
    inet6 *::1/60 scope global noprefixroute
       valid_lft forever preferred_lft forever
    inet6 fe80::3a94:edff:fe15:9484/64 scope link
       valid_lft forever preferred_lft forever
17: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 fe80::3a94:edff:fe15:9485/64 scope link
       valid_lft forever preferred_lft forever
18: pppoe-wan: <POINTOPOINT,MULTICAST,NOARP,UP,LOWER_UP> mtu 1492 state UNKNOWN qlen 3
    inet6 */64 scope global noprefixroute
       valid_lft forever preferred_lft forever
    inet6 fe80::b4b0:7bbb:d685:79ec/128 scope link
       valid_lft forever preferred_lft forever
25: ifb4pppoe-wan: <BROADCAST,NOARP,UP,LOWER_UP> mtu 1500 state UNKNOWN qlen 32
    inet6 fe80::457:e3ff:fe43:6af8/64 scope link
       valid_lft forever preferred_lft forever
root@OpenWrt:~# ip -6 route
default from *::/64 via fe80::230:88ff:fe04:8380 dev pppoe-wan  metric 512
default from *::/64 via fe80::230:88ff:fe04:8380 dev pppoe-wan  metric 512
*::/64 dev br-lan  metric 1024
unreachable *::/64 dev lo  metric 2147483647
unreachable *::/64 dev lo  metric 2147483647
*::/64 dev br-lan  metric 1024
unreachable *::/48 dev lo  metric 2147483647
fe80::230:88ff:fe04:8380 dev pppoe-wan  metric 256
fe80::b4b0:7bbb:d685:79ec dev pppoe-wan  metric 256
fe80::/64 dev eth0  metric 256
fe80::/64 dev wlan0  metric 256
fe80::/64 dev br-lan  metric 256
fe80::/64 dev wan  metric 256
fe80::/64 dev ifb4pppoe-wan  metric 256
anycast *:: dev br-lan  metric 0
anycast *:: dev pppoe-wan  metric 0
anycast *:: dev br-lan  metric 0
anycast fe80:: dev eth0  metric 0
anycast fe80:: dev wlan0  metric 0
anycast fe80:: dev br-lan  metric 0
anycast fe80:: dev wan  metric 0
anycast fe80:: dev ifb4pppoe-wan  metric 0
multicast ff00::/8 dev eth0  metric 256
multicast ff00::/8 dev br-lan  metric 256
multicast ff00::/8 dev wlan0  metric 256
multicast ff00::/8 dev wan  metric 256
multicast ff00::/8 dev pppoe-wan  metric 256
multicast ff00::/8 dev ifb4pppoe-wan  metric 256
1 Like

possibly beyond my comprehension but suggest messing with listen-address(search forum) style config option to attempt to eliminate initialising on that interface in the short term... ( if eliminating the logspam is the key concern )

the ppp code change does appear to play a role... as does some dhcp6c and netifd code which seems to be the more recent of them... and due to the timing of the issues surfacing... it does point to something other/in addition to the ppp stuff alone... possibly isp specific also...

For now I just make dnsmasq ignore WAN since it doesn't really do anything.

1 Like
dnsmasq[6941]: failed to create listening socket for fe80::xxxx:xxxx:xxx:2fce%pppoe-wan: Address not available

any news ?

Only temp resolution.

Exclude the WAN interface in dnsmasq setting.

1 Like
Tue Apr 13 23:25:18 2021 daemon.warn dnsmasq[7923]: failed to create listening socket for fe80::82ac:acff:feee:5acc%pppoe-wan: Address not available
Tue Apr 13 23:25:18 2021 daemon.warn dnsmasq[7923]: failed to create listening socket for fe80::82ac:acff:feee:5acc%pppoe-wan: Address not available
Tue Apr 13 23:26:05 2021 daemon.warn dnsmasq[7923]: failed to create listening socket for fe80::82ac:acff:feee:5acc%pppoe-wan: Address not available
Tue Apr 13 23:26:05 2021 daemon.warn dnsmasq[7923]: failed to create listening socket for fe80::82ac:acff:feee:5acc%pppoe-wan: Address not available
Tue Apr 13 23:26:05 2021 daemon.warn dnsmasq[7923]: failed to create listening socket for fe80::82ac:acff:feee:5acc%pppoe-wan: Address not available
Tue Apr 13 23:26:05 2021 daemon.warn dnsmasq[7923]: failed to create listening socket for fe80::82ac:acff:feee:5acc%pppoe-wan: Address not available
Tue Apr 13 23:35:18 2021 daemon.warn dnsmasq[7923]: failed to create listening socket for fe80::82ac:acff:feee:5acc%pppoe-wan: Address not available
Tue Apr 13 23:35:18 2021 daemon.warn dnsmasq[7923]: failed to create listening socket for fe80::82ac:acff:feee:5acc%pppoe-wan: Address not available
Tue Apr 13 23:36:06 2021 daemon.warn dnsmasq[7923]: failed to create listening socket for fe80::82ac:acff:feee:5acc%pppoe-wan: Address not available
Tue Apr 13 23:36:06 2021 daemon.warn dnsmasq[7923]: failed to create listening socket for fe80::82ac:acff:feee:5acc%pppoe-wan: Address not available
Tue Apr 13 23:36:06 2021 daemon.warn dnsmasq[7923]: failed to create listening socket for fe80::82ac:acff:feee:5acc%pppoe-wan: Address not available
Tue Apr 13 23:36:07 2021 daemon.warn dnsmasq[7923]: failed to create listening socket for fe80::82ac:acff:feee:5acc%pppoe-wan: Address not available
Tue Apr

Add:

list notinterface 'pppoe-wan'

to the "config dnsmasq" section in /etc/config/dhcp, and the problem will go away.

2 Likes

This problem persists on OpenWrt SNAPSHOT r19289-f65596e8a9 ,

Tue Mar 29 09:20:10 2022 daemon.warn dnsmasq[1]: failed to create listening socket for fe80::1%pppoe-wan: Address not available
Tue Mar 29 09:20:10 2022 daemon.warn dnsmasq[1]: failed to create listening socket for fe80::1%pppoe-wan: Address not available

You can detail what I need to do in / etc / config / dhcp?

config dnsmasq
    option domainneeded '1'
    option boguspriv '1'
    option filterwin2k '0'
    option localise_queries '1'
    option rebind_protection '1'
    option rebind_localhost '1'
    option local '/lan/'
    option domain 'lan'
    option expandhosts '1'
    option nonegcache '0'
    option authoritative '1'
    option readethers '1'
    option leasefile '/tmp/dhcp.leases'
    option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
    option nonwildcard '1'
    option localservice '1'
    option ednspacket_max '1232'
    option confdir '/tmp/dnsmasq.d'


config dhcp 'lan'
    option interface 'lan'
    option start '100'
    option limit '150'
    option leasetime '12h'
    option dhcpv4 'server'
    option dhcpv6 'server'
    option ra 'server'
    option ra_slaac '1'
    list ra_flags 'managed-config'
    list ra_flags 'other-config'

config dhcp 'wan'
    option interface 'wan'
    option ignore '1'
    list ra_flags 'none'

config odhcpd 'odhcpd'
    option maindhcp '0'
    option leasefile '/tmp/hosts/odhcpd'
    option leasetrigger '/usr/sbin/odhcpd-update'
    option loglevel '4'

config dnsmasq
    option domainneeded '1'
    option boguspriv '1'
      .
    list notinterface 'pppoe-wan'
      . 
    option confdir '/tmp/dnsmasq.d'

1 Like

I'm sorry but I don't know what to do, and what it should look like in my config?

config dnsmasq
    option domainneeded '1'
    option boguspriv '1'
    option filterwin2k '0'
    option localise_queries '1'
    option rebind_protection '1'
    option rebind_localhost '1'
    option local '/lan/'
    option domain 'lan'
    option expandhosts '1'
    option nonegcache '0'
    option authoritative '1'
    option readethers '1'
    option leasefile '/tmp/dhcp.leases'
    option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
    option nonwildcard '1'
    option localservice '1'
    option ednspacket_max '1232'
    list notinterface 'pppoe-wan'
    option confdir '/tmp/dnsmasq.d'


config dhcp 'lan'
    option interface 'lan'
    option start '100'
    option limit '150'
    option leasetime '12h'
    option dhcpv4 'server'
    option dhcpv6 'server'
    option ra 'server'
    option ra_slaac '1'
    list ra_flags 'managed-config'
    list ra_flags 'other-config'
  

config dhcp 'wan'
    option interface 'wan'
    option ignore '1'
    list ra_flags 'none'

config odhcpd 'odhcpd'
    option maindhcp '0'
    option leasefile '/tmp/hosts/odhcpd'
    option leasetrigger '/usr/sbin/odhcpd-update'
    option loglevel '4'

That will do.