Possible support for linksys ea6100?

Hello there
I have linksys ea6100 which ac an AC1200. In theory it can be supported by openwrt but there is no firmware image for this device. Can it be supported in the near future? 32326236_router-linksys-ea6100-2-antenas-ultra-rapidonuevo-d-nq-np-662525-mlv25448822694-032017-f_300x218

What's 'in theory'? Do you know if the SoC is already supported by OpenWrt etc.? If you can get someone knowledgeable to get a look at it and poke around a bit (or do that yourself if you're skilled enough), you might be able to get it supported.

Hardware specs: https://wikidevi.wi-cat.ru/Linksys_EA6100 -> MT7620A

1 Like

From TOH it says possible to support !
Unfortunately I'm not skilled enough to do that


See also:

What is your definition of "near future"?

I was able to read from the UART on this router. I can put instructions up if anyone's interested.

1 Like

Can you help please ?

pretty much all you need is at https://0x434b.dev/linksys-ea6100_pt1/ and https://0x434b.dev/linksys-ea6100_pt2/

i mean how to install openWRT on it ?

no one said it was (currently) doable, only that it could be, since there were other, already supported routers, using the same hw platform.

Hi. I haven't worked on this router in a while, but I think I'll see if I can put a build together this weekend if I finish writing the code for the class I TA. If I do, I'll put it here.

Thank you, I’ll appreciate this, I have a graduation project and need to install it asap,

Best regards.

Got it booting over TFTP.


  1. Build an initramfs image for the Linksys E1700.
  2. Rename it to uboot.img, and stick it in a tftp server with a static IP of
  3. Hook up to the serial port on the EA6100 and press 4 at the boot prompt.
  4. Run tftp 08550000. (or any address big enough to leave room for the decompressed image)
  5. Run bootm.

And it should go straight into OpenWrt. We'll have to make a device tree to get things actually working, but it boots. I haven't tested anything yet; will update here when I do.

Played with it a little more. Here's the output from lspci -k:

00:00.0 Class 0604: 1814:0801
01:00.0 Class 0280: 14c3:7662 mt76x2e
  • The first device is an RT2880 iNIC. This is not supported by the Linux kernel. Maybe there's a driver to be recovered from Linksys's source code.
  • The second device is a Mediatek MT7662E. It works with the mt76x2e driver.
  • Note that this contradicts the wiki here and wikidevi, which both say that this router has an MT7612E and make no mention of the RT2880.

Ethernet doesn't work if you build for the E1700, but does work if you build for the netgear EX3700. I'll have to actually read those makefiles and device trees to make a working configuration for this thing. After that, I'll try to tackle the nand.

I've written up a device tree. Wifi, ethernet, and usb all work. Still no nand yet. It's probably beyond my capabilities right now.

1 Like

but, why from E7100? is it recommended?

the second thing, what is the best way of TFTP on Mac OS, I tried before but there is a connect issue

thank you so much

woooooow that's huge pro, can you share the codes? and what you exactly did?

thank you ibn advanced.

but, why from E7100? is it recommended?

E1700 because it has the same SoC as the EA6100. (MT7620A)
Definitely don't flash an image for another router, but you can get away with running it with an initramfs. If you want to take that route though, you're better off using an initramfs image for the netgear EX3700 (also uses MT7620A) because its ethernet config works on our hardware.

the second thing, what is the best way of TFTP on Mac OS, I tried before but there is a connect issue

No idea. I have never set up a tftp server on anything other than linux. On Arch, you can just pacman -S tftp-hpa and systemctl start tftpd, then put the stuff you want to serve in /srv/tftp.

woooooow that's huge pro, can you share the codes? and what you exactly did?

I'll post the code when I get back home, but there's not much there. It's just bits and pieces ripped from the E1700 and EX3700 device trees plus half-written nand and pinctrl nodes. You will gain no additional functionality from using my device tree over using the one for the netgear ex3700 (but you will have less bootlog errors)

If you want something usable right now, your best bet is to set up the build system to make images for the ex3700 and configure it for extroot to boot from USB. Then you could have someting working right now. I'm not sure why nand isn't working, so until that gets figured out USB booting will be your only option for persistence.

Bit late too the party, but any news on this?

No news for the moment. Been busy with other stuff.
I unfortunately fried my laptop's SSD soon after making that post, so I no longer have that device tree. Honestly not a huge loss -- it wasn't too different from EX3700.