Possible error on the TL-WDR4300 page

Hi! I'm using a tl-wdr4300 V1.7 (https://openwrt.org/toh/tp-link/tl-wdr4300_v1) and I think there might be an error on the "Supported Versions" table. On version 1.7->Model Specific Notes it shows a link to the tp-link tl-wrd4310 version, so I assumed that I needed to install the firmware of that device instead of mine. But when I tried, it showed the error 18005 "Upgrade unsuccessfully because the version of the upgraded file was incorrect. Please check the file name.". When I tried the tl-wdr4300 version I successfully installed OpenWRT on my device, so I thought that there can be an error on the wiki page.


1 Like

That's more of a misunderstanding, than a factual error.

rev1.0 was the tl-wdr4310, sold only in China.
rev1.1 was the first model labelled as tl-wdr4300, there aren't any real differences (aside from changing the LED colour from blue to green some time later) between rev 1.1 and rev1.7.

The only difference between tl-wdr4310 and tl-wdr4300 is the hardware ID checked by the upgrade and bootloader (TL-WDR4310 with 0x43100001 and TL-WDR4300 with 0x43000001), this means either of them needs a dedicated firmware image (even though the hardware is identical).

Yes, expressing the model specific notes as "-" would have been better than "TP-Link TL-WDR4310".