Porting Firmware to TP-Link Archer C20 v5

Actually I killed it with tftp flashing. So, no reaction anymore on power on. Chip already removed and waiting for dump :slight_smile: But I don't have it.

Well done :+1::ok_hand:

Okay if you haven't erased the chip yet,then backup it
I'll send you a YouTube link ,everything explained about flashing via CH341a

It has been erased already unfortunately

Alright then upload that stripped firmware that I already posted into the flash chip

I don't know what you've done :thinking::thinking::wink: but this router has 2 bootloaders!!!! this V5 is better than V4 :wink:I have both

How are you?!!
what's up?
have you finished compiling 19.07 release?!!

Hey After I flashed your image, my router doesn't react at all, just LAN led blinking fast (if I detached the ethernet cable, all the LEDs are off). do you know what happens to my router? I installed factory image/openwrt via tftp doesn't help at all.

here's my tftp logs:

Connection received from on port 3726 [17/03 19:11:29.263]
Read request for file <tp_recovery.bin>. Mode octet [17/03 19:11:29.263]
OACK: <timeout=1,> [17/03 19:11:29.263]
Using local port 51592 [17/03 19:11:29.263]
<tp_recovery.bin>: sent 7809 blks, 3997985 bytes in 7 s. 0 blk resent [17/03 19:11:36.935]

First of all you wanted to install openwrt or just wanted to revert to tp stock firmware!?
Connect your lan cable to port 1 if you want to install openwrt I suggest you to install 18.06.5 stable release
You can find factory image and sysupgrate here

Upload (tp_recovery.bin) via tftp and wait until the router restarts after that update your router with sysupgrade image
I say it again connect your lan cable to port 1 and disable your windows firewall
I don't suggest you to install SNAPSHOT
Let me know
Good luck

1 Like

still no luck, my router is getting a bootloop.
I guess I will flash it via serial. but I don't have the tools for now on.

Before that install factory image(SNAPSHOT)

If you done it successfully then try install 18.06.5 via tftp
I had your problem yesterday but I fixed it


Thank you very much, now it's running (I flash it via lan)

but I got this error when installing luci

root@OpenWrt:~# opkg update
Downloading http://downloads.openwrt.org/snapshots/targets/ramips/mt76x8/package                                                                                                                                                             s/Packages.gz
Updated list of available packages in /var/opkg-lists/openwrt_core
Downloading http://downloads.openwrt.org/snapshots/targets/ramips/mt76x8/package                                                                                                                                                             s/Packages.sig
Signature check passed.
Downloading http://downloads.openwrt.org/snapshots/targets/ramips/mt76x8/kmods/4                                                                                                                                                             .14.171-1-6ea698da0e19b76bff9e967224d4fea6/Packages.gz
Updated list of available packages in /var/opkg-lists/openwrt_kmods
Downloading http://downloads.openwrt.org/snapshots/targets/ramips/mt76x8/kmods/4                                                                                                                                                             .14.171-1-6ea698da0e19b76bff9e967224d4fea6/Packages.sig
Signature check passed.
Downloading http://downloads.openwrt.org/snapshots/packages/mipsel_24kc/base/Pac                                                                                                                                                             kages.gz
Updated list of available packages in /var/opkg-lists/openwrt_base
Downloading http://downloads.openwrt.org/snapshots/packages/mipsel_24kc/base/Pac                                                                                                                                                             kages.sig
Signature check passed.
Downloading http://downloads.openwrt.org/snapshots/packages/mipsel_24kc/luci/Pac                                                                                                                                                             kages.gz
Updated list of available packages in /var/opkg-lists/openwrt_luci
Downloading http://downloads.openwrt.org/snapshots/packages/mipsel_24kc/luci/Pac                                                                                                                                                             kages.sig
Signature check passed.
Downloading http://downloads.openwrt.org/snapshots/packages/mipsel_24kc/packages                                                                                                                                                             /Packages.gz
Updated list of available packages in /var/opkg-lists/openwrt_packages
Downloading http://downloads.openwrt.org/snapshots/packages/mipsel_24kc/packages                                                                                                                                                             /Packages.sig
Signature check passed.
Downloading http://downloads.openwrt.org/snapshots/packages/mipsel_24kc/routing/                                                                                                                                                             Packages.gz
Updated list of available packages in /var/opkg-lists/openwrt_routing
Downloading http://downloads.openwrt.org/snapshots/packages/mipsel_24kc/routing/                                                                                                                                                             Packages.sig
Signature check passed.
Downloading http://downloads.openwrt.org/snapshots/packages/mipsel_24kc/telephon                                                                                                                                                             y/Packages.gz
Updated list of available packages in /var/opkg-lists/openwrt_telephony
Downloading http://downloads.openwrt.org/snapshots/packages/mipsel_24kc/telephon                                                                                                                                                             y/Packages.sig
Signature check passed.
root@OpenWrt:~# opkg install luci
Installing luci (git-20.076.40261-12e1d94-1) to root...
Downloading http://downloads.openwrt.org/snapshots/packages/mipsel_24kc/luci/luc                                                                                                                                                             i_git-20.076.40261-12e1d94-1_all.ipk
Collected errors:
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for luci:
 *      kernel (= 4.14.172-1-6ea698da0e19b76bff9e967224d4fea6)
 * opkg_install_cmd: Cannot install package luci.

As I told you before it's not recommended to install SNAPSHOT
I installed stable version 18.06.5 and everything is fine
If you want to install it just download it and upload via tftp

ok, I will try it.

Your device your choice

still got bootloop with v 18.06 . but the snapshot works fine but very unstable.

But I'm waiting for someone to compile new version 19.07.2
If I was pro and expert in linux ,build that immediately

But my router works flawlessly I used that image

1 Like