Port Forwarding

Dear All,

First of all, I'm new to OpenWrt and have zero experience with Linux, so that's already a good start right? Nevertheless I'm trying to setup OpenWrt on my "NETGEAR WNDR3700" by using LuCI and I think I've got everything figured out, except one thing: enabling my phone to access my NAS from anywhere in the world. I would appreciate if someone could help me with it, or point me in the right direction. (and even make it more safe)

So here's what I've done so far:

  1. Started with OpenWrt "custom settings"
  2. Created a static lease for my NAS
  3. Followed the guide for DDNS https://openwrt.org/docs/guide-user/services/ddns/client
  4. Followed the guide for Port Forwarding https://www.cfos.de/en/cfos-personal-net/port-forwarding/openwrt.htm (with a few minor adjustments, see screenshot)

Now... the good part is that my phone is able to access my NAS by using the DDNS address when I'm on my own wifi network, but the moment I switch to "4G" (Mobile data) it does not work anymore.


Have you configured the firewall in the NAS device to accept connections from an external IP address?

1 Like

How long it’s been since you created dns record?

Have you tried your public ip x.x.x.x:8085

1 Like

Have you tried without Source Mac Address?

It appears in the screenshot that you are using the MAC address of the phone's WiFi adapter. Now when you connect by 4G, that's source MAC address you have entered doesn't apply!


Eduperez, Vince and Mhegab, thanks for responding. Appreciate it.
The NAS was already correctly configured and the port was already included, so removing the MAC address from the port forwarding resolved the issue for me.

@vanderweyden I am glad it worked.

For you info, when you want to mention something in your post, you may add a "@" before their name; that way they get a notification of such mention, depending on their settings.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.