Thanks but i have solved it just now... sorry for the inconvenience.
I will post the solution and the configuration in the next post.
Thanks but i have solved it just now... sorry for the inconvenience.
I will post the solution and the configuration in the next post.
First of all i have to say thank you so much to all the people has participated in this topic and tried to help me, specially to @psherman and @mk24 , thanks for putting up with me <3
Afer hours of testing, i have solved this, i will post the configuration of my network file and you will understand me better:
root@OpenWrt:~# cat /etc/config/network
config interface 'loopback'
option device 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config globals 'globals'
option ula_prefix 'fd75:07f1:eeb7::/48'
config device
option name 'br-lan'
option type 'bridge'
list ports 'eth0'
config interface 'lan'
option device 'br-lan'
option proto 'static'
option ipaddr '192.168.2.1'
option netmask '255.255.255.0'
option ip6assign '60'
list dns '8.8.8.8'
list dns '8.8.4.4'
config interface 'wan'
option device 'eth1.20'
option proto 'pppoe'
option username 'xxxxxxxxx@digi'
option password 'xxxxxxxxx'
option ipv6 'auto'
config interface 'wan6'
option device 'eth1'
option proto 'dhcpv6'
config device
option type '8021q'
option ifname 'eth1'
option vid '20'
option name 'eth1.20'
option mtu '1500'
config interface 'wg_vpn'
option proto 'wireguard'
option private_key 'xxxxxxxxxxxxxxxxxxx='
option listen_port '51820'
option mtu '1280'
list addresses '192.168.9.1/24'
config wireguard_wg_vpn
option description 'Proxmox'
option public_key 'xxxxxxxxxxxxxxxxxxxxxxxx'
option route_allowed_ips '1'
option endpoint_port '51820'
list allowed_ips '192.168.9.2/32'
list allowed_ips '192.168.1.0/24'
list allowed_ips '192.168.9.3/32'
config wireguard_wg_vpn
option description 'iPhone'
option public_key 'xxxxxxxxxxxxxxxxxxxx='
option route_allowed_ips '1'
option endpoint_port '51820'
list allowed_ips '192.168.9.3/32'
root@OpenWrt:~#
I have solved it basically reading this:
I didnt notice that peers cant have the same AllowedIPs. This is still being valid after 6 years.
I didnt made Phone work with 0.0.0.0/0 but as you can see in the config file, i just had to add that IP to the phone and now is working, i have access to my both networks (A and B) with my ISP data plan.
Again thanks to all who has participated in this topic. Hope you all can help me a bit more in the future.