Please help me with my VLAN setup: "Network device is not present"

Hallo, I am trying to setup VLAN with DSA on a Linksys E8450 running OpenWrt 22.03-SNAPSHOT r19338-ae64d0624c / LuCI openwrt-22.03 branch git-22.119.37115-66994a5. I am trying for days to make VLAN work, following several tutorials.
The switches in my setup are properly configured to route the VLAN tagged traffic, which I was able to verify using a computer directly connected to a switch. ALso, the openWRT devices in my network all work as dumb APs, connected to OPNsense though manageable switches. The VLANs are setup in OPNsense and the DHCP server is enabled for each of them, providing a DHCP lease when requested from a VLAN device.

This is my current network configuration:

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd4c:c9ec:2f25::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.11.3'
        option gateway '192.168.11.1'
        list dns '192.168.11.10'

config device
        option type 'bridge'
        option name 'vlan-bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'
        option ipv6 '0'

config interface 'guest'
        option device 'vlan-bridge.20'
        option proto 'static'
        option ipaddr '192.168.30.3'
        option netmask '255.255.255.0'
        option gateway '192.168.30.1'
        option broadcast '192.168.30.255'

config device
        option type '8021q'
        option ifname 'vlan-bridge'
        option vid '20'
        option name 'vlan-bridge.20'
        option ipv6 '0'

config bridge-vlan
        option device 'vlan-bridge'
        option vlan '20'
        list ports 'lan1:t'

currently I am stuck because I am getting a "Network device is not present" error.

I can't find the reason for this, trying to set up VLAN on the APs since two days.
Thanks for helping me solve this!

EDIT: diagnostic information

{
	"kernel": "5.10.113",
	"hostname": "wlanog.home",
	"system": "ARMv8 Processor rev 4",
	"model": "Linksys E8450 (UBI)",
	"board_name": "linksys,e8450-ubi",
	"rootfs_type": "squashfs",
	"release": {
		"distribution": "OpenWrt",
		"version": "22.03-SNAPSHOT",
		"revision": "r19338-ae64d0624c",
		"target": "mediatek/mt7622",
		"description": "OpenWrt 22.03-SNAPSHOT r19338-ae64d0624c"
	}
}
network.loopback=interface
network.loopback.device='lo'
network.loopback.proto='static'
network.loopback.ipaddr='127.0.0.1'
network.loopback.netmask='255.0.0.0'
network.globals=globals
network.globals.ula_prefix='fd4c:c9ec:2f25::/48'
network.@device[0]=device
network.@device[0].name='br-lan'
network.@device[0].type='bridge'
network.@device[0].ports='lan1' 'lan2' 'lan3' 'lan4'
network.lan=interface
network.lan.device='br-lan'
network.lan.proto='static'
network.lan.netmask='255.255.255.0'
network.lan.ip6assign='60'
network.lan.ipaddr='192.168.11.3'
network.lan.gateway='192.168.11.1'
network.lan.dns='192.168.11.10'
network.@device[1]=device
network.@device[1].type='bridge'
network.@device[1].name='vlan-bridge'
network.@device[1].ports='lan1' 'lan2' 'lan3' 'lan4'
network.@device[1].ipv6='0'
network.guest=interface
network.guest.device='vlan-bridge.20'
network.guest.proto='static'
network.guest.ipaddr='192.168.30.3'
network.guest.netmask='255.255.255.0'
network.guest.gateway='192.168.30.1'
network.guest.broadcast='192.168.30.255'
network.@device[2]=device
network.@device[2].type='8021q'
network.@device[2].ifname='vlan-bridge'
network.@device[2].vid='20'
network.@device[2].name='vlan-bridge.20'
network.@device[2].ipv6='0'
network.@bridge-vlan[0]=bridge-vlan
network.@bridge-vlan[0].device='vlan-bridge'
network.@bridge-vlan[0].vlan='20'
network.@bridge-vlan[0].ports='lan1:t'
WIFI SETTINGS REDACTED
dhcp.@dnsmasq[0]=dnsmasq
dhcp.@dnsmasq[0].domainneeded='1'
dhcp.@dnsmasq[0].localise_queries='1'
dhcp.@dnsmasq[0].rebind_protection='1'
dhcp.@dnsmasq[0].rebind_localhost='1'
dhcp.@dnsmasq[0].local='/lan/'
dhcp.@dnsmasq[0].domain='lan'
dhcp.@dnsmasq[0].expandhosts='1'
dhcp.@dnsmasq[0].leasefile='/tmp/dhcp.leases'
dhcp.@dnsmasq[0].localservice='1'
dhcp.@dnsmasq[0].ednspacket_max='1232'
dhcp.@dnsmasq[0].noresolv='1'
dhcp.lan=dhcp
dhcp.lan.interface='lan'
dhcp.lan.start='100'
dhcp.lan.limit='150'
dhcp.lan.leasetime='12h'
dhcp.lan.dhcpv4='server'
dhcp.lan.ignore='1'
dhcp.lan.dynamicdhcp='0'
dhcp.lan.ra_flags='none'
dhcp.wan=dhcp
dhcp.wan.interface='wan'
dhcp.wan.ignore='1'
dhcp.odhcpd=odhcpd
dhcp.odhcpd.maindhcp='0'
dhcp.odhcpd.leasefile='/tmp/hosts/odhcpd'
dhcp.odhcpd.leasetrigger='/usr/sbin/odhcpd-update'
dhcp.odhcpd.loglevel='4'
HOSTS REDACTED
firewall.@defaults[0]=defaults
firewall.@defaults[0].syn_flood='1'
firewall.@defaults[0].input='ACCEPT'
firewall.@defaults[0].output='ACCEPT'
firewall.@defaults[0].forward='REJECT'
firewall.@zone[0]=zone
firewall.@zone[0].name='lan'
firewall.@zone[0].input='ACCEPT'
firewall.@zone[0].output='ACCEPT'
firewall.@zone[0].forward='ACCEPT'
firewall.@zone[0].network='lan'
firewall.@zone[1]=zone
firewall.@zone[1].name='wan'
firewall.@zone[1].input='REJECT'
firewall.@zone[1].output='ACCEPT'
firewall.@zone[1].forward='REJECT'
firewall.@zone[1].masq='1'
firewall.@zone[1].mtu_fix='1'
firewall.@forwarding[0]=forwarding
firewall.@forwarding[0].src='lan'
firewall.@forwarding[0].dest='wan'
firewall.@rule[0]=rule
firewall.@rule[0].name='Allow-DHCP-Renew'
firewall.@rule[0].src='wan'
firewall.@rule[0].proto='udp'
firewall.@rule[0].dest_port='68'
firewall.@rule[0].target='ACCEPT'
firewall.@rule[0].family='ipv4'
firewall.@rule[1]=rule
firewall.@rule[1].name='Allow-Ping'
firewall.@rule[1].src='wan'
firewall.@rule[1].proto='icmp'
firewall.@rule[1].icmp_type='echo-request'
firewall.@rule[1].family='ipv4'
firewall.@rule[1].target='ACCEPT'
firewall.@rule[2]=rule
firewall.@rule[2].name='Allow-IGMP'
firewall.@rule[2].src='wan'
firewall.@rule[2].proto='igmp'
firewall.@rule[2].family='ipv4'
firewall.@rule[2].target='ACCEPT'
firewall.@rule[3]=rule
firewall.@rule[3].name='Allow-DHCPv6'
firewall.@rule[3].src='wan'
firewall.@rule[3].proto='udp'
firewall.@rule[3].src_ip='fc00::/6'
firewall.@rule[3].dest_ip='fc00::/6'
firewall.@rule[3].dest_port='546'
firewall.@rule[3].family='ipv6'
firewall.@rule[3].target='ACCEPT'
firewall.@rule[4]=rule
firewall.@rule[4].name='Allow-MLD'
firewall.@rule[4].src='wan'
firewall.@rule[4].proto='icmp'
firewall.@rule[4].src_ip='fe80::/10'
firewall.@rule[4].icmp_type='130/0' '131/0' '132/0' '143/0'
firewall.@rule[4].family='ipv6'
firewall.@rule[4].target='ACCEPT'
firewall.@rule[5]=rule
firewall.@rule[5].name='Allow-ICMPv6-Input'
firewall.@rule[5].src='wan'
firewall.@rule[5].proto='icmp'
firewall.@rule[5].icmp_type='echo-request' 'echo-reply' 'destination-unreachable' 'packet-too-big' 'time-exceeded' 'bad-header' 'unknown-header-type' 'router-solicitation' 'neighbour-solicitation' 'router-advertisement' 'neighbour-advertisement'
firewall.@rule[5].limit='1000/sec'
firewall.@rule[5].family='ipv6'
firewall.@rule[5].target='ACCEPT'
firewall.@rule[6]=rule
firewall.@rule[6].name='Allow-ICMPv6-Forward'
firewall.@rule[6].src='wan'
firewall.@rule[6].dest='*'
firewall.@rule[6].proto='icmp'
firewall.@rule[6].icmp_type='echo-request' 'echo-reply' 'destination-unreachable' 'packet-too-big' 'time-exceeded' 'bad-header' 'unknown-header-type'
firewall.@rule[6].limit='1000/sec'
firewall.@rule[6].family='ipv6'
firewall.@rule[6].target='ACCEPT'
firewall.@rule[7]=rule
firewall.@rule[7].name='Allow-IPSec-ESP'
firewall.@rule[7].src='wan'
firewall.@rule[7].dest='lan'
firewall.@rule[7].proto='esp'
firewall.@rule[7].target='ACCEPT'
firewall.@rule[8]=rule
firewall.@rule[8].name='Allow-ISAKMP'
firewall.@rule[8].src='wan'
firewall.@rule[8].dest='lan'
firewall.@rule[8].dest_port='500'
firewall.@rule[8].proto='udp'
firewall.@rule[8].target='ACCEPT'
firewall.@rule[9]=rule
firewall.@rule[9].name='Support-UDP-Traceroute'
firewall.@rule[9].src='wan'
firewall.@rule[9].dest_port='33434:33689'
firewall.@rule[9].proto='udp'
firewall.@rule[9].family='ipv4'
firewall.@rule[9].target='REJECT'
firewall.@rule[9].enabled='false'
firewall.@include[0]=include
firewall.@include[0].path='/etc/firewall.user'
firewall.@zone[2]=zone
firewall.@zone[2].name='guest'
firewall.@zone[2].input='ACCEPT'
firewall.@zone[2].output='ACCEPT'
firewall.@zone[2].forward='REJECT'
firewall.@zone[2].network='guest'
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1504 qdisc fq_codel state UP group default qlen 1000
    link/ether e8:9f:80:d5:db:13 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::ea9f:80ff:fed5:db13/64 scope link 
       valid_lft forever preferred_lft forever
3: lan1@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-lan state UP group default qlen 1000
    link/ether e8:9f:80:d5:db:13 brd ff:ff:ff:ff:ff:ff
4: lan2@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-lan state UP group default qlen 1000
    link/ether e8:9f:80:d5:db:13 brd ff:ff:ff:ff:ff:ff
5: lan3@eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue master br-lan state LOWERLAYERDOWN group default qlen 1000
    link/ether e8:9f:80:d5:db:13 brd ff:ff:ff:ff:ff:ff
6: lan4@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-lan state UP group default qlen 1000
    link/ether e8:9f:80:d5:db:13 brd ff:ff:ff:ff:ff:ff
7: wan@eth0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default qlen 1000
    link/ether e8:9f:80:d5:db:12 brd ff:ff:ff:ff:ff:ff
10: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether e8:9f:80:d5:db:13 brd ff:ff:ff:ff:ff:ff
    inet 192.168.11.3/24 brd 192.168.11.255 scope global br-lan
       valid_lft forever preferred_lft forever
    inet6 fd4c:c9ec:2f25::1/60 scope global noprefixroute 
       valid_lft forever preferred_lft forever
    inet6 fe80::ea9f:80ff:fed5:db13/64 scope link 
       valid_lft forever preferred_lft forever
12: vlan-bridge: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default qlen 1000
    link/ether 8a:86:20:a1:4a:c9 brd ff:ff:ff:ff:ff:ff
13: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-lan state UP group default qlen 1000
    link/ether e8:9f:80:d5:db:14 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::ea9f:80ff:fed5:db14/64 scope link 
       valid_lft forever preferred_lft forever
14: wlan1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-lan state UP group default qlen 1000
    link/ether e8:9f:80:d5:db:15 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::ea9f:80ff:fed5:db15/64 scope link 
       valid_lft forever preferred_lft forever
15: wlan1-1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-lan state UP group default qlen 1000
    link/ether ea:9f:80:d5:db:15 brd ff:ff:ff:ff:ff:ff permaddr e8:9f:80:d5:db:15
    inet6 fe80::e89f:80ff:fed5:db15/64 scope link 
       valid_lft forever preferred_lft forever
16: wlan1-2: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether ee:9f:80:d5:db:15 brd ff:ff:ff:ff:ff:ff permaddr e8:9f:80:d5:db:15
    inet6 fe80::ec9f:80ff:fed5:db15/64 scope link 
       valid_lft forever preferred_lft forever
17: wlan1-3: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-lan state UP group default qlen 1000
    link/ether e2:9f:80:d5:db:15 brd ff:ff:ff:ff:ff:ff permaddr e8:9f:80:d5:db:15
    inet6 fe80::e09f:80ff:fed5:db15/64 scope link 
       valid_lft forever preferred_lft forever
18: wlan1-4: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-lan state UP group default qlen 1000
    link/ether e6:9f:80:d5:db:15 brd ff:ff:ff:ff:ff:ff permaddr e8:9f:80:d5:db:15
    inet6 fe80::e49f:80ff:fed5:db15/64 scope link 
       valid_lft forever preferred_lft forever
19: wlan1-5: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-lan state UP group default qlen 1000
    link/ether fa:9f:80:d5:db:15 brd ff:ff:ff:ff:ff:ff permaddr e8:9f:80:d5:db:15
    inet6 fe80::f89f:80ff:fed5:db15/64 scope link 
       valid_lft forever preferred_lft forever
20: wlan0-1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-lan state UP group default qlen 1000
    link/ether ea:9f:80:d5:db:14 brd ff:ff:ff:ff:ff:ff permaddr e8:9f:80:d5:db:14
    inet6 fe80::e89f:80ff:fed5:db14/64 scope link 
       valid_lft forever preferred_lft forever
21: wlan0-2: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-lan state UP group default qlen 1000
    link/ether ee:9f:80:d5:db:14 brd ff:ff:ff:ff:ff:ff permaddr e8:9f:80:d5:db:14
    inet6 fe80::ec9f:80ff:fed5:db14/64 scope link 
       valid_lft forever preferred_lft forever
default via 192.168.11.1 dev br-lan proto static 
192.168.11.0/24 dev br-lan proto kernel scope link src 192.168.11.3 
broadcast 127.0.0.0 dev lo table local proto kernel scope link src 127.0.0.1 
local 127.0.0.0/8 dev lo table local proto kernel scope host src 127.0.0.1 
local 127.0.0.1 dev lo table local proto kernel scope host src 127.0.0.1 
broadcast 127.255.255.255 dev lo table local proto kernel scope link src 127.0.0.1 
broadcast 192.168.11.0 dev br-lan table local proto kernel scope link src 192.168.11.3 
local 192.168.11.3 dev br-lan table local proto kernel scope host src 192.168.11.3 
broadcast 192.168.11.255 dev br-lan table local proto kernel scope link src 192.168.11.3 
fd4c:c9ec:2f25::/64 dev br-lan proto static metric 1024 pref medium
unreachable fd4c:c9ec:2f25::/48 dev lo proto static metric 2147483647 pref medium
fe80::/64 dev eth0 proto kernel metric 256 pref medium
fe80::/64 dev br-lan proto kernel metric 256 pref medium
fe80::/64 dev wlan1 proto kernel metric 256 pref medium
fe80::/64 dev wlan1-1 proto kernel metric 256 pref medium
fe80::/64 dev wlan1-2 proto kernel metric 256 pref medium
fe80::/64 dev wlan1-3 proto kernel metric 256 pref medium
fe80::/64 dev wlan1-4 proto kernel metric 256 pref medium
fe80::/64 dev wlan1-5 proto kernel metric 256 pref medium
fe80::/64 dev wlan0 proto kernel metric 256 pref medium
fe80::/64 dev wlan0-1 proto kernel metric 256 pref medium
fe80::/64 dev wlan0-2 proto kernel metric 256 pref medium
local ::1 dev lo table local proto kernel metric 0 pref medium
anycast fd4c:c9ec:2f25:: dev br-lan table local proto kernel metric 0 pref medium
local fd4c:c9ec:2f25::1 dev br-lan table local proto kernel metric 0 pref medium
anycast fe80:: dev eth0 table local proto kernel metric 0 pref medium
anycast fe80:: dev br-lan table local proto kernel metric 0 pref medium
anycast fe80:: dev wlan1 table local proto kernel metric 0 pref medium
anycast fe80:: dev wlan1-3 table local proto kernel metric 0 pref medium
anycast fe80:: dev wlan1-4 table local proto kernel metric 0 pref medium
anycast fe80:: dev wlan1-1 table local proto kernel metric 0 pref medium
anycast fe80:: dev wlan1-2 table local proto kernel metric 0 pref medium
anycast fe80:: dev wlan1-5 table local proto kernel metric 0 pref medium
anycast fe80:: dev wlan0 table local proto kernel metric 0 pref medium
anycast fe80:: dev wlan0-2 table local proto kernel metric 0 pref medium
anycast fe80:: dev wlan0-1 table local proto kernel metric 0 pref medium
local fe80::e09f:80ff:fed5:db15 dev wlan1-3 table local proto kernel metric 0 pref medium
local fe80::e49f:80ff:fed5:db15 dev wlan1-4 table local proto kernel metric 0 pref medium
local fe80::e89f:80ff:fed5:db14 dev wlan0-1 table local proto kernel metric 0 pref medium
local fe80::e89f:80ff:fed5:db15 dev wlan1-1 table local proto kernel metric 0 pref medium
local fe80::ea9f:80ff:fed5:db13 dev eth0 table local proto kernel metric 0 pref medium
local fe80::ea9f:80ff:fed5:db13 dev br-lan table local proto kernel metric 0 pref medium
local fe80::ea9f:80ff:fed5:db14 dev wlan0 table local proto kernel metric 0 pref medium
local fe80::ea9f:80ff:fed5:db15 dev wlan1 table local proto kernel metric 0 pref medium
local fe80::ec9f:80ff:fed5:db14 dev wlan0-2 table local proto kernel metric 0 pref medium
local fe80::ec9f:80ff:fed5:db15 dev wlan1-2 table local proto kernel metric 0 pref medium
local fe80::f89f:80ff:fed5:db15 dev wlan1-5 table local proto kernel metric 0 pref medium
multicast ff00::/8 dev eth0 table local proto kernel metric 256 pref medium
multicast ff00::/8 dev br-lan table local proto kernel metric 256 pref medium
multicast ff00::/8 dev wlan1 table local proto kernel metric 256 pref medium
multicast ff00::/8 dev wlan1-1 table local proto kernel metric 256 pref medium
multicast ff00::/8 dev wlan1-2 table local proto kernel metric 256 pref medium
multicast ff00::/8 dev wlan1-3 table local proto kernel metric 256 pref medium
multicast ff00::/8 dev wlan1-4 table local proto kernel metric 256 pref medium
multicast ff00::/8 dev wlan1-5 table local proto kernel metric 256 pref medium
multicast ff00::/8 dev wlan0 table local proto kernel metric 256 pref medium
multicast ff00::/8 dev wlan0-1 table local proto kernel metric 256 pref medium
multicast ff00::/8 dev wlan0-2 table local proto kernel metric 256 pref medium
0:	from all lookup local
32766:	from all lookup main
32767:	from all lookup default
-ash: iptables-save: not found
==> /etc/resolv.conf <==
# Interface lan
nameserver 192.168.11.10

==> /tmp/resolv.conf <==
# Interface lan
nameserver 192.168.11.10

==> /tmp/resolv.conf.d <==
head: /tmp/resolv.conf.d: I/O error

==> /tmp/resolv.conf.d/resolv.conf.auto <==
# Interface lan
nameserver 192.168.11.10

dmesg output:

[    0.000000] Booting Linux on physical CPU 0x0000000000 [0x410fd034]
[    0.000000] Linux version 5.10.113 (builder@buildhost) (aarch64-openwrt-linux-musl-gcc (OpenWrt GCC 11.2.0 r19338-ae64d0624c) 11.2.0, GNU ld (GNU Binutils) 2.37) #0 SMP Fri May 6 19:55:52 2022
[    0.000000] Machine model: Linksys E8450 (UBI)
[    0.000000] earlycon: uart8250 at MMIO32 0x0000000011002000 (options '')
[    0.000000] printk: bootconsole [uart8250] enabled
[    0.000000] Zone ranges:
[    0.000000]   DMA      [mem 0x0000000040000000-0x000000005fffffff]
[    0.000000]   DMA32    empty
[    0.000000]   Normal   empty
[    0.000000] Movable zone start for each node
[    0.000000] Early memory node ranges
[    0.000000]   node   0: [mem 0x0000000040000000-0x0000000042ffffff]
[    0.000000]   node   0: [mem 0x0000000043000000-0x000000004302ffff]
[    0.000000]   node   0: [mem 0x0000000043030000-0x000000005fffffff]
[    0.000000] Initmem setup node 0 [mem 0x0000000040000000-0x000000005fffffff]
[    0.000000] On node 0 totalpages: 131072
[    0.000000]   DMA zone: 2048 pages used for memmap
[    0.000000]   DMA zone: 0 pages reserved
[    0.000000]   DMA zone: 131072 pages, LIFO batch:31
[    0.000000] psci: probing for conduit method from DT.
[    0.000000] psci: PSCIv1.1 detected in firmware.
[    0.000000] psci: Using standard PSCI v0.2 function IDs
[    0.000000] psci: MIGRATE_INFO_TYPE not supported.
[    0.000000] psci: SMC Calling Convention v1.2
[    0.000000] percpu: Embedded 20 pages/cpu s43864 r8192 d29864 u81920
[    0.000000] pcpu-alloc: s43864 r8192 d29864 u81920 alloc=20*4096
[    0.000000] pcpu-alloc: [0] 0 [0] 1 
[    0.000000] Detected VIPT I-cache on CPU0
[    0.000000] CPU features: detected: ARM erratum 845719
[    0.000000] CPU features: kernel page table isolation disabled by kernel configuration
[    0.000000] CPU features: detected: ARM erratum 843419
[    0.000000] Built 1 zonelists, mobility grouping on.  Total pages: 129024
[    0.000000] Kernel command line: earlycon=uart8250,mmio32,0x11002000 console=ttyS0,115200n1 swiotlb=512
[    0.000000] Dentry cache hash table entries: 65536 (order: 7, 524288 bytes, linear)
[    0.000000] Inode-cache hash table entries: 32768 (order: 6, 262144 bytes, linear)
[    0.000000] mem auto-init: stack:off, heap alloc:off, heap free:off
[    0.000000] Memory: 494120K/524288K available (8254K kernel code, 896K rwdata, 1440K rodata, 448K init, 302K bss, 30168K reserved, 0K cma-reserved)
[    0.000000] SLUB: HWalign=64, Order=0-3, MinObjects=0, CPUs=2, Nodes=1
[    0.000000] rcu: Hierarchical RCU implementation.
[    0.000000] 	Tracing variant of Tasks RCU enabled.
[    0.000000] rcu: RCU calculated value of scheduler-enlistment delay is 10 jiffies.
[    0.000000] NR_IRQS: 64, nr_irqs: 64, preallocated irqs: 0
[    0.000000] GIC: GICv2 detected, but range too small and irqchip.gicv2_force_probe not set
[    0.000000] random: get_random_bytes called from 0xffffffc010980c4c with crng_init=0
[    0.000000] arch_timer: cp15 timer(s) running at 12.50MHz (phys).
[    0.000000] clocksource: arch_sys_counter: mask: 0xffffffffffffff max_cycles: 0x2e2049cda, max_idle_ns: 440795202628 ns
[    0.000003] sched_clock: 56 bits at 12MHz, resolution 80ns, wraps every 4398046511080ns
[    0.008486] Calibrating delay loop (skipped), value calculated using timer frequency.. 25.00 BogoMIPS (lpj=125000)
[    0.019217] pid_max: default: 32768 minimum: 301
[    0.024074] Mount-cache hash table entries: 1024 (order: 1, 8192 bytes, linear)
[    0.031653] Mountpoint-cache hash table entries: 1024 (order: 1, 8192 bytes, linear)
[    0.040654] rcu: Hierarchical SRCU implementation.
[    0.045745] dyndbg: Ignore empty _ddebug table in a CONFIG_DYNAMIC_DEBUG_CORE build
[    0.053964] smp: Bringing up secondary CPUs ...
[    0.058986] Detected VIPT I-cache on CPU1
[    0.058993] CPU features: SANITY CHECK: Unexpected variation in SYS_CNTFRQ_EL0. Boot CPU: 0x00000000bebc20, CPU1: 0x00000000000000
[    0.059010] CPU features: Unsupported CPU feature variation detected.
[    0.059040] CPU1: Booted secondary processor 0x0000000001 [0x410fd034]
[    0.059106] smp: Brought up 1 node, 2 CPUs
[    0.093090] SMP: Total of 2 processors activated.
[    0.097958] CPU features: detected: 32-bit EL0 Support
[    0.103279] CPU features: detected: CRC32 instructions
[    0.108710] CPU: All CPU(s) started at EL2
[    0.112953] alternatives: patching kernel code
[    0.121023] clocksource: jiffies: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 19112604462750000 ns
[    0.131242] futex hash table entries: 512 (order: 3, 32768 bytes, linear)
[    0.138354] pinctrl core: initialized pinctrl subsystem
[    0.144872] NET: Registered protocol family 16
[    0.149889] DMA: preallocated 128 KiB GFP_KERNEL pool for atomic allocations
[    0.157243] DMA: preallocated 128 KiB GFP_KERNEL|GFP_DMA pool for atomic allocations
[    0.165283] DMA: preallocated 128 KiB GFP_KERNEL|GFP_DMA32 pool for atomic allocations
[    0.173842] thermal_sys: Registered thermal governor 'fair_share'
[    0.173849] thermal_sys: Registered thermal governor 'bang_bang'
[    0.180161] thermal_sys: Registered thermal governor 'step_wise'
[    0.186412] thermal_sys: Registered thermal governor 'user_space'
[    0.192917] ASID allocator initialised with 65536 entries
[    0.205354] pstore: Registered ramoops as persistent store backend
[    0.211790] ramoops: using 0x10000@0x42ff0000, ecc: 0
[    0.246854] cryptd: max_cpu_qlen set to 1000
[    0.253625] SCSI subsystem initialized
[    0.258118] libata version 3.00 loaded.
[    0.262356] usbcore: registered new interface driver usbfs
[    0.268073] usbcore: registered new interface driver hub
[    0.273682] usbcore: registered new device driver usb
[    0.281024] clocksource: Switched to clocksource arch_sys_counter
[    0.287992] NET: Registered protocol family 2
[    0.292666] IP idents hash table entries: 8192 (order: 4, 65536 bytes, linear)
[    0.300704] tcp_listen_portaddr_hash hash table entries: 256 (order: 0, 4096 bytes, linear)
[    0.309401] TCP established hash table entries: 4096 (order: 3, 32768 bytes, linear)
[    0.317451] TCP bind hash table entries: 4096 (order: 4, 65536 bytes, linear)
[    0.324897] TCP: Hash tables configured (established 4096 bind 4096)
[    0.331566] UDP hash table entries: 256 (order: 1, 8192 bytes, linear)
[    0.338335] UDP-Lite hash table entries: 256 (order: 1, 8192 bytes, linear)
[    0.345652] NET: Registered protocol family 1
[    0.350177] PCI: CLS 0 bytes, default 64
[    0.356630] workingset: timestamp_bits=46 max_order=17 bucket_order=0
[    0.365919] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[    0.371994] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
[    0.415088] Block layer SCSI generic (bsg) driver version 0.4 loaded (major 250)
[    0.423282] mtk-tphy 1a0c4000.usb-phy: failed to get ref_clk(id-1)
[    0.435168] mt-pmic-pwrap 10001000.pwrap: unexpected interrupt int=0x1
[    0.456927] Serial: 8250/16550 driver, 16 ports, IRQ sharing enabled
[    0.465638] printk: console [ttyS0] disabled
[    0.490268] 11002000.serial: ttyS0 at MMIO 0x11002000 (irq = 22, base_baud = 1562500) is a ST16650V2
[    0.499767] printk: console [ttyS0] enabled
[    0.508136] printk: bootconsole [uart8250] disabled
[    0.538690] 11004000.serial: ttyS1 at MMIO 0x11004000 (irq = 23, base_baud = 1562500) is a ST16650V2
[    0.548679] 1100c000.serial: ttyS2 at MMIO 0x1100c000 (irq = 27, base_baud = 17499995) is a MediaTek BTIF
[    0.558410] serial serial0: tty port ttyS2 registered
[    0.564233] mtk_rng 1020f000.rng: registered RNG driver
[    0.564417] random: fast init done
[    0.569716] cacheinfo: Unable to detect cache hierarchy for CPU 0
[    0.573047] random: crng init done
[    0.581172] loop: module loaded
[    0.585508] Loading iSCSI transport class v2.0-870.
[    0.592145] mtk-snand 1100d000.snfi: chip is FM35Q1GA, size 128MB, page size 2048, oob size 64
[    0.601139] 4 fixed-partitions partitions found on MTD device 1100d000.snfi
[    0.608101] Creating 4 MTD partitions on "1100d000.snfi":
[    0.613510] 0x000000000000-0x000000080000 : "bl2"
[    0.619116] 0x000000080000-0x0000001c0000 : "fip"
[    0.625475] 0x0000001c0000-0x0000002c0000 : "factory"
[    0.632014] 0x000000300000-0x000008000000 : "ubi"
[    0.794559] mtk_soc_eth 1b100000.ethernet eth0: mediatek frame engine at 0xffffffc011cc0000, irq 37
[    0.805256] i2c /dev entries driver
[    0.809997] mtk-wdt 10212000.watchdog: Watchdog enabled (timeout=31 sec, nowayout=0)
[    0.821520] NET: Registered protocol family 10
[    0.826791] Segment Routing with IPv6
[    0.830495] NET: Registered protocol family 17
[    0.834990] bridge: filtering via arp/ip/ip6tables is no longer available by default. Update your scripts to load br_netfilter if you need this.
[    0.848059] 8021q: 802.1Q VLAN Support v1.8
[    0.853436] pstore: Using crash dump compression: deflate
[    0.868611] mtk-pcie 1a143000.pcie: host bridge /pcie@1a143000 ranges:
[    0.875187] mtk-pcie 1a143000.pcie: Parsing ranges property...
[    0.881035] mtk-pcie 1a143000.pcie:      MEM 0x0020000000..0x0027ffffff -> 0x0020000000
[    0.915572] mtk-pcie 1a143000.pcie: PCI host bridge to bus 0000:00
[    0.921770] pci_bus 0000:00: root bus resource [bus 00-ff]
[    0.927249] pci_bus 0000:00: root bus resource [mem 0x20000000-0x27ffffff]
[    0.934125] pci_bus 0000:00: scanning bus
[    0.938172] pci 0000:00:00.0: [14c3:3258] type 01 class 0x060400
[    0.944203] pci 0000:00:00.0: reg 0x10: [mem 0x00000000-0x1ffffffff 64bit pref]
[    0.953104] pci_bus 0000:00: fixups for bus
[    0.957293] pci 0000:00:00.0: scanning [bus 00-00] behind bridge, pass 0
[    0.963997] pci 0000:00:00.0: bridge configuration invalid ([bus 00-00]), reconfiguring
[    0.972014] pci 0000:00:00.0: scanning [bus 00-00] behind bridge, pass 1
[    0.978839] pci_bus 0000:01: scanning bus
[    0.983073] pci 0000:01:00.0: [14c3:7915] type 00 class 0x000280
[    0.989255] pci 0000:01:00.0: reg 0x10: [mem 0x00000000-0x000fffff 64bit pref]
[    0.996580] pci 0000:01:00.0: reg 0x18: [mem 0x00000000-0x00003fff 64bit pref]
[    1.003906] pci 0000:01:00.0: reg 0x20: [mem 0x00000000-0x00000fff 64bit pref]
[    1.011869] pci 0000:01:00.0: supports D1 D2
[    1.016131] pci 0000:01:00.0: PME# supported from D0 D1 D2 D3hot D3cold
[    1.022763] pci 0000:01:00.0: PME# disabled
[    1.027243] pci 0000:01:00.0: 2.000 Gb/s available PCIe bandwidth, limited by 2.5 GT/s PCIe x1 link at 0000:00:00.0 (capable of 4.000 Gb/s with 5.0 GT/s PCIe x1 link)
[    1.072330] pci_bus 0000:01: fixups for bus
[    1.076518] pci_bus 0000:01: bus scan returning with max=01
[    1.082102] pci_bus 0000:01: busn_res: [bus 01-ff] end is updated to 01
[    1.088713] pci_bus 0000:00: bus scan returning with max=01
[    1.094299] pci 0000:00:00.0: BAR 0: no space for [mem size 0x200000000 64bit pref]
[    1.101951] pci 0000:00:00.0: BAR 0: failed to assign [mem size 0x200000000 64bit pref]
[    1.109946] pci 0000:00:00.0: BAR 8: assigned [mem 0x20000000-0x201fffff]
[    1.116735] pci 0000:01:00.0: BAR 0: assigned [mem 0x20000000-0x200fffff 64bit pref]
[    1.124558] pci 0000:01:00.0: BAR 2: assigned [mem 0x20100000-0x20103fff 64bit pref]
[    1.132384] pci 0000:01:00.0: BAR 4: assigned [mem 0x20104000-0x20104fff 64bit pref]
[    1.140202] pci 0000:00:00.0: PCI bridge to [bus 01]
[    1.145168] pci 0000:00:00.0:   bridge window [mem 0x20000000-0x201fffff]
[    1.152045] pcieport 0000:00:00.0: of_irq_parse_pci: failed with rc=-22
[    1.158651] pcieport 0000:00:00.0: assign IRQ: got 0
[    1.163623] pcieport 0000:00:00.0: enabling device (0000 -> 0002)
[    1.169726] pcieport 0000:00:00.0: enabling bus mastering
[    1.175661] mtk-pcie 1a145000.pcie: host bridge /pcie@1a145000 ranges:
[    1.182214] mtk-pcie 1a145000.pcie: Parsing ranges property...
[    1.188047] mtk-pcie 1a145000.pcie:      MEM 0x0028000000..0x002fffffff -> 0x0028000000
[    1.296242] mtk-pcie 1a145000.pcie: Port1 link down
[    1.301253] mtk-pcie 1a145000.pcie: PCI host bridge to bus 0001:00
[    1.307430] pci_bus 0001:00: root bus resource [bus 00-ff]
[    1.312921] pci_bus 0001:00: root bus resource [mem 0x28000000-0x2fffffff]
[    1.319788] pci_bus 0001:00: scanning bus
[    1.324943] pci_bus 0001:00: fixups for bus
[    1.329120] pci_bus 0001:00: bus scan returning with max=00
[    1.335038] mtk_hsdma 1b007000.dma-controller: Using 3 as missing dma-requests property
[    1.343338] mtk_hsdma 1b007000.dma-controller: MediaTek HSDMA driver registered
[    1.401002] mt7530 mdio-bus:00 lan1 (uninitialized): PHY [mt7530-0:00] driver [MediaTek MT7531 PHY] (irq=145)
[    1.420870] mt7530 mdio-bus:00 lan2 (uninitialized): PHY [mt7530-0:01] driver [MediaTek MT7531 PHY] (irq=146)
[    1.440736] mt7530 mdio-bus:00 lan3 (uninitialized): PHY [mt7530-0:02] driver [MediaTek MT7531 PHY] (irq=147)
[    1.460612] mt7530 mdio-bus:00 lan4 (uninitialized): PHY [mt7530-0:03] driver [MediaTek MT7531 PHY] (irq=148)
[    1.480670] mt7530 mdio-bus:00 wan (uninitialized): PHY [mt7530-0:04] driver [MediaTek MT7531 PHY] (irq=149)
[    1.492426] mt7530 mdio-bus:00: configuring for fixed/2500base-x link mode
[    1.499497] DSA: tree 0 setup
[    1.499677] mt7530 mdio-bus:00: Link is Up - 2.5Gbps/Full - flow control rx/tx
[    1.503270] xhci-mtk 1a0c0000.usb: xHCI Host Controller
[    1.514962] xhci-mtk 1a0c0000.usb: new USB bus registered, assigned bus number 1
[    1.524042] xhci-mtk 1a0c0000.usb: hcc params 0x01403198 hci version 0x96 quirks 0x0000000000210010
[    1.533130] xhci-mtk 1a0c0000.usb: irq 31, io mem 0x1a0c0000
[    1.539256] hub 1-0:1.0: USB hub found
[    1.543048] hub 1-0:1.0: 2 ports detected
[    1.547328] xhci-mtk 1a0c0000.usb: xHCI Host Controller
[    1.552581] xhci-mtk 1a0c0000.usb: new USB bus registered, assigned bus number 2
[    1.559984] xhci-mtk 1a0c0000.usb: Host supports USB 3.0 SuperSpeed
[    1.566303] usb usb2: We don't know the algorithms for LPM for this host, disabling LPM.
[    1.574717] hub 2-0:1.0: USB hub found
[    1.578492] hub 2-0:1.0: 1 port detected
[    1.583515] UBI: auto-attach mtd3
[    1.586843] ubi0: attaching mtd3
[    1.973067] ubi0: scanning is finished
[    1.981192] ubi0: attached mtd3 (name "ubi", size 125 MiB)
[    1.986680] ubi0: PEB size: 131072 bytes (128 KiB), LEB size: 126976 bytes
[    1.993560] ubi0: min./max. I/O unit sizes: 2048/2048, sub-page size 2048
[    2.000338] ubi0: VID header offset: 2048 (aligned 2048), data offset: 4096
[    2.007299] ubi0: good PEBs: 1000, bad PEBs: 0, corrupted PEBs: 0
[    2.013403] ubi0: user volume: 6, internal volumes: 1, max. volumes count: 128
[    2.020616] ubi0: max/mean erase counter: 11/5, WL threshold: 4096, image sequence number: 2079458346
[    2.029831] ubi0: available PEBs: 0, total reserved PEBs: 1000, PEBs reserved for bad PEB handling: 20
[    2.039143] ubi0: background thread "ubi_bgt0d" started, PID 849
[    2.040196] FIT: Default configuration: "config-1" (OpenWrt linksys_e8450-ubi)
[    2.052429] FIT:           kernel sub-image 0x00001000..0x004da00d "kernel-1" (ARM64 OpenWrt Linux-5.10.113) 
[    2.062354] FIT:          flat_dt sub-image 0x004db000..0x004e25b4 "fdt-1" (ARM64 OpenWrt linksys_e8450-ubi device tree blob) 
[    2.073753] FIT:       filesystem sub-image 0x004e3000..0x009c2fff "rootfs-1" (ARM64 OpenWrt linksys_e8450-ubi rootfs) 
[    2.084535] FIT: selecting configured loadable "rootfs-1" to be root filesystem
[    2.091839]  ubiblock0_4: p1(rootfs-1)
[    2.092146] block ubiblock0_4: created from ubi0:4(fit)
[    2.104849] VFS: Mounted root (squashfs filesystem) readonly on device 259:1.
[    2.112220] Freeing unused kernel memory: 448K
[    2.161074] Run /sbin/init as init process
[    2.165162]   with arguments:
[    2.168120]     /sbin/init
[    2.170816]   with environment:
[    2.173960]     HOME=/
[    2.176309]     TERM=linux
[    2.353809] init: Console is alive
[    2.357333] init: - watchdog -
[    2.628026] kmodloader: loading kernel modules from /etc/modules-boot.d/*
[    2.646708] kmodloader: done loading kernel modules from /etc/modules-boot.d/*
[    2.663172] init: - preinit -
[    2.918606] mtk_soc_eth 1b100000.ethernet eth0: configuring for fixed/2500base-x link mode
[    2.927175] mtk_soc_eth 1b100000.ethernet eth0: Link is Up - 2.5Gbps/Full - flow control rx/tx
[    2.936036] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[    2.943063] mt7530 mdio-bus:00 lan1: configuring for phy/gmii link mode
[    2.950179] 8021q: adding VLAN 0 to HW filter on device lan1
[    4.125063] mt7530 mdio-bus:00 lan1: Link is Up - 1Gbps/Full - flow control off
[    4.132415] IPv6: ADDRCONF(NETDEV_CHANGE): lan1: link becomes ready
[    7.007363] UBIFS (ubi0:5): Mounting in unauthenticated mode
[    7.013127] UBIFS (ubi0:5): background thread "ubifs_bgt0_5" started, PID 928
[    7.036486] UBIFS (ubi0:5): recovery needed
[    7.100942] UBIFS (ubi0:5): recovery completed
[    7.105491] UBIFS (ubi0:5): UBIFS: mounted UBI device 0, volume 5, name "rootfs_data"
[    7.113322] UBIFS (ubi0:5): LEB size: 126976 bytes (124 KiB), min./max. I/O unit sizes: 2048 bytes/2048 bytes
[    7.123234] UBIFS (ubi0:5): FS size: 92311552 bytes (88 MiB, 727 LEBs), journal size 4571136 bytes (4 MiB, 36 LEBs)
[    7.133663] UBIFS (ubi0:5): reserved for root: 4360102 bytes (4257 KiB)
[    7.140270] UBIFS (ubi0:5): media format: w5/r0 (latest is w5/r0), UUID 2A3D1BC4-36F9-4EA3-8652-3011B82D5835, small LPT model
[    7.156080] mount_root: switching to ubifs overlay
[    7.163496] overlayfs: "xino" feature enabled using 2 upper inode bits.
[    7.173472] urandom-seed: Seeding with /etc/urandom.seed
[    7.316807] mt7530 mdio-bus:00 lan1: Link is Down
[    7.327047] procd: - early -
[    7.330008] procd: - watchdog -
[    7.879634] procd: - watchdog -
[    7.883807] procd: - ubus -
[    7.938341] procd: - init -
[    8.166853] urngd: v1.0.2 started.
[    8.224666] kmodloader: loading kernel modules from /etc/modules.d/*
[    8.241593] Loading modules backported from Linux version v5.15.33-0-g06f50ca83ace
[    8.249167] Backport generated by backports.git v5.15.33-1-0-g183c4ab2
[    8.315181] ieee80211 phy0: Selected rate control algorithm 'minstrel_ht'
[    8.326531] mt7915e 0000:01:00.0: assign IRQ: got 150
[    8.331683] pci 0000:00:00.0: enabling bus mastering
[    8.336664] mt7915e 0000:01:00.0: enabling device (0000 -> 0002)
[    8.342782] mt7915e 0000:01:00.0: enabling bus mastering
[    8.392510] mt7622-wmac 18000000.wmac: HW/SW Version: 0x8a108a10, Build Time: 20190801210006a
[    8.392510] 
[    8.411968] mt7915e 0000:01:00.0: HW/SW Version: 0x8a108a10, Build Time: 20201105222230a
[    8.411968] 
[    8.501269] mt7622-wmac 18000000.wmac: N9 Firmware Version: 2.0, Build Time: 20200131180931
[    8.599700] mt7915e 0000:01:00.0: WM Firmware Version: ____000000, Build Time: 20201105222304
[    8.659663] mt7915e 0000:01:00.0: WA Firmware Version: DEV_000000, Build Time: 20201105222323
[    8.799398] PPP generic driver version 2.4.2
[    8.805409] NET: Registered protocol family 24
[    8.816356] kmodloader: done loading kernel modules from /etc/modules.d/*
[   11.648102] mtk_soc_eth 1b100000.ethernet eth0: Link is Down
[   11.657915] mtk_soc_eth 1b100000.ethernet eth0: configuring for fixed/2500base-x link mode
[   11.666626] mtk_soc_eth 1b100000.ethernet eth0: Link is Up - 2.5Gbps/Full - flow control rx/tx
[   11.675365] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[   11.684064] mt7530 mdio-bus:00 lan1: configuring for phy/gmii link mode
[   11.692180] 8021q: adding VLAN 0 to HW filter on device lan1
[   11.701165] br-lan: port 1(lan1) entered blocking state
[   11.706397] br-lan: port 1(lan1) entered disabled state
[   11.712428] device lan1 entered promiscuous mode
[   11.717050] device eth0 entered promiscuous mode
[   11.730127] mt7530 mdio-bus:00 lan2: configuring for phy/gmii link mode
[   11.737419] 8021q: adding VLAN 0 to HW filter on device lan2
[   11.747903] mt7530 mdio-bus:00 lan2: Link is Up - 1Gbps/Full - flow control rx/tx
[   11.758253] br-lan: port 2(lan2) entered blocking state
[   11.763549] br-lan: port 2(lan2) entered disabled state
[   11.769553] device lan2 entered promiscuous mode
[   11.776733] br-lan: port 2(lan2) entered blocking state
[   11.781988] br-lan: port 2(lan2) entered forwarding state
[   11.787543] IPv6: ADDRCONF(NETDEV_CHANGE): br-lan: link becomes ready
[   11.799737] mt7530 mdio-bus:00 lan3: configuring for phy/gmii link mode
[   11.807144] 8021q: adding VLAN 0 to HW filter on device lan3
[   11.817996] br-lan: port 3(lan3) entered blocking state
[   11.823409] br-lan: port 3(lan3) entered disabled state
[   11.830262] device lan3 entered promiscuous mode
[   11.840773] mt7530 mdio-bus:00 lan4: configuring for phy/gmii link mode
[   11.849744] 8021q: adding VLAN 0 to HW filter on device lan4
[   11.852680] mt7530 mdio-bus:00 lan4: Link is Up - 100Mbps/Half - flow control off
[   11.859478] br-lan: port 4(lan4) entered blocking state
[   11.868166] br-lan: port 4(lan4) entered disabled state
[   11.876476] device lan4 entered promiscuous mode
[   11.886174] br-lan: port 4(lan4) entered blocking state
[   11.891445] br-lan: port 4(lan4) entered forwarding state
[   13.080267] br-lan: port 5(wlan0) entered blocking state
[   13.085658] br-lan: port 5(wlan0) entered disabled state
[   13.091243] device wlan0 entered promiscuous mode
[   13.096079] br-lan: port 5(wlan0) entered blocking state
[   13.101436] br-lan: port 5(wlan0) entered forwarding state
[   14.208832] mt7530 mdio-bus:00 lan1: Link is Up - 1Gbps/Full - flow control off
[   14.436092] br-lan: port 6(wlan1) entered blocking state
[   14.441485] br-lan: port 6(wlan1) entered disabled state
[   14.446999] device wlan1 entered promiscuous mode
[   14.451887] br-lan: port 6(wlan1) entered blocking state
[   14.457212] br-lan: port 6(wlan1) entered forwarding state
[   14.462979] br-lan: port 5(wlan0) entered disabled state
[   14.468481] br-lan: port 1(lan1) entered blocking state
[   14.473805] br-lan: port 1(lan1) entered forwarding state
[   14.479616] br-lan: port 6(wlan1) entered disabled state
[   18.910811] IPv6: ADDRCONF(NETDEV_CHANGE): wlan1: link becomes ready
[   18.917313] br-lan: port 6(wlan1) entered blocking state
[   18.922646] br-lan: port 6(wlan1) entered forwarding state
[   19.044403] br-lan: port 7(wlan1-1) entered blocking state
[   19.049951] br-lan: port 7(wlan1-1) entered disabled state
[   19.055738] device wlan1-1 entered promiscuous mode
[   19.064618] br-lan: port 7(wlan1-1) entered blocking state
[   19.070130] br-lan: port 7(wlan1-1) entered forwarding state
[   19.142690] IPv6: ADDRCONF(NETDEV_CHANGE): wlan1-1: link becomes ready
[   19.323213] IPv6: ADDRCONF(NETDEV_CHANGE): wlan1-2: link becomes ready
[   19.403191] br-lan: port 8(wlan1-3) entered blocking state
[   19.408687] br-lan: port 8(wlan1-3) entered disabled state
[   19.414464] device wlan1-3 entered promiscuous mode
[   19.422465] br-lan: port 8(wlan1-3) entered blocking state
[   19.427968] br-lan: port 8(wlan1-3) entered forwarding state
[   19.482702] IPv6: ADDRCONF(NETDEV_CHANGE): wlan1-3: link becomes ready
[   19.563879] br-lan: port 9(wlan1-4) entered blocking state
[   19.569380] br-lan: port 9(wlan1-4) entered disabled state
[   19.575159] device wlan1-4 entered promiscuous mode
[   19.583319] br-lan: port 9(wlan1-4) entered blocking state
[   19.588839] br-lan: port 9(wlan1-4) entered forwarding state
[   19.616723] IPv6: ADDRCONF(NETDEV_CHANGE): wlan1-4: link becomes ready
[   19.714047] br-lan: port 10(wlan1-5) entered blocking state
[   19.719664] br-lan: port 10(wlan1-5) entered disabled state
[   19.725580] device wlan1-5 entered promiscuous mode
[   19.732806] br-lan: port 10(wlan1-5) entered blocking state
[   19.738390] br-lan: port 10(wlan1-5) entered forwarding state
[   19.766042] IPv6: ADDRCONF(NETDEV_CHANGE): wlan1-5: link becomes ready
[   22.584049] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[   22.590539] br-lan: port 5(wlan0) entered blocking state
[   22.595928] br-lan: port 5(wlan0) entered forwarding state

You cannot create two separate bridge devices using the same ports.
/etc/config/network should look like this:

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd4c:c9ec:2f25::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'

config bridge-vlan
        option device 'br-lan'
        option vlan '1'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'
		
config bridge-vlan
        option device 'br-lan'
        option vlan '20'
        list ports 'lan1:t'

config interface 'lan'
        option device 'br-lan.1'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.11.3'
        option gateway '192.168.11.1'
        list dns '192.168.11.10'

config interface 'guest'
        option device 'br-lan.20'
        option proto 'static'
        option ipaddr '192.168.30.3'
        option netmask '255.255.255.0'
        option gateway '192.168.30.1'
        option metric '10'
2 Likes

HI @pavelgl - thanks for that important information. I wasn't sure if I could connect a second bridge, now I know I cannot. The device now works and I can connect to the internet.

The only thing which does not work is obtaining an IP address though DHCP. When I set a manual IP, it's fine. I am not sure as of now if this is related to openWRT or OPNsense, where I have firewall rules created. Using another machine directly connected to a switch though the same VLAN, DHCP works. What could be the reason for this? I have created a new topic for this.

Thank you!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.