Please help, I've messed up (revert Archer C6 V2 to TP-link firmware)


I installed openwrt to my Archer C6 router V2 (i'm in the UK, so I assume it's the EU version), because I thought it would let me use a higher channel number (so as not to conflict with other 5ghz wifi signals).

Although it let me select other channels above 48....they didn't work, as the wifi was "not associated" when I chose anything above 48.

SO I thought I may as well just flash back the original TP-LINK firmware.....but this has messed up the router and now it doesn't boot into either openwrt or the power light comes on, but that's it.

I've tried updating using a tftp sever, and eventually got it to bring up messages in the log, and then I can see a file transfer take place (although this is literally only a fraction of a second?), but then nothing happens after that. I read that the router should reboot itself after a couple of monutes.....but it doesn't seem to be doing anything, and if I manually poer cycle, it still doesn't boot into either firmware.

Does anyone have any clue how I can fix this, either to (preferably) put the original TP LINK software back on to it, or even just to have a working router again with the openwrt version?

1 Like

I hope this could help.

1 Like

thank you, when i get home later, i'll try an older version of the tplink software as suggested

1 Like

In situations like this if you can put a serial connection in place it will help you see what is happening. If you have an Arduino with USB connection to hand you can often get a "good enough" connection using one of these methods (there a re three different ones, no need to do all three things):

I say "good enough" because grounds and voltages can be a bit different leading to garbled patches of output and / or inability to type things back to the router, but I've always been able to see enough of what was happening to help me move forwards.

Transferring a ~8MB file over a 100Mb link is around a second, and will be even faster on a 1Gb link. If the TFTP server shows successful transfer then a long power down followed by a hard reset (see original manual) should bring things back to life. This one of the stages where a serial port is handy.


1 Like

Unfortunately I don't have any of that kit. I'm definitely out of my depth with this stuff and probably shouldn't have messed with it.

Ive just tried with the older firmware, but it's the same thing....tftpd64 shows that the file is transferred 100%, but then nothing happens no matter how long I leave it.

Anything else I can try, on a consumer level, or is the unit basically bricked?

1 Like

Try to upload an OpenWrt image over tftp. If you succeed, for sure it will be better than a brick...

1 Like

Tried with the latest openwrt file too.... same thing happens.... it transfers the file, but then nothing happens after that. It's the same file that I used to switch to openwrt to begin with, so it did work before (although I updated that with the tp link firmware update section of their router management page).

It feels like the router knows it is looking for a file, so it downloads it, but then doesn't know what to do with it after that.... after the transfer, nothing happens on the c6..... no lights flash, no reboot, just nothing.

1 Like

Only light I have is power light.

At "boot" all the lights come on for about half a second, then it's just the power light.

When I hold the reset button at boot, wps light comes on after a few seconds and stays on for a few seconds, the file then transfers a few seconds after that, which takes less than a second. Then it's just the power light. Nothing reboots, nothing flashes to show that it's doing anything.

1 Like

Sometimes it can take a few attempts. Perchance it's loaded but missing LuCI?

That is good, the bootloader is working but it's rejecting the firmware that was uploaded. This is often due to a mismatch of the country code. The original firmware (before you rename it recovery.bin) file name should have the same two-letter country code (EU, US, RU, etc) that matches the label on the bottom.

Of course TP-Link distributions are zips, unzip the firmware to get the raw bin file before trying to upload it.

1 Like

@mk24 Oh yeah it was the same with the C7. I got one C7 v2 EU version (but didn't know it) and the US firmware did not work on first attempt. Reattempt with EU firmware worked.

The router is EU version, confirmed by the label on the bottom. Firmware is also EU version.

Just watched another YouTube tutorial and they said to run something called wireshark.... that does seem to show a bunch of stuff happening that I don't understand. But the video also says that the lights on the router should be flashing..... but they don't on mine..... also, even after like 5-10 minutes....wireshark is still showing a bunch of stuff going on? Nothing happening on the router lights though.

How could I remedy this missing LuCi?

It's like burning a CD/DVD just keep trying.

ssh root@ ain't happening?

Sometimes after flashing I will reboot , on/off or factory reset to try to reinitialize if it won't connect via LuCI/ssh.

But why aren't any of the lights flashing to say that something is happening?

Sorry, I didn't understand that :s

If itype (or into a browser, it either times out or says it's unreachable.

Can you ssh in?

How do I do that?

On windows it's called PUTTY. Or on UBUNTU it's ctl-alt-t.

Thank you. I'll take a look in a moment.