Ping Watchcat/dog on OpenWrt from

I have a LTE router from with a Quectel mobilemodem. It is installed on a ship. When i sail out of LTE range and loose connection i do need to reboot when coming back in range. I did hope it did go to search mode and connected again when signals are ok.

In luci there is under services "WAN WATCHDOG" with this config:

config watchdog 'global'
	option enable '1'
	option network 'MOBILE'
	list track_ip ''
	option mode 'ifup'

I can choose if i want to restart mobile modem, or reboot if internet drops.
Sometimes the ship is out of LTE signals for days/weeks. Have tested the restart mobile modem option, but no sucsess. Looks like the modem do freeze after some restarts, and i need to reboot router to connect.

I suppose if i choose reboot , the router vil reboo MANY times if im out of signals for weeks. In my head this option is not good for my hardware?

I am not sure what the diffrence of watchdog and cat, but have downloaded the watchcat and looking at the config.

Forced reboot delay
What is diffrent between soft reboot and hard reboot? Looks like i can set a time delay for soft reboot to fail before an hard reboot ?

Period: defines the longest period of time without internet access before a reboot is engaged? What should this period be?

Ping Period: How often to check internet connection, i would say every second hour.

I do have satelite connection backup with mwan3, but will not go over to LTE before lte router is rebooted when in coveraged area again.

What should forced boot delay and period to avoid it just bootloop day and night when out of range ?

Reboot won't harm the system, what usually harms the system is excessive writing on the flash.

Reboot gracefully vs. kill'em all.

As long as you think the system should stay without successful pings before taking an action.

Maybe 5 minutes? 2 hours sounds too long to me.

It sounds like you need to find a way to restart the modem (service modemmanager restart maybe) rather than rebooting the whole router.

Thank you for information!
Just tried this service modemmanager command. It says available commands restart, but uci entry not found?

root@OutdoorRouter:~# service modemmanager
Syntax: /etc/init.d/modemmanager [command]

Available commands:
        start   Start the service
        stop    Stop the service
        restart Restart the service
        reload  Reload configuration files (or restart if service does not implement reload)
        enable  Enable service autostart
        disable Disable service autostart

root@OutdoorRouter:~# service modemmanager restart
uci: Entry not found

Is modemmanager installed? What is the version of the router? ubus call system board

root@OutdoorRouter:~# ubus call system board
        "kernel": "4.9.152",
        "hostname": "OutdoorRouter",
        "system": "Qualcomm Atheros QCA9531 ver 2 rev 0",
        "model": "Outdoor MIMO 4G Router",
        "board_name": "ap147-010",
        "release": {
                "distribution": "EZR33",
                "version": "EV3132",
                "revision": "r7676-cddd7b4c77",
                "target": "ar71xx\/generic",
                "description": "EV3132"

I found several people on forums with problem reconnecting modems without reboot device.

One mentioned usb reset and i found this:

echo "usb1"> /sys/bus/usb/drivers/usb/unbind
echo "usb1"> /sys/bus/usb/drivers/usb/bind

As what i can see from luci status page it looks like it takes down the 4g modem. Info about modem disapears. When i bind, info about modem comes back. I am not at 4g range before tomorrow, but hopefully this command shuts down and up the usb ? I will test test it tomorrow when in range and see if it will connect or if i need to reboot.


Looks like this command just "ejects" the usb. Dont know if that is enough.
Here is my gpio.

The script in link over is just what i am looking for but i dont know how to edit it for my router. :neutral_face:

root@OutdoorRouter:~# cat /sys/kernel/debug/gpio
gpiochip0: GPIOs 0-31, parent: platform/ath79-gpio, ath79-gpio:
 gpio-1   (                    |ap147:sim           ) out lo
 gpio-4   (                    |ap147:green:lan1    ) out lo
 gpio-12  (                    |ap147:green:wlan-2g ) out hi
 gpio-13  (                    |ap147:green:status  ) out lo
 gpio-14  (                    |ap147:green:sim1    ) out lo
 gpio-15  (                    |ap147:green:sim2    ) out hi
 gpio-16  (                    |ap147:green:wan     ) out hi
 gpio-17  (                    |reset               ) in  hi

gpiochip1: GPIOs 494-511, ath9k-phy0:
 gpio-495 (                    |ath9k-phy0          ) in  lo

It appears you are using firmware that is not from the official OpenWrt project.

When using forks/offshoots/vendor-specific builds that are "based on OpenWrt", there may be many differences compared to the official versions (hosted by Some of these customizations may fundamentally change the way that OpenWrt works. You might need help from people with specific/specialized knowledge about the firmware you are using, so it is possible that advice you get here may not be useful.

You may find that the best options are:

  1. Install an official version of OpenWrt, if your device is supported (see
  2. Ask for help from the maintainer(s) or user community of the specific firmware that you are using.
  3. Provide the source code for the firmware so that users on this forum can understand how your firmware works (OpenWrt forum users are volunteers, so somebody might look at the code if they have time and are interested in your issue).

If you believe that this specific issue is common to generic/official OpenWrt and/or the maintainers of your build have indicated as such, please feel free to clarify.

Thank you!
You are probably right that this is vendor specific build that are based on openwrt.
I will try contact dealer and check if it is possible to get support from them.