Pi remembers my mistakes

I am trying to use my pi4 b as a travel router and I have corrupted something:

If I flash the SD card it still 'remembers' my messed up configuration. If I use a new card it allows new configurations but 'remembers' the network names.

I need to delete the messed up configs. I have repartitioned them, reformatted them but the pi is storing the information somewhere other than the cards.

Could really use some insight on how to delete interfaces that do not show up in LuCi.

What configuration in particular? Are you able to grab evidence of the configuration in question and post it here?

That wording triggered a vague memory, which prompted me to search.

This might be interesting, relevant, and/or helpful:

I can't.

I'm trying to config an Alfa AWUS036NH as the Wan side and use the internal WiFi as the AP. I'm configuring it all through the ethernet port @ I can get the internal wifi to connect and even download packages and drivers for the Alfa.
I can get it to work until I turn it off and then the ethernet port no longer responds to 192,168.1.1.

I can see the Pi broadcasting its SSID, even after reboots, but as soon as I turn it off it no longer broadcasts its SSID but it does connect to the home router (I can see it on the client list).

Then, after re-flashing on the SSD card the same firmware the Ethernet is still no longer accepting I cannot even SSH into it.

It did this with 2 cards. I'd get them configured and repower and they are gone. But if I use a card that has had no openWRT on it, works just fine.

Then grab the configuration files right at the very last second, after you make all your changes, and before turning it off, while you still have access to the device. Or, since you have access to an SD card reader, grab your modified configuration from the micro SD card using the computer you used to put OpenWRT onto the SD card in the first place.

My hunch is that you're configuring something which is changing the Ethernet interface's IP address (possibly turning it from LAN to WAN, or maybe something else?)

If that is in fact the case, then it shouldn't be too hard to identify what additional changes to make to your configuration to preserve access to the device after you finish configuring it.

Edit: the files to grab are:


Redact any passwords/keys in those files, but leave the rest of the configuration intact.

On the first try I named the Alfa 'Alfa' (so I could avoid getting confused.
On the second try/card I left the eth0 as a static address but no longer in bridge mode. I tried to, again, change the name to 'Alfa' but it said that name was already in use; I had to use 'Alfa2'.

On the 3rd card it did the same thing, even though that card had never had anything named to it; both 'Alfa' and 'Alfa2' were already in use.

That is when I started this topic...

What is the "it" which is saying this?


If I ipconfig through ssh only the ethernet and the radio show up.

If I attach a monitor (after everything gets corrupted) to the Pi I get a command prompt but commands like ipconfig are not recognized and I cannot find the command that works like it (I've looked around).

I would think there would be a command to delete the configurations that are saved somewhere but I am sure they are not on the sd cards.

like I said earlier: I have deleted partitions, and formatted both of them.

It wouldn't be. ipconfig is a Windows command. The Linux equivalent (and OpenWRT is based on Linux) is ifconfig or even ip addr.

Still, none of this helps get to the root of your problem.

Please do as I suggested above and grab copies of those configuration files after you make all your changes and before you switch the device off.

1 Like

...then you can take photographs of whatever is on the screen.

1 Like

Thanks and I will...

I need to go to work so it will be later today.

Thanks again.

So do I. This place is too much of a distraction...


The RPi is reading everything from the SD card.
That being said, one thing you need to check is that the SD card is properly erased when you switch from one version to another. The leftovers can also be browser cache. Clear cache, use private mode, or use another browser to eliminate that.


This has been a long-standing issue with the Pi where overlay isn’t erased when flashing. I used to run firstboot after flashing and then reboot to get a clean install.


firstboot ->reboot worked.

Thank you and all of you for your help!

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.