Philips HUE Hub disconnects every boot


I tried to troubleshoot this for a long time without success.

Every time I reboot my router, my philips HUE HUB gets disconnected. The only way to fix, is to go there and manually re-plug network cable.
I tried restart network, firewall, dnsmasq after boot. Nothing.

Any ideas where I should look for?

A cabled device should not "disconnect" from the network. Perhaps it just disappears from the DNS server?

I checked logread and dnsmasq doesn't show any DHCPDISCOVER for hub.
Maybe hub is not requesting dhcp?

A device doesn't request DHCP unless the lease is expiring or (in some cases) the cable has been re-plugged.

So when you reboot the router, the DNS server can no longer look up LAN names because the DHCP client list (in RAM) was erased. The hub does not know this. It continues to operate with its previous address. You should be able to access it by IP number though not by name.

Using short DHCP lease times would make the recovery faster, though rebooting should be infrequent anyway.

1 Like

I usually use about 30 mins for a lease time, I figure even with maybe a hundred devices this is still one renewal every 9 seconds... Trivial. I'd be more concerned if there were say 10000 devices and you had a renewal every 100ms. But you'd probably split your network into subnets anyway.

1 Like

I"m not sure what is the cause of problem, but try to run the following in terminal:

ip link set $interface down
ip link set $interface up


ifconfig $interface down
ifconfig $interface up

replace $interface with interface name that's connected to your hub, ex: "eth0.2"

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.