Phicomm K3 thoughts

I've recently purchased a phicomm k3 from ebay (waiting for the shipment) to replace my d-link dir-860l, which I've been rocking for two years with lede/openwrt without any issues.

Does anyone know what is the status of the phicomm k3 with openwrt? I saw there are some official builds but no meaningful topics/comments here in the forum. Any happy owners out here?

Happy holidays!

Phicomm K3 A1 has snapshot support.

https://openwrt.org/toh/hwdata/phicomm/phicomm_k3_a1
https://openwrt.org/toh/phicomm/phicomm_k3_a1 (this page needs someone to enter usefull information like installation instructions, bootlogs and other stuff)

Sparse installation instructions: https://git.openwrt.org/?p=openwrt/openwrt.git;a=commit;h=62dadcb86c6e6f80ce6fbcd89befc3cc22c2176a

I had a K3 as well, however it's the B1 version. B1 and A1 has the same hardware, but the pre-installed firmware maybe different. I manually soldered serial connection for easier debugging, you can using CFE to install OpenWRT firmware.

The biggest issue with K3 using OpenWRT is the buggy wireless drivers - common for Broadcom-based devices.

As for now, I'm using https://downloads.openwrt.org/releases/19.07.1/targets/bcm53xx/generic/openwrt-19.07.1-bcm53xx-phicomm-k3-squashfs.trx as it now has stable releases (along with packages repository), and I'm generally happy with it - except for the wireless.

I can't get it to respond to anything, i tried the tricks with holding the reset and two serial cables without any luck (do you have to connect voltage or only tx, rx, ground). Please share your procedure for the serial connection. Thanks!

For the wifi people seem to be happy when using another firmware. See last comment here - https://www.snbforums.com/threads/phicomm-k3-not-k3c-discussion.49109/

For the wifi people seem to be happy when using another firmware

I think they are saying the original firmware has the best wifi.

For serial Vcc is not needed (rx/tx/gnd is needed), bitrate is 115200. Try switch tx and rx if you can see nothing after powering on.

Anyway, I will update the OpenWRT wiki for K3 B1 version sometime...

Thanks, do you have to hold reset or press any key (ctrl+c) to get anything in the terminal ?

get anything in the terminal

There should be meaningful output as soon as you powered on if your serial connection is correct.

Holding reset or press ctrl+c is only needed if you would like to switch to CFE's 'debug' mode (i.e. interrupt standard boot procedure).

I also own Phicomm K3 B1 and I'm thinking about installing OpenWrt on it. Is the wireless still not very good? Can the installation be done through the web page (as described for A1) or is a serial port connection needed? Has anyone managed to revert to the original software?

@CptTZ Is there a chance you could update the wiki with B1 information?

Just wanted to put some update here:

  • For debricking I soldiered a spi flash which i programmed and flashed with cfe and booted from it, then I flashed openwrt via TTL on the normal memory.
  • While I put the latest binary firmware from ASUS RT-AC88U the wifi is still highly unstable and in general can not set channels etc. Something is wrong there.
  • I was hoping to put a luks encrypted drive via the usb port but after doing some cryptsetup benchmark the results aren't what i expected (around 30mb/sec, was hoping for 60). It turns out this CPU doesn't have any crypto engine or aes acceleration (at least from what i found)
  • In general I'll play a bit more with it, but I might sell it as I'm not getting anything major from this device (well if 160ghz works nicely it will be cool)

Another updated:
Installed Asus Merlin on it from right.com.cn with the help of @RavenChan for getting the files (thanks, man).
Used it for work the whole day without any issues, tried iperf3 between wired and wireless computer but the results were awful, strangely enough when transferring file between those two computers i get 40+ MB/sec through couple of walls, so not bad. However not sure I trust this Chinese made FW, looks good, quite popular, but still. Also not sure on the Merlin stuff as well, I'm missing some freedoms, currently trying to install entware to see what packages are there.

1 Like

160mhz works nicely with openwrt and latest firmware. I'm getting 1.5x real throughput increase when switching to 160mhz. There is a workaround for regulatory limit on total power for 160mhz channels too which helps with range but this limit is not a router-specific issue.

I couldn't test 160MHz properly both on openwrt and merlin, I suspect it is my cards (intel 9260) fault as it only has one antenna installed (this is how the laptop was initially setuped with crappy realtek ac wifi). I have ordered new antennas (with the smaller connector) but haven't installed them yet (also won't be able to put them in the monitor so will be sub-optimal).

Anyway decided to test merlin, which in general is polished (easy to setup openvpn, dns filtering, guest network etc) but quite limited for anything outside of the already installed stuff. Installed entware yestarday as I wanted to do cryptsetup benchmark, however it lacks the crypto kernel modules (also massively old kernel 2.something), so that is useless for me, however openssl speed performs pretty much the same (a bit faster) around 30mb/sec for aes 256 so there isn't any magical hardware engine which is with asus fw.

Probably going to go back to openwrt and see why it isn't working. Basically i do a clean install, replace the brcmfmac4366c-pcie.bin with the one from march (also tried everysingle other i can get my hands) , reboot and try to change channels. I tried setting the country to DE, US, GB, China etc. Initially the power is set to 31 and i tried lowering it to 20, 17 etc. When i change the channels like the one for N to 13 (enabled for DE,GB) or some else, the wifi get disconnected and have to reboot (sometimes there are errors about can not scan, can not set channel etc in dmesg, but not always). Same for AC, i tried 100 and doesn't want to, was able 149 or something for china.

I'm thinking it is something country related but everything seems ok iw list shows the channels (20db for power as far as i remember, somewhere it was 24), iw get puts the right stuff as well.

Not sure what is wrong, maybe difference between A1 and B1 (which i have)

Thanks all for the help!