People asked about TL-WA7210N but nobody told them that the firmware is useless

i have seen all forums about this damn Router, everywhere everybody talks about the lack of internal antenna support in lede, openWRT or DD-wrt, but nobody and i repeat nobody, has dropped a line to tell us that the external antenna is not working either, its frustrating, you say say that this router is supporte!!!BUT HOW??? NO ANTENNA IS WORKING WITH LEDE! WHAT KIND OS SUPPORT IS THIS? IF I CANNOT USE THE ANTENNA OF A LONG RANGE AP, WHAT THE HELL IS THE NEED TO HAVE FIRMWARE HERE ??? WITHOUT ANY DAMN EXPLANATION "THE STUPID ANTENNAS ARE NOT SUPPORTED DONT FLASH IT"!!!! ON THE ROUTER PAGE OF LEDE!!! REALLY FRUSTRATING!

I have a 7510 v2 (5 GHz version of the 7210) but haven't looked at how to activate the external antenna. It is probably just a GPIO controlling the RF switch.
Overall that TP-LINK box is fully disappointing with its 4+32 memory, 1x1 MIMO, and maximum power of 17 dBm. The Ubiquiti NanoStation loco is superior in all respects except no antenna connector and they are locking the software.

The problem is that nobody is telling us not to flash it because will end with a non working AP, have a look at the support page! nowhere is been written that the antennas are not supported, or at least a workaround how to fix it!!!! not even how to revert back or a file to do it! I have got an 24dbi antenna, and with the prehistoric factory firmware i had 100% signal but with low quality connection , i wanted something better but i end up with a box without antennas, thats make me mad, and also the reason that this box is far from here and its way too difficult to go there and fix it!! i could have avoided that if someone had written at the router support page that the antennas are not working woith lede, same as they are writing in many routers that the 5Ghz chip is not supported!!!

People that "work" here are volunteers that have other commitments, so their time is limited.

There is always a risk when you flash a device with 3rd party firmware. For example...DD-WRT, OpenWRT, and LEDE (current firmware) all worked for me. Gargoyle did not.

You should create a safety net "before" flashing, so that you know how to get back to stock. That is not the responsibility of the community.

There is a stripped version of the TP-Link firmware to revert back to stock...

http://www.friedzombie.com/tplink-stripped-firmware/

the problem is that there are many guys in the forums around the net that asking if this Router is working, but nowhere and nobody mentions that the antennas are not working at all, only about internal antennas there is a warning!!!! nobody blames the devs ,but it should have been a warning about it!! check the products page, there is nowhere writing about non working antennas!! i can flash it back, but its a pain in the ass to go get it from the mountain and flash it and get it back there!!

And by the way, the images are for lede or for ddwrt, because as i remember what reverts one bricks the other! and vice versa! its good for scp - ssh or needs tftp?

I don't get why anyone should have "warned" you.

Firmware can't be tested for every possible deployment situation.

Probably should have tested everything before putting it on the mountain.

Take the bull by the horns and update the comments line on this page and add a link to this or the other post re the antenna.
https://lede-project.org/toh/hwdata/tp-link/tp-link_tl-wa7210n_v2

1 Like

I guess you really did not read that page because if you did you would have known there was a problem. manly due to low flash/ram.

Stop yelling like a little child

should

 

4MB devices can't fit anything noteworthy unless you use the Image Generator (Image Builder) (that requires a Linux system and some mild experience) or use Extroot. Experienced users deploying specific or custom builds may not be affected by these restrictions; novices however will likely waste hours only to see that their expectations of an extensible operating system which LEDE claims to be can not be met by their device.

i read it, doesnt mean that 4MB devices have no amtenna support, i think you can understand it! i have many 4mb devices for everyday tasks and not even one of them have problems with the antenna, 4MB means have no packages support, which means no extras, antenna support is not extra, its a basic feature! And by the way, take a life and stop be ironic, if someone is asking for advices and nobody telling the truth what the hell you think will happen, 5 forums about this damn router and nowhere noone has mentioned that the antennas are not working with custom firmwares,This is not a home device which you will take from the table put the cable and flash it, its an outdoor long range device, most of them are in difficult to be reached areas, like mine, Now put the finger out of your mouth and become usefull human!!!

If nobody mentioned this in the past, how should we have known?
Anyways, I updated the dataentry accordingly now.

1 Like

thank you, i thought that so many who haved tried it would have given back a feedback, so nobody will do the same mistake, i dont blame the devs have noi intention to do it, i am just furious because i have read of many people tried it but nobody has given a simnple feedback! Guys we are a community, a problem must be sharing with everybody!

I've done a little probing on my TL-WR7510. (7210 may be very similar, or completely different, I don't have one.) The device has two RF switch chips. The first chip serves as an antenna selector and T-R switch in the conventional way. Output 1 of this switch is connected to the vertically polarized internal antenna. If you use a default setup (i.e. don't specify an antenna in the wifi-device section of /etc/config/wireless), it should operate with the vertical internal antenna.

If antenna 2 is selected (option txantenna 2 and option rxantenna 2), the signal goes to the second RF switch chip. This chip is controlled by a GPIO on the radio chip, which is known to the kernel as GPIO507. If the GPIO is low or in input mode (the default) you should get the external antenna. If the GPIO is high you should get the internal horizontally polarized antenna for antenna 2.

To operate the GPIO driver from the command line the following commands can be used:

echo 507 > /sys/class/gpio/export
echo out > /sys/class/gpio/gpio507/direction
echo 1 > /sys/class/gpio/gpio507/value

or of course send 0 to value to set the pin low.

So in summary, how it seems it should operate:
Driver 'antenna' | GPIO507 | Antenna in use
1 X Internal (vertical)
2 1 Internal (horizontal)
2 0 (or input mode) External

I say should because my signal testing trying to confirm all this was inconclusive.

May I say that your OP is pretty rude? People at LEDE are spending their free time so people like you can use LEDE for free. So I must say that using all these caps is rude and asocial behavior.

Not everyone use WiFI on their targets. Some just use their devices as a small embedded processing platform. Sure this is not the case for a 150Mb/s outdoor AP. But having the initial support for a device could also lead to other maintainers finishing the support for a target. And there is always a risk for a device to break after a flash because some commit not specifically targeting that target could have damaged the support in any way.

1 Like

not talking about the devs, its clear, talking about community which is not sharing the problems, there are plenty of forums about this Router but noone has mentioned the bugs he found, can you get it? even the Router page was empty!

1 Like

Then please add it yourself, you are part of the community as well. Seems that no one bothered to do so or don't care for not having WiFI. So someone has to be the first.

I installed the LEDE 17.01.4 on my WA7210N
*The system works normally
*The external antenna is working to route the wifi signal.
*The Internal antenna has a sensitivity problem and receives only very close wifi networks.
*The reset button apparently does not reset all WA7210N settings. Because I accidentally deleted the LAN connection and now I have a white box with no function whatsoever. I have to buy a USB-SERIAL CP2102 adapter to try to reinstall the original software and reuse my Antenna (this function to delete the LAN connection should not exist)

Thanks for the polite request...

The "reset" button under OpenWRT typically puts the device into "failsafe" mode when pressed at the right moment in the boot cycle.

Typically, during the early boot phase (after the boot loader), the power light will flash a couple times a second for two or three seconds. If you press the "reset" button (or, in some cases, the "WPS" button) in that time window, the device will enter failsafe mode. This is generally indicated by the power light flashing even faster.

I read about this function, but unfortunately the WA7210N is an antenna that does not have the WPS button. It only has a reset button and a LAN port. Then there is no way to enter the failsafe mode, even if you hold the reset button for more than 10 seconds the antenna only restarts and does not give any more signals like flashing LEDs.
On opening it I saw that there is a 4 pin connection to use the CP2102 and this I believe will be my only attempt to make it work again.

The work with the LEDE is going well and I'm sure it will reach full operation.

Some of the older instructions for entering failsafe mode aren't quite right. These days, at least for the units I know of, it is a click of the button in the right time window, not a "hold" action. Might save you the soldering and/or figuring out which pin is which.