OVS build & Install issues

"developer" build for OpenWRT with OVS is giving me "kernal mismatch" problem during install.

root@OpenWrt:~# opkg install openvswitch
Installing openvswitch (2.10.1-1) to root...
Downloading http://downloads.openwrt.org/snapshots/packages/mips_24kc/packages/openvswitch_2.10.1-1_mips_24kc.ipk
Collected errors:
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for openvswitch:
 *      kernel (= 4.14.95-1-d1ee8700c94508a73d768b2eef7c2e84)
 * opkg_install_cmd: Cannot install package openvswitch.

On GitHUB, There is a mention of some config changes before building OpenWRT:

I have tried these changes and I still see this kernel mismatch during install.

Please advise best way to solve this problem.


You need to upgrade to the current OpenWrt firmware snapshot before installing a current snapshot package.

snapshots are updated frequently, so you need to install all the packages you need soon after installing the snapshot firmware.

I did. I flashed router with latest firmware snapshot available on web-site. I tried installing OVS on this snapshot and it was NOT available.

So, I decided to build firmware with OVS as development build. It built fine. However, during install, I got kernel mis-match as posted. Initially, I created firmware without "config" changes posted on Github for OVS. It failed. Then I tried with config changes. It failed again with kernel mismatch.


1 Like

The kernel difference minor.. However, OVS is still showing "error" during install..

Require version = 4.14.95-1-d1ee8700c94508a73d768b2eef7c2e84,
installed 4.14.95-1-6c1da4165bbf3ee261ca6a6d7a3925f4