Override MAC address wwan

Hi everyone,
Only my third post I think here, as have recently purchased some hardware that supports OpenWRT (netgear r7800 & tplink wr902ac). Not an expert but generally find my way around systems/software well enough. Have the r7800 running great with Wireless/Guest/Guest-bandwidth-limiter/Cake-sqm/Samba/NextDNS/irqbalance. I'm finding the stability, performance and gaming ping from OpenWRT is just awesome.

My question if anyone would help though is for the wr902ac. I'm trying to use as a wifi repeater with its own subnet/NAT (for work - our music system), and trying to override the wwan MAC address. I've used interfaces>WWAN>advanced settings>Override MAC. This adds the entry to etc/config/network:

config interface 'wwan'
option proto 'dhcp'
option macaddr '14:1F:XX:XX:XX:XX'

Unfortunately this doesn't take effect see sniptool1:


I've read many, threads trying to work around this, and found to add an entry such as:

config device 'wan_dev'
option name 'eth0'
option macaddr '14:1F:XX:XX:XX:XX'

This doesn't work either. I have a feeling I've got something wrong with the syntax/naming. Would anyone be able to point out where I went wrong? Thanks!

to make it work that need be under the radio setting ' wireless', non under interface, so add that via scp or sftp

1 Like

Thanks so much bricco1981!

I added to etc/config/wireless, under config wifi-iface. Now showing the desired MAC.