Override MAC address doesn't work on OpenWrt 19.07.0-rc1

Override MAC address doesn't work on Nanostation M2 / LuCI openwrt-19.07 branch (git-19.317.63431-ebd354d) / OpenWrt 19.07.0-rc1 r10649-c4fdb377a2

I have tried to changed it via LuCI >Interfaces (wlan0)>Edit>Advanced Settings>Override MAC address with following Restart and Reboot.

Any solution?

Have you tried v19.07.0? I think the build is still in the process but it maybe available for your device as most of the targets have been built so far along with their packages.The bug may have been fixed already. If after v19.07.0 you still have this issue then you can come back here.

That creates an option macaddr to change the MAC - which works for a bridge definitely (because I tested). For a PHY (like a WiFi chip or VLAN), instead try:

config device 'xxx_dev'
	option name 'wlan0'
	option macaddr 'xx:xx:xx:xx:xx:xx'

xxx == the name of the Interface in OpenWrt (e.g. wlan0).

This post better explains the difference between the two configs.

1 Like

It looks like a common problem on some devices, e.g. Is the Wan Mac address override working in 19 with Luci?

E.g. in 18.06.X changing of MAC doesn't work on WR1200JS for 5GHz. It 'works', but connection is not established.

You should reflash partition with specific data.

What does this mean?

'Stock' data including MAC is stored in 'factory' partition, as far as I remember. I think, it is possible to dump it, edit, and reflash. I haven't done it.

1 Like

Are you running "ar71xx" or the new "ath79" firmware for this device?

Sorry, it is ramips architecture.


My example is about another architecture, I can say nothing about yours.

Did the config work?

I'm kinda lost at the posts about architecture?

I'm not sure it would be defined as a problem, though.

No, it did not. Actually there are only 'config interface' in /etc/config/network
Ups, sorry, too tired. Corrected.

We know this. I'm suggesting you manually add the needed config device section, reload, and let us know.

Added config device section, rebooted and no changes.

Isn't the config option supposed to be option macaddr 'xxxxxx' ? It works for my WAN interface. I have a HomeHub 5A, Lantiq based router.

I have tried adding both options to /etc/config/network and they do not work.

config device 'wlan0_dev'
      option name 'wlan0'
      option macaddr 'xx:xx:xx:xx:xx:xx'
config interface 'xxxxxxxxx'
      option macaddr 'xx:xx:xx:xx:xx:xx'
      option proto 'dhcp'

The problem is for wireless interface, for wan it works.

Does the problem persist with the final release of 19.07.0?

I have not tested yet with the final release of 19.07.0, nor with rc2.