OPNsense + Managed Switch + Ubiquiti 6 LR - VLANS

Hi again,

I think I managed to solve it. Could you guys please have a look on the configuration if everything is fine?

What I did to fix it:

  1. Reset
  2. Network - Devices - Edit br-lan - add VLAN 1 tagged, Enable VLAN Filtering
  3. Network - Interfaces - Edit lan - Set to br-lan.1
  4. Save and Apply
  5. add the other vlans and ssids
config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'xxxxxxxxx

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0'

config interface 'lan'
	option device 'br-lan.1'
	option proto 'static'
	option ipaddr 'xx.xx.xx.xx'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option gateway 'xx.xx.xx.1'

config bridge-vlan
	option device 'br-lan'
	option vlan '1'
	list ports 'eth0:t'

config device
	option name 'br-lan.1'
	option type '8021q'
	option ifname 'br-lan'
	option vid '1'

config bridge-vlan
	option device 'br-lan'
	option vlan '2'
	list ports 'eth0:t'

config bridge-vlan
	option device 'br-lan'
	option vlan '3'
	list ports 'eth0:t'

config bridge-vlan
	option device 'br-lan'
	option vlan '4'
	list ports 'eth0:t'

config bridge-vlan
	option device 'br-lan'
	option vlan '5'
	list ports 'eth0:t'

config bridge-vlan
	option device 'br-lan'
	option vlan '6'
	list ports 'eth0:t'

config interface 'WIFI1'
	option proto 'none'
	option device 'br-lan.2'

config interface 'WIFI2'
	option proto 'none'
	option device 'br-lan.3'

config interface 'WIFI3'
	option proto 'none'
	option device 'br-lan.4'

config interface 'WIFI4'
	option proto 'none'
	option device 'br-lan.5'

config interface 'WIFI5'
	option proto 'none'
	option device 'br-lan.6'
	option defaultroute '0'
	option delegate '0

This looks fine... basically the same as what I had provided earlier with the exception of VLAN 1 being tagged (that is why I asked for screenshots of your switch configuration so many times -- it wasn't clear what the trunk configuration was, and the screenshots were the only way to verify it).

1 Like

Thanks a lot for your help psherman.

You're welcome.

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.
Thanks! :slight_smile:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.