Opkg wget returned 4 on wired repeater

Hello there, I'm getting the wget returned 4 error. The router is an Archer C2 AC750 and it's currently serving as a WiFi extender (I hope it's well configed), fed by an ethernet cable coming from my main router.
DHCP's disabled, IP is static, and SSIDs are the same as my main ones.

So I read this could be because I have no "internet" on the router. WAN and WAN6 are stopped because I'm not using them. So is there a way to opkg update without touching the wiring?

Net config:

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdd6:448c:e0d6::/48'

config interface 'lan'
        option type 'bridge'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option _orig_ifname 'eth0.1 radio0.network1 rai0'
        option _orig_bridge 'true'
        option ifname 'eth0.1 rai0'
        option ipaddr '192.168.5.2'

config device 'lan_dev'
        option name 'eth0.1'
        option macaddr '[MAC ADDRESS]'

I censored the mac address because I dont really know if it's safe to post it. If you need it, please tell me.

Thank you!

https://www.gnu.org/software/wget/manual/html_node/Exit-Status.html

4
Network failure.

Most likely you've got basic connectivity or DNS problems.

You either need "global" Internet connectivity, or need to transfer the package files to the router "by hand" (including all the dependencies) and install them from the file. For most people, getting the connectivity, even just for the period required, is the easier approach.

Does the router have DNS and a default route, probably through 192.168.5.1 (guessing, based on its IP address being 192.168.5.2)?


Not part of the problem, but the following lines are cruft from LuCI-based edits, and can be safely deleted on current releases (and probably on older ones as well):

option _orig_ifname 'eth0.1 radio0.network1 rai0'
option _orig_bridge 'true'
2 Likes

You have not defined 'gateway' and 'dns' address options for the LAN interface, so traffic originating from the router itself does not work properly as it can't resolve addresses and does not get routed.

(Traffic originating from connected PCs works, as they get the info via DHCP from the main router.)

1 Like
config interface 'lan'
        option type 'bridge'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.5.2'
        option gateway '192.168.5.1'
        option ifname 'eth0.1 rai0'
        option dns '192.168.5.1'

Would you say this is an okay cfg? Being 192.168.5.1 my main routers IP.

Also thanks to @jeff for the answer. I deleted the option orig cmmds.

Looks right at the first glance.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.