Opkg update is broken

Hi, I have flashed openwrt on my netgear R7500, and use this as the main router, no wireless is required, I use other router as AP, but now when I try to run opkg update, it throws,

Error relocating /bin/opkg: __stat_time64: symbol not found
Error relocating /bin/opkg: __time64: symbol not found
Error relocating /bin/opkg: __lstat_time64: symbol not found
Error relocating /bin/opkg: __utime64: symbol not found
Error relocating /bin/opkg: __ctime64: symbol not found

I'm quite new to openwrt, the image I have downloaded is from [[OpenWrt Wiki] Techdata: NETGEAR R7500 v1], any clue what I can do?


Other than flashing the router, have you made any other changes to the configuration or taken any other actions such as installing or upgrading packages previously?

Also, is it performing its routing functions properly?

1 Like

Hi @psherman thank you for the prompt reply.

In the very beginning I tried to install simple-adblock and its ui, but it got failed, I didn't record the false message, but i can recall false message was very similar to this one, since simple-adblock went failed, then I installed adblock and the ui instead, then I try to perform a opkg update, it throws above exceptions.

Not sure if I have messed up everything, I just now tried to install libubox.so.20210819 and now there are two libubox.so

I cannot even delete any of them now :rofl: :rofl:

Do you think i need to do a fresh flashing?

make a backup of your configuration and then simply reset to defaults if things are not working properly.

That said, you have a snapshot installed. Snapshots can break in all sorts of ways, and the packages can become out of sync fairly quickly --- sometimes as fast as the next day, depending on the changes being made along the way.

I'd recommend that you install the stable release of 21.02.1 which you can download from the firmware selector (grab the sysupgrade image since you're already running OpenWrt.


Thanks a ton, the original reason why I chose this snapshot version was because it supports 5G wifi, anyway, I'm not going to use its wifi function since there might be a hardware problem of this model, I will take your recommendation to install the stable version and try.

Thank you again!

Update to a newer snapshot image (or use 21.02.x), the recent musl 1.2.x update comes with ABI incompatible changes for 64 bit time_t.

(Old, outdated, snapshot with musl 1.1.x preinstalled, using opkg to install new/ current packages built against musl 1.2.x --> BOOOM).

1 Like

@psherman just come back to thank you again, after installed the stable version, now it works like a charm, thank you.

I have reinstalled the stable version, and now it works now. Thank you anyway.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.