Opkg update error with arm_cortex-a9(ARMv7)

I am writing to report an issue when I run "opkg update" at my DIR-885L(ARMv7). Firmware version is "OpenWrt 19.07.7". It was working normally until few days ago, but now it is not working. I attached whole result of this command.

Summery: All other files was downloaded, but only one file from http://downloads.openwrt.org/releases/19.07.7/packages/arm_cortex-a9/packages/Packages.gz cannot be downloaded. Collected errors are as follows:

Collected errors:

I tried to get it by wget. It goes well until 99%, but finally returned "timed out" error. Its result was as follows:

root@OpenWrt:~# wget http://downloads.openwrt.org/releases/19.07.7/packages/arm_
Downloading 'http://downloads.openwrt.org/releases/19.07.7/packages/arm_cortex-a9/packages/Packages.gz'
Connecting to
Writing to 'Packages.gz'
Packages.gz 99% |****************************** | 361k - stalled -Connection error: Connection timed out

I can download this file manually by Chrome browser in my desktop. I am not sure why it is not working. I can download other files in the repository by wget normally.

Thank you for someone's help in advance.

nslookup of "downloads.openwrt.org" returned "mirror-02.infra.openwrt.org". So I replaced this domain name to "mirror-01.infra.openwrt.org" in opkg/distfeeds.conf. Now it works. I think the problem is in the distribution feeds.