OPKG No Valid Architecture Raspberry Pi 3 B+

Hello, I am attempting to set up Open-WRT on my 2014 Raspberry Pi 3B+ (No wifi chip). Things that works so far:

  • I downloaded the latest RPi 3B+ image here.
  • I flashed my sd card
  • I can ssh into the Pi.
  • I configured the WAN
  • I can successfully ping outside the network (google.com)

Things that don't work:

  • I can't access the LUCI dashboard from the browser (It's not installed)
  • I can't install luci
root@OpenWrt:/etc# opkg install luci
Unknown package 'luci'.
Collected errors:
 * opkg_install_cmd: Cannot install package luci.
  • when I run opkg update I get Signature check failed. Remove wrong Signature file.
  • (I disabled option check_signature and opkg update runs successfully)
  • Now when I run opkg list-upgradable I get the following messages for all of the packages Package <package name> has no valid architecture, ignoring.
  • I am unable to install any packages with opkg install

Has anyone encountered this error? I'm seeing a lot of people posting issues with the getting OpenWRT running on a Pi, so if there is a clear cut guide to get it running please send it to me.

Thank you!