Opkg doesn't install dependencies, or get configured

Newbie here so maybe I'm doing something simple incorrectly.

I have a Linksys ea7300. Following this page I installed the Snapshot Install and it boots fine and I can ssh in.

Luci is not installed by default and I'm trying to get it working. The problem is when I 'opkg install luci' it doesn't install any actual files. It is a metapackage but doesn't install any of the dependent packages.

So I installed from that same webpage the Snapshot Upgrade. Didn't notice any changes except it undid what I had done.

So I installed all the packages listed for offline luci install (however using opkg to do so).

Now it seems closer, I visit and get

Bad Gateway

The process did not produce any response

Logread gives some promising information such as
Sat Oct 31 14:27:31 2020 daemon.err uhttpd[8142]: no file '/usr/share/lua/luci/util.lua'

So presumably this could be fixed if I can figure out which package to install.

But my bigger question is why opkg doesn't seem to install any dependencies on its own?

1 Like

Looks like you have installed a snapshot. You probably need to update to the latest supported release (if available) or the most recent snapshot.

When you get the message “Cannot satisfy the following dependencies for…” it is most likely because you installed a snapshot version of OpenWrt.
Read here for possible solutions.

Also important is network connectivity. How is this router connecting to the internet? Can you ping OpenWrt.org from the router itself?

The router is assigned a wan address by the cable modem - that part is working fine. I am connected through the router currently, so the basic wired routing and masquerading is working ok.

I don't get any messages about unsatisfied dependencies from opkg. It just says the package (luci in this case) was installed and configured, and subsequently lists it as installed, but none of its dependencies.

I had similar results with installing diffutils and bash, I can't run them because the libraries they need don't get installed.

openwrt update appears to run OK, although if I try to update all packages for which updates are available, it says a lot of them are not available for this arch after all. I used this command.
opkg list-upgradable | cut -f 1 -d ' ' | xargs opkg upgrade

I'll check out the "here" link you posted.

I finally got enough luci packages manually installed, but my wifi interfaces don't seem to be detected...?

Bad idea to update like this. Could be the reason you are having problems.

Upgrading packages (via the CLI opkg upgrade command or the LuCI Upgrade... button) can result in major problems. It is generally highly discouraged, unless you know what you are doing or if there is specific instruction to do so.

1 Like

I only tried that upgrade after I was having the problem.
It broke everything so I have done 'firstboot' since then to undo that.

But yeah, I am groping in the dark.
I took a stab at getting the wifi detected by installing all packages with 'mt76' in the name.
Now the router has rebooted into ipv6-only mode apparently, so I cannot figure out how to access luci or even ssh in haha. (So I just reset it again).

The info I found on this mt76 radio made it sound pretty experimental so maybe this is just above my head.

Did you install the latest snapshot? From there you should be able to do an online install of LuCI (assuming the networking is functional).

1 Like

I may be missing something about how to install the latest snapshot?

From the page for this device, linked above, I installed the "Snapshot Install" image and then the "Snapshot Upgrade" image. This was just last night.

Is that not how to do it?

OK, I re-traced my steps, and instead downloaded the firmware image from here:

The checksum was different.
But the result is the same, here is a transcript. (This is after doing opkg update, and removing a duplicate line from distfeeds.conf which causes a warning)

root@OpenWrt:~# opkg install luci
Installing luci (git-20.304.73778-5a485f8) to root...
Downloading https://downloads.openwrt.org/snapshots/packages/mipsel_24kc/luci/luci_git-20.304.73778-5a485f8_all.ipk
Configuring luci.
root@OpenWrt:~# opkg list-installed | grep luci
luci - git-20.304.73778-5a485f8

So, it doesn't install the dependencies.

Same problem here!

I'm using a snapshot and experiencing the same exact thing with opkg installs not properly configuring.

I'm finding that opkg is trying to install dependencies, but can't find them.
From a boot of a fresh snapshot image, I tried and install with increased debug level on opkg:

opkg update
opkg --force-depends -V3 install luci

and got these messages:

Collected errors:
 * opkg_download: Failed to download https://downloads.openwrt.org/snapshots/packages/aarch64_generic/luci/luci_git-20.304.73778-5a485f8_all.ipk, wget returned 8.
 * opkg_install_pkg: Failed to download luci. Perhaps you need to run 'opkg update'?
 * opkg_install_cmd: Cannot install package luci.

I entered the failed URL into a web browser and get 404 Not Found. Browsing that luci repo shows only a dozen files. I copied that repo 2 days ago and there are over 2000 files supposed to be in that directory. So now I'm trying to follow the buildbot and git changes for more clues.

Having the exact problem... except when I tried --force-depends, I didn't get an error like you did. I think. HUGE list of comments resulted with that one.

I see my checksums matching, just getting one line from the luci "install", and no working luci after.

Ah, the joys of trying snapshots out on the family router! :astonished: At least my life isn't in imminent danger, I have the house running off a travel router till I get this fixed... :roll_eyes:

There is a recent change to okpg dependency handling that may be related:

1 Like

Also experiencing the same problem, hoping for a update/fix soon.

Hmmm.. maybe. It was 2 days ago, while my snapshot was from yesterday.

I see there was a kernel change in the last 4 hrs or so, anyone try a fresher snapshot than that to see, or am I going to be the test animal? :confused:

Other than the general danger of newb updating firmware from the command line (for the first time), is there any other danger in this particular situation? In other words, should I wait till things are "normal"?

Well, bit the bullet and installed Nov 1 snap. Same issue, two kmods locations.
Remove one of them, update, opkg install luci... still single line response and no functional Luci. This is the first time I've had this problem with snapshots and the C7.

Going back to 19.07.4, and forgetting about chasing the C7 wifi/memory issues for now, as well as exploring some improvements to the wifi airtime fairness and quality management. :frowning_face:

On the NanoPI R2S (with snapshot built from 30-10 and 1-11) I have the same error.
Hope a fixx will be released soon!

After a snapshot upgrade, I lost luci and there is another bug related to opkg config: https://bugs.openwrt.org/index.php?do=details&task_id=3422&order=dateopened&sort=desc

After many hours trying to get this last snapshot working and failing to do so and reverting to the previous one and getting errors about the newer kernel dependencies, I had to revert to stock firmware.

This is a mess! -.-'

This was just fixed by dangowrt and is already pushed to opkg.git. next snapshot tomorrow is hopefully fixed.

Sorry for the inconveniences and thanks for testing!


Glad for your precious help and effort! @aparcar

Kudos to you!

1 Like