OpenWrtOne connection issue after reset

On a OpenWRT One.
Due to not being able to make it work correctly, I decided to restart from scratch. My problem is that after installing the firmware I seem to be stuck and my knowledge on how to fix it is limited.

I need to add Luci back but I cannot connect. When I ping from the computer (or from the console I have intermittent connection and never long enough to run apk update (note: I have tried this in 24.10.0 with opk update and I am now in Snapshot)

root@OpenWrt:~# apk update
wget: Failed to send request: Operation not permitted
ERROR: wget: exited with error 4
WARNING: updating and opening https://downloads.openwrt.org/snapshots/targets/mediatek/filogic/packages/packages.adb: unexpected end of file
wget: Failed to send request: Operation not permitted
ERROR: wget: exited with error 4
WARNING: updating and opening https://downloads.openwrt.org/snapshots/packages/aarch64_cortex-a53/base/packages.adb: unexpected end of file
wget: Failed to send request: Operation not permitted
ERROR: wget: exited with error 4
WARNING: updating and opening https://downloads.openwrt.org/snapshots/targets/mediatek/filogic/kmods/6.6.83-1-1b5eade834212f74fcb82b50a1ef0272/packages.adb: unexpected end of file
wget: Failed to send request: Operation not permitted
ERROR: wget: exited with error 4
WARNING: updating and opening https://downloads.openwrt.org/snapshots/packages/aarch64_cortex-a53/luci/packages.adb: unexpected end of file
wget: Failed to send request: Operation not permitted
ERROR: wget: exited with error 4
WARNING: updating and opening https://downloads.openwrt.org/snapshots/packages/aarch64_cortex-a53/packages/packages.adb: unexpected end of file
wget: Failed to send request: Operation not permitted
ERROR: wget: exited with error 4
WARNING: updating and opening https://downloads.openwrt.org/snapshots/packages/aarch64_cortex-a53/routing/packages.adb: unexpected end of file
wget: Failed to send request: Operation not permitted
ERROR: wget: exited with error 4
WARNING: updating and opening https://downloads.openwrt.org/snapshots/packages/aarch64_cortex-a53/telephony/packages.adb: unexpected end of file
wget: Failed to send request: Operation not permitted
ERROR: wget: exited with error 4
WARNING: updating and opening https://downloads.openwrt.org/snapshots/packages/aarch64_cortex-a53/video/packages.adb: unexpected end of file
8 unavailable, 0 stale; 137 distinct packages available
root@OpenWrt:~#

and when I try to ping Google I get an intermittent :

% ping  8.8.8.8

Request timeout for icmp_seq 265
Request timeout for icmp_seq 266
Request timeout for icmp_seq 267
64 bytes from 8.8.8.8: icmp_seq=267 ttl=54 time=1037.020 ms
64 bytes from 8.8.8.8: icmp_seq=268 ttl=54 time=31.662 ms
64 bytes from 8.8.8.8: icmp_seq=269 ttl=54 time=6.894 ms
64 bytes from 8.8.8.8: icmp_seq=270 ttl=54 time=7.110 ms
64 bytes from 8.8.8.8: icmp_seq=271 ttl=54 time=6.871 ms
64 bytes from 8.8.8.8: icmp_seq=272 ttl=54 time=7.309 ms
64 bytes from 8.8.8.8: icmp_seq=273 ttl=54 time=6.855 ms
64 bytes from 8.8.8.8: icmp_seq=274 ttl=54 time=6.567 ms
64 bytes from 8.8.8.8: icmp_seq=275 ttl=54 time=6.708 ms
Request timeout for icmp_seq 277
Request timeout for icmp_seq 278
Request timeout for icmp_seq 279
Request timeout for icmp_seq 280
Request timeout for icmp_seq 281
Request timeout for icmp_seq 282
Request timeout for icmp_seq 283
Request timeout for icmp_seq 284
Request timeout for icmp_seq 285
Request timeout for icmp_seq 286
Request timeout for icmp_seq 287
Request timeout for icmp_seq 288
Request timeout for icmp_seq 289
Request timeout for icmp_seq 290
Request timeout for icmp_seq 291
Request timeout for icmp_seq 292
Request timeout for icmp_seq 293
Request timeout for icmp_seq 294
Request timeout for icmp_seq 295
Request timeout for icmp_seq 296
Request timeout for icmp_seq 297
Request timeout for icmp_seq 298
Request timeout for icmp_seq 299
Request timeout for icmp_seq 300
Request timeout for icmp_seq 301
Request timeout for icmp_seq 302
Request timeout for icmp_seq 303
Request timeout for icmp_seq 304
Request timeout for icmp_seq 305
64 bytes from 8.8.8.8: icmp_seq=306 ttl=54 time=739.283 ms
64 bytes from 8.8.8.8: icmp_seq=307 ttl=54 time=6.225 ms
64 bytes from 8.8.8.8: icmp_seq=308 ttl=54 time=6.614 ms
64 bytes from 8.8.8.8: icmp_seq=309 ttl=54 time=7.006 ms
64 bytes from 8.8.8.8: icmp_seq=310 ttl=54 time=6.863 ms
64 bytes from 8.8.8.8: icmp_seq=311 ttl=54 time=6.973 ms
64 bytes from 8.8.8.8: icmp_seq=312 ttl=54 time=6.361 ms
64 bytes from 8.8.8.8: icmp_seq=313 ttl=54 time=6.895 ms
64 bytes from 8.8.8.8: icmp_seq=314 ttl=54 time=8.991 ms

My setup is currently (temporary, while learning trying to make it work):

  • ISP Router <--> unmanaged switch (with the rest of the house connected to it) <--> Eth0 OpenWrt One Eth1 <--> The laptop from which I am configuring.

Later on I am planning to have:

  • ISP Router <--> OpenWrt One <--> unmanaged switch <-->the rest of my house Lan

My config is:

Network:

root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
    option device 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config globals 'globals'
    option ula_prefix 'fd6b:76f1:ba41::/48'

config device
    option name 'br-lan'
    option type 'bridge'
    list ports 'eth1'

config interface 'lan'
    option device 'br-lan'
    option proto 'static'
    option ipaddr '192.168.1.1'
    option netmask '255.255.255.0'
    option ip6assign '60'

config interface 'wan'
    option device 'eth0'
    option proto 'dhcp'

config interface 'wan6'
    option device 'eth0'
    option proto 'dhcpv6'

Firewall:

root@OpenWrt:~# cat /etc/config/firewall
config defaults
    option syn_flood    1
    option input        REJECT
    option output        ACCEPT
    option forward        REJECT
# Uncomment this line to disable ipv6 rules
#    option disable_ipv6    1

config zone
    option name        lan
    list   network        'lan'
    option input        ACCEPT
    option output        ACCEPT
    option forward        ACCEPT

config zone
    option name        wan
    list   network        'wan'
    list   network        'wan6'
    option input        REJECT
    option output        ACCEPT
    option forward        REJECT
    option masq        1
    option mtu_fix        1

config forwarding
    option src        lan
    option dest        wan

# We need to accept udp packets on port 68,
# see https://dev.openwrt.org/ticket/4108
config rule
    option name        Allow-DHCP-Renew
    option src        wan
    option proto        udp
    option dest_port    68
    option target        ACCEPT
    option family        ipv4

# Allow IPv4 ping
config rule
    option name        Allow-Ping
    option src        wan
    option proto        icmp
    option icmp_type    echo-request
    option family        ipv4
    option target        ACCEPT

config rule
    option name        Allow-IGMP
    option src        wan
    option proto        igmp
    option family        ipv4
    option target        ACCEPT

# Allow DHCPv6 replies
# see https://github.com/openwrt/openwrt/issues/5066
config rule
    option name        Allow-DHCPv6
    option src        wan
    option proto        udp
    option dest_port    546
    option family        ipv6
    option target        ACCEPT

config rule
    option name        Allow-MLD
    option src        wan
    option proto        icmp
    option src_ip        fe80::/10
    list icmp_type        '130/0'
    list icmp_type        '131/0'
    list icmp_type        '132/0'
    list icmp_type        '143/0'
    option family        ipv6
    option target        ACCEPT

# Allow essential incoming IPv6 ICMP traffic
config rule
    option name        Allow-ICMPv6-Input
    option src        wan
    option proto    icmp
    list icmp_type        echo-request
    list icmp_type        echo-reply
    list icmp_type        destination-unreachable
    list icmp_type        packet-too-big
    list icmp_type        time-exceeded
    list icmp_type        bad-header
    list icmp_type        unknown-header-type
    list icmp_type        router-solicitation
    list icmp_type        neighbour-solicitation
    list icmp_type        router-advertisement
    list icmp_type        neighbour-advertisement
    option limit        1000/sec
    option family        ipv6
    option target        ACCEPT

# Allow essential forwarded IPv6 ICMP traffic
config rule
    option name        Allow-ICMPv6-Forward
    option src        wan
    option dest        *
    option proto        icmp
    list icmp_type        echo-request
    list icmp_type        echo-reply
    list icmp_type        destination-unreachable
    list icmp_type        packet-too-big
    list icmp_type        time-exceeded
    list icmp_type        bad-header
    list icmp_type        unknown-header-type
    option limit        1000/sec
    option family        ipv6
    option target        ACCEPT

config rule
    option name        Allow-IPSec-ESP
    option src        wan
    option dest        lan
    option proto        esp
    option target        ACCEPT

config rule
    option name        Allow-ISAKMP
    option src        wan
    option dest        lan
    option dest_port    500
    option proto        udp
    option target        ACCEPT

Dhcp:

root@OpenWrt:~# cat /etc/config/dhcp

config dnsmasq
    option domainneeded '1'
    option boguspriv '1'
    option filterwin2k '0'
    option localise_queries '1'
    option rebind_protection '1'
    option rebind_localhost '1'
    option local '/lan/'
    option domain 'lan'
    option expandhosts '1'
    option nonegcache '0'
    option cachesize '1000'
    option authoritative '1'
    option readethers '1'
    option leasefile '/tmp/dhcp.leases'
    option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
    option nonwildcard '1'
    option localservice '1'
    option ednspacket_max '1232'
    option filter_aaaa '0'
    option filter_a '0'

config dhcp 'lan'
    option interface 'lan'
    option start '100'
    option limit '150'
    option leasetime '12h'
    option dhcpv4 'server'
    option dhcpv6 'server'
    option ra 'server'
    option ra_slaac '1'
    list ra_flags 'managed-config'
    list ra_flags 'other-config'

config dhcp 'wan'
    option interface 'wan'
    option ignore '1'

config odhcpd 'odhcpd'
    option maindhcp '0'
    option leasefile '/tmp/hosts/odhcpd'
    option leasetrigger '/usr/sbin/odhcpd-update'
    option loglevel '4'

I read the following post but without much success to fix it:

Any idea why the connection keeps dropping?

Try tracerote to identify network equipment at fault

I will make a guess about what is causing your issue..

it is quite possible that your upstream network uses the same subnet (192.168.1.0/24). Change the address above to a different subnet -- for example, 192.168.7.1.

3 Likes

Well Thank you! Thank you! That was easy when someone with experience can easily spot the total newbie error.
After seeing the results I realized that was already the issue in my previous config. No need to start from scratch. After reloading the last backup everything seems to be working fine now.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.