OpenWrt x86 boot up hang issue

Hi, I've been using OpenWrt/LEDE x86 on a multi LAN industrial PC as my main router for quite a while. However, when I recently want to try the latest kernel release, I'm encountering the same boot hang issue with all my 3 Industrial PCs, and it's the same symptom with different custom/community builds, even the image I downloaded from OpenWrt official website.

My 3 IPCs configurations are listed below

  1. Intel J1900 + 4x Intel 82583v
  2. Intel J3160 + 4x Intel i210
  3. Intel DQ77KB motherboard with Intel 82579LM and 82574L

I've tried to write the image to either a USB flash drive or the on-board SSD then boot up the machine, however, the boot up process always hang at the same place:
"8021q: adding VLAN 0 to HW filter on device eth1"

So could there be anyone please kindly let me know where the problem is? Thanks a lot!

Are you sure that it hangs on this line and this isn't only the latest printed kernel message?

What happens if you press ENTER to activate the console?
Probably your keyboard isn't detected or there like if it's not working.

You can also try to ssh into your machine on eth1 (normally attached to br-lan).
Give your desktop pc and ssh to

I think intel 825x NIC using kmod-igb driver, but your fw suddenly used kmod-e1000e driver. Try remove kmod-e1000e to see what happens.

Thanks a lot for your advice.
To be honest, I'm not familiar with compiling the OpenWRT image so I'm not able to remove the e1000e dirver to use the igb driver, but I don't think it's the e1000e driver.
First, it's fine with eth0, but start to hang with eth1.
Second, I've attached a picture of the boot up log from a previous working community build on the same machine using Intel 82583 LAN chip, it's also using e1000e and booting up just fine.

I have a router using intel 82580 nic card, it uses igb driver without problems but cannot use e1000e driver.

root@Openx86:~# lspci -nnv
01:00.3 Ethernet controller [0200]: Intel Corporation 82580 Gigabit Network Connection [8086:150e] (rev 01)
        Subsystem: Hewlett-Packard Company NC365T 4-port Ethernet Server Adapter [103c:1780]
        Flags: bus master, fast devsel, latency 0, IRQ 22
        Memory at 91000000 (64-bit, non-prefetchable) [size=512K]
        Memory at 91200000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: [40] Power Management version 3
        Capabilities: [50] MSI: Enable- Count=1/1 Maskable+ 64bit+
        Capabilities: [70] MSI-X: Enable+ Count=10 Masked-
        Capabilities: [a0] Express Endpoint, MSI 00
        Capabilities: [e0] Vital Product Data
        Kernel driver in use: igb

Which version of openwrt are you using ?

Hi leeanay, I'm using 19.07.2, but it seems earlier version may also have the problem, and I'm not sure which version my working build is using.
BTW, as I'm from China and I have posted this problem in a Chinese forum before, I'm not the only one who is encountering this problem, at least 2 other persons have replied to me that they're having the same issue.
In addition, as I've mentioned, not only the machine with Intel 82583 LAN chip is having this problem, my other 2 machines are also having the same issue.

Hi juppin, I've tried your suggestion by pressing ENTER and it could activate the console as below, but it seems I need to wait for a while after seeing the boot up stopped at "8021q: adding VLAN 0 to HW filter on device eth1".

However, when trying to SSH, I got no response. With some other community build which has LUCI web GUI, I could not see the log in page when typing in browser, that's why I know the boot up process hasn't successfully finished. You can see my reply to leeandy above, I think seeing "random: crng init done" means the boot up is successful.

For me the latest x86_64 images with linux 5.4 works fine in combination with 3x intel i210 on a amd cpu.

Thanks for the information. Since the machine is working fine with the earlier build, I don't think it's a hardware problem. For now, I'm just not sure if there's something changed with the new kernel affecting the compatibility, or if there's any BIOS setting should be changed to work along with the new kernel.

Problem solved.
Got enlightened by a screen capture in an ordinary OpenWrt installation post, realized I was wrong about whether the system has finished the boot up process. In my situation, eth0 in no longer the WAN port but the LAN port, eth1 has become the WAN port (usually eth0 is WAN and eth1 is LAN by default in my previous experience), just plug the cable into eth0 and successfully logged into the management page.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.