OpenWrt x86_64 images bad?

Setting up an x86 router and it only supports EFI. I've tried several efi images and a couple different messages and none of them extract right. Gnome archive manager shows them with a decompressed size of >500mb yet they extract with an error and the image is considerably smaller. Ive tried with gunzip, and selecting the compressed image directly with balenaEtcher......same result.

I've tried this one amongst others:

You verified the checksums of the images you downloaded? Just gunzipping and dd'ing onto your device should do the trick.


The image linked above matches hash e16445cc240225e0515dbb8da93986407ef7bee5476c116e687927d89d3061c5

gunzip followed by dd doesn't complain about anything, however it doesn't produce a recognizable boot drive either. I usually use the graphical archive extractors and this would be the first archive I've seen do this.

What's exactly the file u're using? I tried openwrt-21.02.0-rc1-x86-64-generic-ext4-combined-efi.img.gz and WinRAR reports no error.

1 Like

That is the image I was actually trying to use but I've tried earlier versions of EFI images. I did get it to work using gunzip then gnome disks to write the image. It seems all images dated 4/21 that I tried throw errors in Gnome Archive Manager, Xarchiver, and balenaEtcher. The archives all show a larger decompressed size and then fail with a "header" error. They extract smaller than initially calculated, but I think the decompressed file is actually's just something about the way they were compressed that causes an issue with some Linux decompression apps.