OpenWrt won't boot in VirtualBox and hangs with br-lan : link becomes ready

Hi everyone :slight_smile:

I followed the wiki instructions to install OpenWrt via VirtualBox to prepare the image and I can boot from the virtual disk, but it won't go further than br-lan : link becomes ready.

I am using the following image:

openwrt-21.02.1-x86-64-generic-squashfs-combined.img.gz

This is the case wether I configured an adapter to work via NAT or bridged:

Adapter 1:

 - Name: vboxnet0
 - Connected: Host only adapter
 - Advanced: Adapter Type: Intel PRO/1000 MT Desktop
 - Promiscuous mode: Deny

Adapter 2:

 - Connected: with NAT

Adapter 3 (optional):

 - Connected: with Bridged Adapter
 - ethernet/wifi eth0/wlp2s0
 - Advanced: Adapter Type: Intel PRO/1000 MT Desktop
 - Promiscuous mode: Deny

I installed virtualbox as a debian package and I don't get the menu to configure my network in VirtualBox as it is described here:

https://openwrt.org/docs/guide-user/virtualization/virtualbox-vm#virtualbox_settings

(Sadly, as a new user, I can only include one embedded image per post)

What seems weird:

  • I only get this dialog to configure a NAT network and it doesn't make a difference if I enable ipv6 for it or not.
  • it says that eth0 is entering promiscuous mode, but I set it to deny on all the adapters. Even to change this setting (which one shouldn't do, but is mentioned here) didn't work. (Edit: since I didn't configure eth0 it is getting disabled, as the screenshot says.)

Could someone:

  • point me to a working VirtualBox config (or a way to get there)
  • or test wether they are stuck at the same point?

Btw I used the arch linux 2021-11-01 x86-64 with the same VirtualBox config and could ping stuff by simply booting it.

That looks like a normal boot. If your virtual keyboard is working you should be able to click in the window then hit enter and get control of the console.

As far as networking if there is one port it will be on br-lan with an IP of 192.168.1.1. As a host only network you need an interface on your host in 192.168.1.X and you should be able to ssh to OpenWrt from a terminal on the host.

If there are two ports the second one will attempt to be a wan connection as a DHCP client. Usually I would bridge that to the host LAN so the virtual OpenWrt has Internet access. There is no way to log in through that port unless the firewall is changed.

2 Likes

Hey @mk24 that's good to hear. I'll try ASAP and then post the results.

When I install OpenWrt on a real device I don't have to connect a keyboard and to press enter. So how does it work on devices? I think this is not architecture specific.

On a headless device access is via a network connection.

Here lan is connected to a virtual host only network but you haven't set up a matching interface on the host. Which is a topic outside the scope of this forum.