OpenWrt with Pi-hole (dnsmasq) configuration

Hello! So I'm running an OpenWRT router and installed Pi-hole on another client. I have several services on another server, so my plan was to configure dnsmasq on the Pi-hole to resolve my local domain to the server, where I have configured an nginx reverse proxy, e.g. emby.home.local/.

However, this is not enough/doesn't work - I have to add the domain -> ip to the router's dnsmasq, otherwise the domain is not resolvable.

The topology (simplified) is:

Client (192.168.1.X)   -
                         Router ( - Pi-hole (
Server ( -

I added this to the Pi'hole's dnsmasq configuration, but is effectively useless.


On the Router I have set the DHCP option to 6, I thought it was enough to set my Router's DNS forwardings to my Pi-hole, but then no domain can be resolved anymore.

What am I doing wrong here? Is there a simpler way of configuring this?

if the option is sent to the clients, the request shouldn't go to the router, at all.
then there's something with your pi-hole.

make sure you allow the piholes DNS request to go out, or you'll create a loop.

this isn't a client DoH/DoT issue, is it ?

1 Like