OpenWrt with IPv6 WAN using PPP


My Fiber ISP offers an IPv4 and IPv6 using PPP(oe). At the moment I am using a Drayk 2925, but it is enterprise and bulky. OpenWRT has suited my needs, so I bought an EdgeRouter X and installed OpenWRT. I've tried to configure my Openwrt with IPv6 but sadly I am not getting a IPv6 Adres.

I've tried to use:

option ipv6 auto

But the spawned WAN_6 interface does not have an active link.
When setting up with "1" and creating a manual wan6 interface (with DHCPv6) no link is also active.

The problem (i think) is that in my Draytek I can configure my IPv4 with PPPOE and point my IPv6 to the PPP of my IPv4. But in OpenWRT this option isn't available, when selecting PPP(OE) on IPv6 I need to validate my credentials and it goes haywire.

I've configured the needed ports in the firewall and added the :://0 route for IPv6.

How to proceed?


The following has worked for me:

config interface 'wan'
	option ifname 'lan0'
	option proto 'pppoe'
	option username 'xxxxxxxx'
	option password 'xxxxxxxx'
	option ipv6 '1'

config interface 'wan6'
	option proto 'dhcpv6'
	option ifname '@wan'

Note @wan just tells OpenWrt to use the wan interface (stanza above wan6) to apply the IPv6 options to.


Yeah, there's nothing much to config. My guess would be to blame your ISP router.

config interface 'want'
	option ifname 'eth3'
	option proto 'pppoe'
	option username 'cliente@cliente'
	option password 'cliente'
	option peerdns '1'
	option dns ','
	option ipv6 '1'
	option delegate '0'
	option metric '10'
config interface 'want6'
	option ifname '@want'
	option proto 'dhcpv6'
	option reqaddress 'try'
	option peerdns '0'
	option metric '20'
	option reqprefix '56'
1 Like

@Borromini This is my current setup. The @wan is present.
@Hikari Well..why does it work out of the box with a normal Draytek:

As you can see I've got the option to use PPP (from my IPv4) or use DHCPv6.
My IPv6 /56 subnet is being given through PPPOE and not DHCPv6.

Mode PPP:

Because that doesn't make immediate sense.

It also worked instantly for me too, once I learned how to make PPPoE work. When IPv4 came online, IPv6 and its PD came together.

My guess is because they are independent softwares, their developers never tested them together. Maybe one of them have some conflict bug that only happens when interacting with the other.

The other option I see if u're mistaken. Yesterday I was trying to learn how to fine tune firewall, I blocked TCP+UDP and was testing with ping and couldn't understand why ping was connecting if I had the device blocked. When I set the block for all protocols, ping became blocked too.

You said u receve a /56 PD, but on the SS it seems to be /64, so that's a inconsistence. Is the address reported by whatismyip inside the global PD? Maybe Draytek is using NAT6 instead of PD?

My VMnet doesn't have IPv6 GUA because my ISPs give me a single /64 PD each. When I enable NAT6 on my LAN router, my VMnet starts working from ULA. But that's ULA, GUA remains not working.

1 Like

Yesterday I did another test, because I found this post: [Solved] How to configure IPv6 PPPoE connectivity? - #14 by renne
It seems I have (almost) the same setup. Firewall is correctly workin, so that is not the problem.

The LAN subnet is mostly /64, even on OpenWRT the LAN subnet is /64 even though the connection has a /56.

Weird part is when a /64 IPv6-PD in OpenWRT I have a connection. So I am going to create a ticket with my ISP. Because when I do this, the connection is really unstable.

1 Like

Okay, I did a search on OpenWRT IPv6 Dual stack and found out another post:

It seems there was a bug in an OpenWRT build with the specific MT7621 hardware (EdgeRouter X). Going to investigate.

My ERX always worked fine getting IPv6 from PPPoE.

The problem, that also happens on my Ryzen, is that it troubles to handle routes and gets confused with eth and pppoe interfaces.