OpenWrt with DAP2610 and vlan

Hello, I'm new using openwrt and I have partial success with it. My first install was with a ASUS RT-N16 and everything is working fine. This is my main router and I'm trying to use a d-link DAP2610 with it. The DAP2610 was working with the default OEM firmware but I was curious to use openwrt on both device. I did not read enough before uploading openwrt and seem that device is not that good with vlan. No obvious switch like in my router.

My first question is, anybody is able to use DAP2610 with VLAN without problems?

If not anybody that was able to go back to the D-link firmware? I tried without success. I sis install sysupdate after the latest openwrt 21.02. I was able to upload version 1.0 at one point but was still seeing the Luci going to default 192.168.1.1. Was not able to upload to firmware 2.06 using the default firmware. I'm able to get 192.168.0.50 to upload the firmware OEM 2.06, but it does nothing. Always back to 192.168.0.50.

Any feedback would be nice. I would love to use openwrt but if my DAP2610 is not able to do VLAN it is not useful since I'm trying to have a main wifi and guest wifi on that device.

Thank you,

You do not need a built in switch to use VLANs. You will need to connect it to another vlan aware device, though - either directly to a router with vlan support or to an external managed switch.

I tested a lot of things and was never able to get my two wifi configuration receiving different IP. I'll keep on reading about vlans and hope to be able to use the dap2610 to have wifi main and wifi guest. I'm using a managed switch between my router and AP but does not seem to work. From your reply, it looks like the DAP2610 is working with openwrt and I should be able to have two different wifi.

On my router I have the main interface IP 192.168.1.0/24 and a guest interface IP 192.168.10.0/24. It was working with the default D-link firmware and I was able to see the LAN being TAG and was splitting with vlan and multi SSID. But so far nothing on the DAP2610 and openwrt.

Thank you very much for your reply.

Have you verified that the router's configuration is functioning properly for the guest network? And have you tested that your switch is properly configured? This needs to be done first -- ideally with a wired computer connected to your managed switch

On your DAP2610, you'll be adding an additional network interface and binding it to a bridge with something like eth0.3 or whatever your ethernet interface name is (replace eth0 if it has some other name) and the VLAN ID (replace the 3 if you are using another VLAN ID). Then you will create a guest SSID and bind that with the name of the guest network interface.

Yes the router and switch were ok. Like I said I did the full test with stock firmware on the DAP2610. Everything was working fine. I wanted more and wanted to have openwrt on both device. Probbaly my first mistake since it was working fine at that point. But now I will have to stick with openwrt since I'm not able to go back to OEM firmware on it.

Yes the switch is working and in my case it is also vlan 3 that I used. Don't think it is a proble if I use another number but in that case I would have to change my managed switch and also the info on the router since the router is sending the IP to the AP.

I think I did what you described at one point. Not sure why it was not working. But from your description I should be able to have both IP coming from the router. One from the default interface and one from the guest interface.

I will work on it more tomorrow. Good to know somebody knows it should work. Probably a minor detail I forgot

Thank you,

Stick with the upstream configuration you have (since you know it is working).

Please copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall

Hi,
I tried but not able to get anything working on AP. Looks like I'm way over my head here.

Network of my router just in case. Router is supposed to give IP to other device and it is ok because I tested with my laptop changing vlan on network adapter and the IP did change according to the selected vlan.

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdbc:9e84:1736::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0'

config device
	option name 'eth0'
	option macaddr '78:98:e8:bf:8a:90'

config interface 'lan'
	option device 'br-lan'
	option proto 'dhcp'

config interface 'guests'
	option device 'br-guests'
	option proto 'dhcp'

config device
	option type 'bridge'
	option name 'br-guests'
	list ports 'eth0'

config bridge-vlan
	option device 'br-guests'
	option vlan '3'

On the DAP2610 these are my files. I'm able to get an IP from DHCP only for one interface.
DHCP and firewall are supposed to be disabled on the AP since the router is supposed to do the job.

gave yo uthe firewall and dhcp file anyway.

This is what I see for interface

/etc/config/network


config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd8c:d490:171d::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0'
	option mtu '1500'
	option macaddr 'BE:D1:4C:DF:A1:19'

config device
	option name 'eth0'
	option macaddr '78:98:e8:bf:8a:90'

config interface 'lan'
	option device 'br-lan'
	option proto 'dhcp'

config device
	option type 'bridge'
	option name 'br-guests'
	option mtu '1500'
	option macaddr '78:98:E8:B1:8A:90'
	list ports 'eth0'

config interface 'guests'
	option proto 'dhcp'
	option device 'br-guests'

config device
	option type '8021ad'
	option ifname 'br-guests'
	option vid '3'
	option name 'br-guests.3'
	option mtu '1500'
	option macaddr '78:98:E8:B2:8A:90'

/etc/config/wireless


config wifi-device 'radio0'
	option type 'mac80211'
	option channel '11'
	option hwmode '11g'
	option path 'platform/soc/a000000.wifi'
	option htmode 'HT20'
	option cell_density '0'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'OpenWrt'
	option encryption 'none'

config wifi-device 'radio1'
	option type 'mac80211'
	option channel '36'
	option hwmode '11a'
	option path 'platform/soc/a800000.wifi'
	option htmode 'VHT80'
	option disabled '1'

config wifi-iface 'wifinet1'
	option device 'radio0'
	option mode 'ap'
	option ssid 'OpenWrt2'
	option encryption 'none'
	option network 'guests'

/etc/config/dhcp


config dnsmasq
	option domainneeded '1'
	option boguspriv '1'
	option filterwin2k '0'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option nonegcache '0'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
	option nonwildcard '1'
	option localservice '1'
	option ednspacket_max '1232'

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option dhcpv4 'server'
	list ra_flags 'managed-config'
	list ra_flags 'other-config'
	option ra 'hybrid'
	option dhcpv6 'hybrid'
	option ignore '1'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'

/etc/config/firewall


config defaults
	option syn_flood '1'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'REJECT'

config zone
	option name 'lan'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'ACCEPT'

config zone
	option name 'wan'
	list network 'wan'
	list network 'wan6'
	option input 'REJECT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option masq '1'
	option mtu_fix '1'

config forwarding
	option src 'lan'
	option dest 'wan'

config rule
	option name 'Allow-DHCP-Renew'
	option src 'wan'
	option proto 'udp'
	option dest_port '68'
	option target 'ACCEPT'
	option family 'ipv4'

config rule
	option name 'Allow-Ping'
	option src 'wan'
	option proto 'icmp'
	option icmp_type 'echo-request'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-IGMP'
	option src 'wan'
	option proto 'igmp'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-DHCPv6'
	option src 'wan'
	option proto 'udp'
	option src_ip 'fc00::/6'
	option dest_ip 'fc00::/6'
	option dest_port '546'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-MLD'
	option src 'wan'
	option proto 'icmp'
	option src_ip 'fe80::/10'
	list icmp_type '130/0'
	list icmp_type '131/0'
	list icmp_type '132/0'
	list icmp_type '143/0'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Input'
	option src 'wan'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	list icmp_type 'router-solicitation'
	list icmp_type 'neighbour-solicitation'
	list icmp_type 'router-advertisement'
	list icmp_type 'neighbour-advertisement'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Forward'
	option src 'wan'
	option dest '*'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-IPSec-ESP'
	option src 'wan'
	option dest 'lan'
	option proto 'esp'
	option target 'ACCEPT'

config rule
	option name 'Allow-ISAKMP'
	option src 'wan'
	option dest 'lan'
	option dest_port '500'
	option proto 'udp'
	option target 'ACCEPT'

config rule
	option name 'Support-UDP-Traceroute'
	option src 'wan'
	option dest_port '33434:33689'
	option proto 'udp'
	option family 'ipv4'
	option target 'REJECT'
	option enabled 'false'

config include
	option path '/etc/firewall.user'

Thank you,

I tried a lot of things but still not able to have that device working. I also tried version 21.02.1 just to be sure if it's not something that is now fixed. apart from being able to save my "Bridge VLAN filtering", it is all the same.

Anybody with a running DAP2610 using VLANs that can post their network file?

Or anybody that was able to bring back the d-link original firmware. That also failed so I'm stuck with a device I can't use :frowning:

Thank you,

I was able to burn back the original d-link firmware and will use the DAP2610 as is without openwrt. At least doing so I'm able to do what I want. Not really the solution I wanted but don't have the time to test more.

Making sure I connected the AP to my computer with a fixed IP to reach 192.168.0.50 to burn the firmware. I started from 1.01 and did all until 2.06 did not work. I found a different source on the web for the file and that one worked.

Thank you,

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.