OpenWrt VM not detecting WiFi

I'm new to OpenWRT and am having trouble getting it to detect my wireless adapter. I've deployed the VMware OVA and configured the LAN and WAN interfaces. However I have also added an Intel 7265 adapter using PCI passthrough. My plan is to eventually replace the WAN interface with the wireless adapter for a segregated network I'm creating.

I've installed a few packages such as wpad, iwinfo and the firmware for my adapter. However it's not being detected after rebooting. I can see the adapter if I run lspci so it's definately been passed through to the VM. I've also tested it works by configuring passthrough to a Windows VM and had no problems connecting. Finally I also tried deleting /etc/config/wireless and ran 'wifi config'. This recreates the file but it's empty.

Perhaps I'm missing a few other packages or am making a beginner mistake? Greatful for any advice on this one.

opkg list | grep kmod | grep -i intel | grep 7265
1 Like

kmod-iwlwifi - 5.4.124+5.10.42-1-1 - iwlwifi kernel module for Intel Wireless WiFi Link 6250AGN Adapter Intel 6000 Series Wi-Fi Adapters (6200AGN and 6300AGN) Intel WiFi Link 1000BGN Intel Wireless WiFi 5150AGN Intel Wireless WiFi 5100AGN, 5300AGN, and 5350AGN Intel 6005 Series Wi-Fi Adapters Intel 6030 Series Wi-Fi Adapters Intel Wireless WiFi Link 6150BGN 2 Adapter Intel 100 Series Wi-Fi Adapters (100BGN and 130BGN) Intel 2000 Series Wi-Fi Adapters Intel 7260 Wi-Fi Adapter Intel 3160 Wi-Fi Adapter Intel 7265 Wi-Fi Adapter Intel 8260 Wi-Fi Adapter Intel 3165 Wi-Fi Adapter

I managed to get this working in the end. Here's the notes I took which may help someone else who's using the VMware OVA for version 21:

Deploy OVA, ensure LAN and WAN are set, even if you're going to change it later otherwise the wrong interfaces are assigned to the wrong devices.

Ensure adapters are set to 'Connected' and upgraded to VMXNET3.

Add the PCI Wireless adapter and reserve all memory.

Upgrade the VM compatibility to the latest (tested on ESXi 7.0 U2) and change guest OS to 'Other 5.x or later Linux (64-bit)'.

Set a root password at the console using 'passwd'.

Change the LAN IP address by modifying /etc/config/network and reboot.

Now login to the web interface and install the following packages:
iwlwifi-firmware-iwl7265d (firmware may vary depending on your device)

The following will need to be installed via the command line:
opkg update
opkg install kmod-iwlwifi

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.