OpenWrt v21.02.3 for TP-LINK TL-MR3420 v2

About 2 years ago, I asked my first question, Boot custom openwrt firmware from extroot and if it was possible. 2 years worth of research and getting on and off the project had finally paid off.

Now, 2 years later, I have finally managed to build myself a custom firmware for this router based on the latest stable firmware currently available with extroot support integrated and with 300KB free (at the time of this thread was written, 26 May 2022).

Firmware is currently in alpha stage and I'm still testing this firmware for stable daily use.

I've built this firmware a few minutes ago and is currently the first release to successfully boot with extroot support (USB 2 support needs to be installed via opkg). So far, everything works as expected.

Build machine specs:
ASUS N56VZ
Ubuntu 17.10.1
Intel Core i5-3210M, 2c4t
8GB RAM
512GB SSD

Router specs:
TP-LINK TL-MR3420 v2
Qualcomm Atheros AR9341
4MB ROM
32MB RAM

Changelog:
v21.02.3-release2

v21.02.3

2 Likes

Hi!

  • I have i5 CPU with Ubuntu 20.04. My Tp-Link router TLMR3420 v2 was running on OpenWrt v17x, I have 8gb hp flash drive formatted as extroot partition (132mb ext4 extroot partition, rest of the space formatted as ntfs partition for file sharing),

  • after flashing your "openwrt-21.02.3-ath79-tiny-tplink_tl-mr3420-v2-squashfs-factory.bin" file from Luci, & rebooting, my router is totally bricked !!! (:cold_sweat::cold_sweat::cold_sweat:), I have lost access to Luci login page (192.168.1.1),

  • Ubuntu 20.04 network connection activation failed error then i have to static ip setup, to connect router with PC (address: 192.168.1.2, Netmask: 255.255.255.0, Gateway 192.168.1.1),

  • I can not either login with ssh via putty (root@192.168.1.1 or root@192.168.1.2, connection refused or route unavailable),

  • router power, gear, web, LAN 1 LED are turning on as normal (network cable in Lan1), USB LED is off (even when USB is plugged in),

  • on Windows 10 machine Luci login page or ssh aren't working either, I tried TFTP but nothing (ip setup: 192.168.0.86, 255.255.255.0, 192.168.0.66), router back side reset button isn't doing anything (router not resting or TFTP recovery mode flashing .bin file), telnet connection refused, same as with winscp,

My god, why would you flash an untested firmware without having uboot? You should know that by flashing unofficially supported firmware, you are on your own and you are taking a huge risk! I had assumed this firmware would only be used strictly by really advanced users or developers. No one in their right mind would flash an untested firmware unless they know what they are doing and know what backup options they have.

Right now, the only solution (or two) is to put your router in recovery mode and load tp link’s official firmware through 192.168.0.66 or 88. This option never worked on my router so I can’t confirm. This is why I have uboot on my router.

The second way is to get yourself a CH341A flash programmer and unsolder the rom from your router and reprogram the router. This is only for highly skilled person. Do not attempt if you have no knowledge of how to do this.

Because this router is limited by the 4MB/32MB limitation, there is NO LUCI built in to this firmware. DHCP is also not included. This firmware is highly compressed with (xz) and it might take a few long minute to boot. Virtually every possible package that can be removed from the firmware is removed to allow new versions of the OpenWRT firmware running on this device. Only static ip will be possible. No fancy features are included in this firmware. The idea is to get extroot running so that you can install anything after that.

Reading "132mb ext4 extroot partition" and "ntfs partition for file sharing" in the light of a damned 4/32 device (533 MHz mips 74k, single core) more suggests tagging this as learning experiences and getting a device that's actually up to the job.

1 Like

Does it ready for use?