OpenWrt support for Xiaomi AX3000T

I've somehow forgotten my password to login to the router.
How can I reset and get back into it?
Thanks

you can reset the router by long pressing the reset button at the back

1 Like

For those who have problems with Wifi after rebooting.
Here is the perfect Wifi Extender setting for you.
These settings ensure that the wireless connection will not be lost after a reboot.

cat /etc/config/wireless

root@28:AA:3C:3D:E0:F3:~# cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'platform/soc/18000000.wifi'
        option channel '11'
        option band '2g'
        option htmode 'HE20'
        option country 'PA'
        option cell_density '0'
        option txpower '26'

config wifi-device 'radio1'
        option type 'mac80211'
        option path 'platform/soc/18000000.wifi+1'
        option channel '36'
        option band '5g'
        option htmode 'HE80'
        option txpower '28'
        option country 'PA'
        option cell_density '0'

config wifi-iface 'wifinet0'
        option device 'radio0'
        option mode 'sta'
        option ssid 'Vodafone'
        option encryption 'psk2'
        option key '(Vodafone)'

config wifi-iface 'wifinet1'
        option device 'radio1'
        option mode 'sta'
        option ssid 'Vodafone'
        option encryption 'psk2'
        option key '(Vodafone)'

config wifi-iface 'wifinet2'
        option device 'radio0'
        option mode 'ap'
        option ssid 'Test'
        option encryption 'psk2'
        option hidden '1'
        option key '12345678'
        option network 'lan'

config wifi-iface 'wifinet3'
        option device 'radio1'
        option mode 'ap'
        option ssid 'Test'
        option encryption 'psk2'
        option hidden '1'
        option key '12345678'
        option network 'lan'

cat /etc/config/network

root@28:AA:3C:3D:E0:F3:~# cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd7c:0348:3004::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'
        option macaddr '28:AA:3C:3D:E0:F3'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.3.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config device
        option name 'wan'
        option macaddr '28:AA:3C:3D:E0:F3'

config interface 'wan'
        option device 'wan'
        option proto 'dhcp'

config interface 'wan6'
        option device 'wan'
        option proto 'dhcpv6'

config device
        option name 'eth0'
        option macaddr '28:AA:3C:3D:E0:F3'

config device
        option name 'lan2'
        option macaddr '28:AA:3C:3D:E0:F3'

config device
        option name 'lan3'
        option macaddr '28:AA:3C:3D:E0:F3'

config device
        option name 'lan4'
        option macaddr '28:AA:3C:3D:E0:F3'

config device
        option name 'phy0-ap0'
        option macaddr '28:AA:3C:3D:E0:F3'

config device
        option name 'phy0-sta0'
        option macaddr '28:AA:3C:3D:E0:F3'

config device
        option name 'phy1-ap0'
        option macaddr '28:AA:3C:3D:E0:F3'

config device
        option name 'phy1-sta0'
        option macaddr '28:AA:3C:3D:E0:F3'

config interface 'wwan'
        option proto 'dhcp'
        option device 'phy1-sta0'

config interface 'wwan2'
        option proto 'dhcp'
        option device 'phy1-sta0'

root@28:AA:3C:3D:E0:F3:~#

What I have noticed:

  1. the hostname must be sent.

  2. the correct channel must be set exactly.

  3. network wwan: Wireless Network: must be set to unspecified.

  4. network wwan: Network interfaces: Device Wireless Network: Client "your ssid" phy1-sta0

  5. wwan2 network: : Network interfaces: Device Wireless Network: Client "your ssid" phy1-sta0

dears, i made the same mistake (flash the initramfs for uboot while snapshot version is installed, and stuck at mtd-rw), can i:

  1. directly flash ubiformat /dev/mtd8 -y -f /tmp/openwrt-mediatek-filogic-xiaomi_mi-router-ax3000t-initramfs-factory.ubi
  2. then repeat the steps by installing the 23.05.3 version?

I think there's only currently a snapshot available for this hardware.

1 Like

what power supply are you using, what's the Amps and the Voltage?

Completly new to OpenWRT. I purchased an AX3000T. It already has OpenWRT on it. : {
"kernel": "6.1.82",
"hostname": "OpenWrt",
"system": "ARMv8 Processor rev 4",
"model": "Xiaomi Mi Router AX3000T (OpenWrt U-Boot layout)",
"board_name": "xiaomi,mi-router-ax3000t-ubootmod",
"rootfs_type": "squashfs",
"release": {
"distribution": "OpenWrt",
"version": "SNAPSHOT",
"revision": "r25690-b1d579f174",
"target": "mediatek/filogic",
"description": "OpenWrt SNAPSHOT r25690-b1d579f174"
}
}
I changed the ip address such that I can access it from my home network. Root account still has no password. I can SSH to it from Windows. The router needs to be running openNDS as well. It is for my daughter so I think getting everything to work with a web interface is important. But it being a snapshot image means no Luci. Tried installing that and it failed because of the kernel dependencies. So first of all I would like a stable image on it that includes Luci. After a lot of googling however it is still very unclear to me how to do this. Can I do that from the current openWrt version, or do I need to get the original firmware on it again? Any hints appreciated. Thanks Ben

Hi Ben,

the support for this router is still new, so no stable releases are available for it.
You can use the firmware selector to get snapshot images for it:
https://firmware-selector.openwrt.org/?version=SNAPSHOT&target=mediatek%2Ffilogic&id=xiaomi_mi-router-ax3000t-ubootmod
(make sure to select the same "U-Boot layout" image)

In the dropdown "customize installed packages..." you can add the packages you need.

You mentioned luci - so add luci-ssl to the end of the list.
Also I would suggest adding luci-app-attendedsysupgrade - it makes it easier to update to newer snapshots, while keeping the packages you installed.

Btw... Which version did you get? RD03?

Edit:
You can read up on snapshots vs stable releases here:
https://openwrt.org/releases/snapshot#main_differences_of_buildbot_snapshots_vs_official_stable_releases

Does anyone who has used Cake know the limit that the ax3000t has?

Anyone got stock firmware package of the international version(RD23)?

Hey guys, is this listing still shipping with the Chinese version?

I have ordered two of these. It's the Chinese version!

1 Like

If there is 160MHz , 2400Mbps is only from MIMO 2x2 ,right ?
There is something like 3R3T , but this not gives aditional channels.

When did you last order? Things could've changed. Also how stable are things?

Order placed on: 21 Mar 2024
Chinese Version, EU Adapter

I am very satisfied with the stability. No failures.

Will this router be included in the stable version of 24.X?

It should, but 24 might become 25.

1 Like

that is, there will be no new relise in 2024?
will it be in 2025?

What is the quick way to set up mesh?
I read you can do it through LUCI