OpenWrt support for Netgear WAX620

And in addition, you can drop those 2 properties:

nvmem-cells = <&macaddr_ubootenv_ethaddr>;
nvmem-cell-names = "mac-address";

U-boot is already setting the MAC-address via the alias "ethernet0 = &dp6;"

btw, can you post a full OpenWrt-bootlog on gist?

Sure. Let me know if anything looks bad...

Looks good (besides dp6_syn, but you've already changed that in the dts)

Awesome, and thanks for checking :+1:

Edit: PR for board file is submitted.

I've tried a snapshot on my AP. But wlan was not working like in rc2. After boot I had to manually restart network to make it work again. Dunno what that was, but has anyone else experienced the same issue? If I remember correctly the version was WLAN.HK.

I've also tried to downgrade WLAN.HK drivers to 2.7 out of curiosity, but that failed on rc2. I've heard it solves the issue that I'm having with my iOS devices and not able to use the internet after some time.
For now I've enabled option multicast_to_unicast_all '1' that seems to fix my issues.

So for now it has been upgraded to a daily driver as a bridge.

One more (dumb) question: What is the correct way to test WLAN.HK versions? Download the files and replace them in the folder and do a reboot? Maybe I did it the wrong way because it went bad earlier.

There are a lot of changes regarding hostapd functionality in snapshot.
Please always look in the kernel log and logread (grep hostpad) for wireless issues.

What is the correct way to test WLAN.HK versions? Download the files and replace them in the folder and do a reboot?

Yes exactly.

I'm testing latest snapshot r23766-5356462ce5 / LuCI Master git-23.223.85458-f7583b6 build on 2023-08-18, and all seems good. Looking at the log I see 2 new warnings that was not present in rc2.

radio0 (1690): WARNING: Variable 'data' does not exist or is not an array/object
radio1 (1691): WARNING: Variable 'data' does not exist or is not an array/object


daemon.notice hostapd: Set new config for phy phy1:
daemon.notice hostapd: Set new config for phy phy0:
daemon.notice netifd: radio1 (1691): sh: out of range
daemon.notice hostapd: Set new config for phy phy1:
daemon.notice netifd: Wireless device 'radio1' is now up
daemon.notice hostapd: Set new config for phy phy0: /var/run/hostapd-phy0.conf
hostapd: Restart interface for phy phy0
daemon.notice hostapd: Configuration file: data: driver=nl80211 logger_syslog=127 logger_syslog_level=2 ...

Anything to inspect, or is it a known warning?

Edit: My bad, used the wrong bdwlan. Did not pay attention to the log file. Will PR the new one...

[   19.502786] cnss[2]: INFO: Boardid from dts:290,FW:ff
[   19.526724] cnss[2]: INFO: BDF location : 0x4b0c0000
[   19.527578] cnss[2]: INFO: BDF IPQ8074/bdwlan.b290 size 131072
[   19.533156] cnss[2]: INFO: per device BDF location : 0x4b0e0000


Hi. I've created a PR.
So I hope everything is in order. Thanks for all the help @kirdes and @jmspswny. I really appreciate it :slight_smile: :+1:

For now I'm using latest snapshot from yesterday r23782-ac68fbf526 and it's rock solid so far. I've only one problem with some iOS units not able to use the internet after sleep (reconnecting). This is also present in RC2. I've added a workaround for now.

option multicast_to_unicast_all '1'

I can also mention that with bdwlan.b290 board file, my master AP is reporting that SNR went up from 38 to 45. No changes on both AP's, but I only did a sysupgrade with my latest build. Might be something else, but I'll take it.

Update: PR is merged :+1: Will do a final build with latest snapshot to see if everything works correctly.

Update 2023-09-29: Build works, running snapshot with 6.1.55.

Hi guys,
any news about support for this device (WAX620)?

Thank you

P.S. where can I found the working snapshot? The upgrade is done via serial or via factory web interface?

Tnx again

It's only snapshot for now, but you can use the and add luci.

Serial only, but if you are able to use serial, we could try to create an image for factory web.

1 Like

Tnx Specebar, I was evaluating to buy that device but, at his point, I prefer to think of others.

@Ringo - I've got both the WAX620 and the WAX220 up and running openwrt currently. No real issues with either, but the WAX220 has more capable hardware and is a much easier install.

Hi jmspswny.

Did you install openwrt by serial Port or by ethernet? Because i woul not open the Shell.

I saw WAX220 only has One ethernet Port.


for the WAX220, I installed via the factory image upload. That process is detailed here:

Thnx jmspswny,
I already saw thank you a lot the same...


Did you manage to solve this? Mine booted 4/5 times from openwrt, now back to Netgear fw. Used the WAX620 firmware from snapshot 31/3/24


Though if you login and switch firmware it boots back to OpenWRT :grinning:

No sorry. But as you have noticed, on the fifth (5) boot it will boot from the other partition.
But you can set the boot_count= with fw_setenv boot_count 0 to start from 0 again on the current partition.

You can view the boot_count with fw_printenv in your console.

I like that you have 4 counts before it boots from the other partition, because when I have build an image that fails it will boot to a working partition after 4 boot loops. :+1:

1 Like