OpenWrt support for Linksys MX4200

What settings are you using for the second 5GHz radio?

You can perform sysupgrade with -n option and see if third radio is working.

just did a fresh install. 2.4 and 5ghz1 are similar results (tested from different location):

2.4Ghz:

5ghz1:

5ghz2 is now available as well:

Still the ping is high and speed slow compared to the stock MX4200v1:

wireless config:

config wifi-device 'radio0'
	option type 'mac80211'
	option path 'platform/soc/c000000.wifi'
	option channel '48'
	option band '5g'
	option htmode 'HE80'
	option country 'NL'
	option cell_density '0'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'openwrt51'
	option encryption 'sae-mixed'
	option key '********'

config wifi-device 'radio1'
	option type 'mac80211'
	option path 'platform/soc/c000000.wifi+1'
	option channel '6'
	option band '2g'
	option htmode 'HE20'
	option cell_density '0'
	option country 'NL'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option ssid 'openwrt24'
	option encryption 'sae-mixed'
	option key '********'

config wifi-device 'radio2'
	option type 'mac80211'
	option path 'platform/soc/c000000.wifi+2'
	option channel '100'
	option band '5g'
	option htmode 'HE80'
	option country 'NL'

config wifi-iface 'default_radio2'
	option device 'radio2'
	option network 'lan'
	option mode 'ap'
	option ssid 'openwrt52'
	option encryption 'sae-mixed'
	option key '********'

Thanks for the test. Can you install one more time official snapshot with -n option and see if third radio works? Also check the speed results.

For better performance you may be interested in NSS build: IPQ807X NSS Build

Is it necessary to install with -n? It takes some time to configure it all. Would a sysupgrade work as well?

In fact, you currently have two separate rootfs_data partitions where changes are saved. When doing sysupgrade you are switched to the second partition with a separate rootfs_data.

There is a reported PR that allows installation on the same partition: https://github.com/openwrt/openwrt/pull/14720

ok thanks, will do that later. FYI: backup functionality from your build is not working. it generates a 0 bytes .tar.gz file that cannot be opened.

I did flash the official snapshot on the other partition and further test in the evening. Thanks for all your help so far!

There is a fix for that: https://github.com/openwrt/openwrt/commit/4efbfcd996abd351547203cf5d51d53564ada5fb

You can check if backup functionality works on new build: https://github.com/testuser7/openwrt/releases/tag/qualcommax-3191136

2 Likes

I have prepared a new version. Configuration backup should now be working here. There is also an added -s option for sysupgrade to install on the same partition.

The patch for regdomain has been removed in this build. Can you check how WiFi behaves without this patch?
It is necessary to install without saving the configuration (-n) or to delete the file /lib/firmware/ath11k/IPQ8074/hw2.0/cal-ahb-c000000.wifi.bin after installation and restart.

Build: https://github.com/testuser7/openwrt/releases/tag/qualcommax-970c50c

I did the sysupgrade using that new build and then did

rm /lib/firmware/ath11k/IPQ8074/hw2.0/cal-ahb-c000000.wifi.bin
reboot

once rebooted I ran iwinfo:

phy0-ap0  ESSID: "XX"
          Access Point: D8:EC:5E:XX:XX:X
          Mode: Master  Channel: 52 (5.260 GHz)  HT Mode: HE80
          Center Channel 1: 58 2: unknown
          Tx-Power: 5 dBm  Link Quality: unknown/70
          Signal: unknown  Noise: -110 dBm
          Bit Rate: unknown
          Encryption: WPA2 PSK (CCMP)
          Type: nl80211  HW Mode(s): 802.11ac/ax/n
          Hardware: embedded [Qualcomm Atheros IPQ8074]
          TX power offset: none
          Frequency offset: none
          Supports VAPs: yes  PHY name: phy0

phy1-ap0  ESSID: "XX"
          Access Point: D8:EC:5E:XX:XX:XX
          Mode: Master  Channel: 6 (2.437 GHz)  HT Mode: HE20
          Center Channel 1: 6 2: unknown
          Tx-Power: 5 dBm  Link Quality: unknown/70
          Signal: unknown  Noise: -102 dBm
          Bit Rate: unknown
          Encryption: WPA2 PSK (CCMP)
          Type: nl80211  HW Mode(s): 802.11ax/b/g/n
          Hardware: embedded [Qualcomm Atheros IPQ8074]
          TX power offset: none
          Frequency offset: none
          Supports VAPs: yes  PHY name: phy1

phy2-ap0  ESSID: "XX"
          Access Point: D8:EC:5E:XX:XX:XX
          Mode: Master  Channel: 108 (5.540 GHz)  HT Mode: HE80
          Center Channel 1: 106 2: unknown
          Tx-Power: 8 dBm  Link Quality: 67/70
          Signal: -43 dBm  Noise: -108 dBm
          Bit Rate: 6.0 MBit/s
          Encryption: WPA2 PSK (CCMP)
          Type: nl80211  HW Mode(s): 802.11ac/ax/n
          Hardware: embedded [Qualcomm Atheros IPQ8074]
          TX power offset: none
          Frequency offset: none
          Supports VAPs: yes  PHY name: phy2

Seems like without the regdomain patch the TX powers are all low again.

What's the speed without the regdomain patch?
Maybe also try 160MHZ channel?
Also is the ping better?

Thanks for checking. Could you add a comment with the results without the patch and with the patch here: https://github.com/openwrt/openwrt/pull/14512 ?

160MHz is not supported on this SoC.

I'm having same issue with v1, seems that memory is really tight and kernel seems to reserve quite a big chunk to itself from the boot, so I only get around 365M of memory to use.

I backported support for the MX4200 v1 and v2 to 23.05 which uses kernel 5.15. It might be more suitable for MX4200v1. I have a v2 and it's more stable, but that is to be expected from a stable branch anyway.

Note 1: please note that it is extremely unlikely that you will ever see this backport merged into the official repo. There is an open PR but the feedback is that it requires more changes than a backport should for a stable branch. https://github.com/openwrt/openwrt/pull/14474

Note 2: since that's the case, I backported lytr's code to remove regdomain, which is not merged into main yet. I am also less concerned about minimising the changes included in the backport to the essentials. Having said that, I want a very stable firmware and I am not going to backport any changes that aren't self-contained and a clear improvement.

1 Like

My issues seems to be mostly that I configured too many ssid networks and those ate my memory, otherwise daily snapshot builds have been running nicely for me.

I have one SSID for my home network and one for the guest network. They are enabled on the three BSSIDs / radios available. That didn't give me any trouble on either the snapshots or 23.05. But more importantly, I have a v2 which has double the RAM so it's like comparing apples and oranges :slight_smile:

1 Like

Any chance the kernel can be updated to 6.1.82-1-c5bffb40 I wanted to install wireguard from software tab tried force install but if didn't work, (see message)

Support for WireGuard VPN

  • The installed version of package kernel is not compatible, require 6.1.82-1-c5bffb40… while 6.1.79-1-3910cb06… is installed.

Not visited the mx4200 for a while as had chucked an early build on last year and had just left it. Finally got around to updating my 2nd unit (use them both as AP's) and realised chaos ensued as MAC associated with the LAN were identical (clearly ARP table on router got confused). quick fix is to manually set it in br-lan but would be better for it to be picked up - unsure if this is fixed in newer builds ?

MAC addresses for LAN and WAN interfaces should be the same as on the sticker.
And for wireless interfaces, the MAC address from the sticker +1, +2 and +3.

Fixed in this commit: https://github.com/openwrt/openwrt/commit/7173a52f6aea971ae90610f10fd2f184dd29755c

ahh the joys of openwrt. Was running OpenWrt SNAPSHOT r24632-82670f94b4 ok but is quite old so pulled newest V2 snapshot from https://firmware-selector.openwrt.org/?version=SNAPSHOT&target=qualcommax%2Fipq807x&id=linksys_mx4200v2

ran sysupgrade... and its gone !!
Isnt on ip it was using, isnt on default and back 192.168.1.1. Left for 5 min and power cycled and blue led light is on almost immediately and stays there. Any debricking advice ?