OpenWrt Support for D-Link DAP-X1860

Sorry, I don't know.

Regarding the performance, I did a short test with iperf3 between my Windows machine (connected via LAN to the Router) and my Mac (connected via Wifi):

If the Mac is directly connected to the 5GHz wifi of the router:
[ ID] Interval Transfer Bitrate Retr
[ 5] 0.00-10.00 sec 282 MBytes 236 Mbits/sec 0 sender
[ 5] 0.00-10.00 sec 281 MBytes 236 Mbits/sec receiver

If the Mac is connected to the 5GHz Wifi of DAP-X1860 (running as AP connected to the Router LAN):
[ ID] Interval Transfer Bitrate Retr
[ 5] 0.00-10.00 sec 258 MBytes 216 Mbits/sec 0 sender
[ 5] 0.00-10.00 sec 257 MBytes 216 Mbits/sec receiver

If the Mac is connected to the 2.4GHz Wifi of DAP-X1860 (running as AP connected to the Router LAN):
[ ID] Interval Transfer Bitrate Retr
[ 5] 0.00-10.00 sec 125 MBytes 104 Mbits/sec 0 sender
[ 5] 0.00-10.00 sec 124 MBytes 104 Mbits/sec receiver

Used image: (based on

Did you use the web interface to upload the image? In my case it says firmware update failed.

I think I used the sysupgrade command via SSH. Do you already have OpenWrt installed on your device? Then flashing the sysupgrade via web interface should work. Otherwise use the factory image as described here: OpenWrt Support for D-Link DAP-X1860 - #49 by s_2

Currently the stock firmware is installed. I tried using factory image as described above, but it fails as soon as i click upload.

Which browser do you use? I had update problems with Firefox but it worked with Chrome. If the problem still exists, I’ll double check my uploaded files

Chrome. Will try others just in case and report back.

Edit: It is the same problem with Edge & Firefox.

Ok, I re-tried the files on my device, I can upload the factory image:

Upgrade process is started:

And finished successfully:

To be sure: You're using the factory image? Where exactly in the process does it fail?

I see where I have made the mistake. I thought reset button was to factory reset the repeater (maybe I held the button too long as I didn’t get into recovery mode). Anyways thanks for your time, now it works.


  1. Download the openWRT image.
  2. Connect to the repeater with ethernet cable.
  3. Enter recovey mode. (Hold RESET button, before plugin in the repeater, until orange power light starts blinking)
  4. In Chrome open
  5. Upload factory.bin
  6. Wait a couple of minutes.
  • Note: I did not get update completed message, but when the orange light was on (not blinking) it was finished and I could acess LuCI on

Might be relevant.

what is currently preventing a pull-request? More test results?

A patch was sent to the mailing list:

1 Like

If required, I provide new images for the DAP-X1860 time to time:


Thank you Rolando. I have not seen the patch from S_2 arrive in the OpenWRT repository or as Pull-request at GitHub yet, so thank you for keeping us updated.

It seems like there will be some changes to package and firmware dependencies for mt7615e and 7915e: mt76: refine package dependency for mt7615e and mt7915e. They have not yet taken the DAP-X1860 into account though.

1 Like

Hi all devs,
hope you guys doing well.

As a casual OpenWRT user i hope to get a little help on flashing this device as i really stuck rn. I tried to flash the fw but I always get stuck in recovery mode.
When I try to upload the OpenWrt images I always get something like:
"Size: 1259 Bytes" or "Size: 1301 Bytes", depending on which browser I use and on every upload the MD5 is different for the same file.
Only thing that shows correct size and MD5 information is when I upload a stock d-link FW .bin file
I get then:

Upgrade complete!
Rebooting ...

but also end in recovery mode again.

What I tried so far:

  • renaming the openwrt files (to factory.bin and to the name of a stock d-link fw file)

  • tried to reset the device by holding the reset button some seconds after power on

  • different OpenWRT factory and initramfs-kernel images linked in this Thread directly and newer files from RolandoMagico's Github

  • D-LINK support chat trying to get an unencrypted file or anything i could flash they send me an link to try but i think it is also encrypted and not meant for recovery use, however it leads me to the same result as the newer stock fw from the d-link support site I tried first. Finally the chat was out of informations and asked me to open a ticket for the experts to reach out to me, i agreed, i got now answer on the ticket after few minutes, they offer me a RMA. So no luck but was worth the try.
    This was the link they sent me btw if it helps for anything:
    (my bad i wrote them by mistake about DIR device not DAP, thats why i got a wrong link from them, however, the problem persists)

  • i also tried different browsers(Opera, Firefox, Edge, Seamonkey, Chrome)

Btw i have two devices in the same state now, so its definitely not a hardware problem.
Oh and the devices were on the 1.0 FW they came with from factory as i started trying maybe this is important because of the recovery mode version is updated on newer stock fw versions idk.
One of the devices was in use already (linked wifi) the other one put directly to recovery mode

Maybe someone has a little hint for me on what I could try next or where could be a possible reason.
thanks in advance

Looks like Mediamarkt in Germany still wants to get rid of them. You can currently buy one for 30€. But if you buy two of them, there is a 30€ discount. So 30€ for both in the end with free shipping.

1 Like

Which firmware file do you use exactly? Do you have serial access to the devices? in the former mentioned pull request there is an instruction how to extract and download the stock image did you try that?

I flashed just now and came across the same problem. Used openwrt-ramips-mt7621-dlink_dap-x1860-a1-squashfs-factory.bin from, which i renamed to "factory.bin". Followed these instructions: OpenWrt Support for D-Link DAP-X1860 - #69 by dKoco, except that I first tried to use it with Firefox. When I did so, i encountered the 1259 Bytes problem (the file should be way bigger!). Then I tried the same with Microsoft Edge and it showed a file size that I deemed more accurate (but I did not crosscheck), so I flashed and it worked just like described in instructions. I am not completely sure if using Microsoft Edge fixed it, or if it was a timing issue.

1 Like


I used DAP-X1860_RevA_Firmware_101b94.bin, thanks for the help, i was now able to get back to stock using this technique described in the pull request you mentioned. I needed to flash it twice for some reason to work. For the OpenWRT, i tried your posted file from OpenWrt Support for D-Link DAP-X1860 - #62 by RolandoMagico and the last 2 releases from your github repo (2022-12-19 and 2022-12-22). Name: openwrt-ramips-mt7621-dlink_dap-x1860-a1-squashfs-factory.bin
I do have serial access but im not sure how to flash it using serial


I tried Edge again now a few times, didn't helped me on OpenWRT files but with the extracted stock fw file it worked to flash on Edge, but same <1301 Bytes problem on Firefox. So it seems to has something to do with browser. I tried another computer but that didn't help. Maybe its only a small thing that makes the difference which makes it work for you but not for me. For some reason different filename of the same file means also different byte size showed in Firefox,(but alway < 1301 Bytes), really strange behaviour of this WebGUI...
I use the same guide [#69 by dKoco] btw

I also noticed there is telnet access possible on stock firmware. I'm not familiar with telnet, only SSH so I dont know how to get any benefit of that (flash OpenWRT somehow maybe)

I don’t know if flashing via serial is possible in general, but can you provide the serial boot log after flashing openwrt fails?