OpenWrt Support for D-Link DAP-X1860

In the last days, there were multiple additions to the mt76 driver and the upstream linux kernel "Linux-next". Many of those were for mt7915. With regard to LEDs, the following commit is of special interest: At first glance I have not found a commit explicitly dealing with issues related to wlan interfaces and default settings, but that could be because my expertise is lacking with regard to interpreting code.

Anyway, I would expect performance changes (hopefully improvements! :slight_smile: ) as soon as those changes from mt76 are merged into OpenWRT main. (Edit: newest mt76 is merged now)

1 Like

The PHYs talked about refer to the wireless radios in this case AFAIK, so that seems very relevant.

1 Like

Hi, from my point of view everything except LEDs is basically working. Did some tests yesterday with the latest OpenWrt master merged. I don't know if it was tested enough to ensure it's "stable". At my environment, OpenWrt is not yet in an productive environment so there is no long term experience.

Regarding testing, there seems to be a problem with the latest updates, see Probable wifi regression in mt7621 snapshot

1 Like

Regarding the LED support, I'm not quite sure if I understood it correctly (please correct me if I'm wrong): The RSSI LEDs are connected to MT7621 GPIO 7/8/22/23/26/27).
This are different pins than the LED pins of MT7915E or MT7975.

Sorry, I don't know.

Regarding the performance, I did a short test with iperf3 between my Windows machine (connected via LAN to the Router) and my Mac (connected via Wifi):

If the Mac is directly connected to the 5GHz wifi of the router:
[ ID] Interval Transfer Bitrate Retr
[ 5] 0.00-10.00 sec 282 MBytes 236 Mbits/sec 0 sender
[ 5] 0.00-10.00 sec 281 MBytes 236 Mbits/sec receiver

If the Mac is connected to the 5GHz Wifi of DAP-X1860 (running as AP connected to the Router LAN):
[ ID] Interval Transfer Bitrate Retr
[ 5] 0.00-10.00 sec 258 MBytes 216 Mbits/sec 0 sender
[ 5] 0.00-10.00 sec 257 MBytes 216 Mbits/sec receiver

If the Mac is connected to the 2.4GHz Wifi of DAP-X1860 (running as AP connected to the Router LAN):
[ ID] Interval Transfer Bitrate Retr
[ 5] 0.00-10.00 sec 125 MBytes 104 Mbits/sec 0 sender
[ 5] 0.00-10.00 sec 124 MBytes 104 Mbits/sec receiver

Used image: (based on

Did you use the web interface to upload the image? In my case it says firmware update failed.

I think I used the sysupgrade command via SSH. Do you already have OpenWrt installed on your device? Then flashing the sysupgrade via web interface should work. Otherwise use the factory image as described here: OpenWrt Support for D-Link DAP-X1860 - #49 by s_2

Currently the stock firmware is installed. I tried using factory image as described above, but it fails as soon as i click upload.

Which browser do you use? I had update problems with Firefox but it worked with Chrome. If the problem still exists, I’ll double check my uploaded files

Chrome. Will try others just in case and report back.

Edit: It is the same problem with Edge & Firefox.

Ok, I re-tried the files on my device, I can upload the factory image:

Upgrade process is started:

And finished successfully:

To be sure: You're using the factory image? Where exactly in the process does it fail?

I see where I have made the mistake. I thought reset button was to factory reset the repeater (maybe I held the button too long as I didn’t get into recovery mode). Anyways thanks for your time, now it works.


  1. Download the openWRT image.
  2. Connect to the repeater with ethernet cable.
  3. Enter recovey mode. (Hold RESET button, before plugin in the repeater, until orange power light starts blinking)
  4. In Chrome open
  5. Upload factory.bin
  6. Wait a couple of minutes.
  • Note: I did not get update completed message, but when the orange light was on (not blinking) it was finished and I could acess LuCI on

Might be relevant.

what is currently preventing a pull-request? More test results?

A patch was sent to the mailing list:

1 Like

If required, I provide new images for the DAP-X1860 time to time:


Thank you Rolando. I have not seen the patch from S_2 arrive in the OpenWRT repository or as Pull-request at GitHub yet, so thank you for keeping us updated.

It seems like there will be some changes to package and firmware dependencies for mt7615e and 7915e: mt76: refine package dependency for mt7615e and mt7915e. They have not yet taken the DAP-X1860 into account though.

1 Like

Hi all devs,
hope you guys doing well.

As a casual OpenWRT user i hope to get a little help on flashing this device as i really stuck rn. I tried to flash the fw but I always get stuck in recovery mode.
When I try to upload the OpenWrt images I always get something like:
"Size: 1259 Bytes" or "Size: 1301 Bytes", depending on which browser I use and on every upload the MD5 is different for the same file.
Only thing that shows correct size and MD5 information is when I upload a stock d-link FW .bin file
I get then:

Upgrade complete!
Rebooting ...

but also end in recovery mode again.

What I tried so far:

  • renaming the openwrt files (to factory.bin and to the name of a stock d-link fw file)

  • tried to reset the device by holding the reset button some seconds after power on

  • different OpenWRT factory and initramfs-kernel images linked in this Thread directly and newer files from RolandoMagico's Github

  • D-LINK support chat trying to get an unencrypted file or anything i could flash they send me an link to try but i think it is also encrypted and not meant for recovery use, however it leads me to the same result as the newer stock fw from the d-link support site I tried first. Finally the chat was out of informations and asked me to open a ticket for the experts to reach out to me, i agreed, i got now answer on the ticket after few minutes, they offer me a RMA. So no luck but was worth the try.
    This was the link they sent me btw if it helps for anything:
    (my bad i wrote them by mistake about DIR device not DAP, thats why i got a wrong link from them, however, the problem persists)

  • i also tried different browsers(Opera, Firefox, Edge, Seamonkey, Chrome)

Btw i have two devices in the same state now, so its definitely not a hardware problem.
Oh and the devices were on the 1.0 FW they came with from factory as i started trying maybe this is important because of the recovery mode version is updated on newer stock fw versions idk.
One of the devices was in use already (linked wifi) the other one put directly to recovery mode

Maybe someone has a little hint for me on what I could try next or where could be a possible reason.
thanks in advance

Looks like Mediamarkt in Germany still wants to get rid of them. You can currently buy one for 30€. But if you buy two of them, there is a 30€ discount. So 30€ for both in the end with free shipping.

1 Like