OpenWrt Support for D-Link DAP-X1860

Not sure if there are still any problems with LEDs or with functionality in general, as I have not tried any of the builds yet, but i found this issue to be an interesting read: ramips: correct the pcie port number for some mt7621 devices (fix Wi-Fi lost) and although they are not talking about mt7915E ... there are a few recent comments at the bottom talking about LED behaviour, which could be used as the base for some experimentation.

Regarding the LEDs, they are working in general. Problem is that wlan0 or wlan1 interfaces are not available when setting up a wireless connection with default settings.
As @s_2 mentioned, as a workaround this line can be used:
uci set'phy0-sta0'

I also had success by renaming the interface name to wlan0 after setting up a wifi connection. After a reboot, the LEDs are also showing the expected behavior


Hello. I have been following this thread, but I am kinda lost. Are just the LEDs not working and the image is safe to use, or is there still some work need to be done?

In the last days, there were multiple additions to the mt76 driver and the upstream linux kernel "Linux-next". Many of those were for mt7915. With regard to LEDs, the following commit is of special interest: At first glance I have not found a commit explicitly dealing with issues related to wlan interfaces and default settings, but that could be because my expertise is lacking with regard to interpreting code.

Anyway, I would expect performance changes (hopefully improvements! :slight_smile: ) as soon as those changes from mt76 are merged into OpenWRT main. (Edit: newest mt76 is merged now)

1 Like

The PHYs talked about refer to the wireless radios in this case AFAIK, so that seems very relevant.

1 Like

Hi, from my point of view everything except LEDs is basically working. Did some tests yesterday with the latest OpenWrt master merged. I don't know if it was tested enough to ensure it's "stable". At my environment, OpenWrt is not yet in an productive environment so there is no long term experience.

Regarding testing, there seems to be a problem with the latest updates, see Probable wifi regression in mt7621 snapshot

1 Like

Regarding the LED support, I'm not quite sure if I understood it correctly (please correct me if I'm wrong): The RSSI LEDs are connected to MT7621 GPIO 7/8/22/23/26/27).
This are different pins than the LED pins of MT7915E or MT7975.

Sorry, I don't know.

Regarding the performance, I did a short test with iperf3 between my Windows machine (connected via LAN to the Router) and my Mac (connected via Wifi):

If the Mac is directly connected to the 5GHz wifi of the router:
[ ID] Interval Transfer Bitrate Retr
[ 5] 0.00-10.00 sec 282 MBytes 236 Mbits/sec 0 sender
[ 5] 0.00-10.00 sec 281 MBytes 236 Mbits/sec receiver

If the Mac is connected to the 5GHz Wifi of DAP-X1860 (running as AP connected to the Router LAN):
[ ID] Interval Transfer Bitrate Retr
[ 5] 0.00-10.00 sec 258 MBytes 216 Mbits/sec 0 sender
[ 5] 0.00-10.00 sec 257 MBytes 216 Mbits/sec receiver

If the Mac is connected to the 2.4GHz Wifi of DAP-X1860 (running as AP connected to the Router LAN):
[ ID] Interval Transfer Bitrate Retr
[ 5] 0.00-10.00 sec 125 MBytes 104 Mbits/sec 0 sender
[ 5] 0.00-10.00 sec 124 MBytes 104 Mbits/sec receiver

Used image: (based on

Did you use the web interface to upload the image? In my case it says firmware update failed.

I think I used the sysupgrade command via SSH. Do you already have OpenWrt installed on your device? Then flashing the sysupgrade via web interface should work. Otherwise use the factory image as described here: OpenWrt Support for D-Link DAP-X1860 - #49 by s_2

Currently the stock firmware is installed. I tried using factory image as described above, but it fails as soon as i click upload.

Which browser do you use? I had update problems with Firefox but it worked with Chrome. If the problem still exists, I’ll double check my uploaded files

Chrome. Will try others just in case and report back.

Edit: It is the same problem with Edge & Firefox.

Ok, I re-tried the files on my device, I can upload the factory image:

Upgrade process is started:

And finished successfully:

To be sure: You're using the factory image? Where exactly in the process does it fail?

I see where I have made the mistake. I thought reset button was to factory reset the repeater (maybe I held the button too long as I didn’t get into recovery mode). Anyways thanks for your time, now it works.


  1. Download the openWRT image.
  2. Connect to the repeater with ethernet cable.
  3. Enter recovey mode. (Hold RESET button, before plugin in the repeater, until orange power light starts blinking)
  4. In Chrome open
  5. Upload factory.bin
  6. Wait a couple of minutes.
  • Note: I did not get update completed message, but when the orange light was on (not blinking) it was finished and I could acess LuCI on

Might be relevant.

what is currently preventing a pull-request? More test results?

A patch was sent to the mailing list:

1 Like

If required, I provide new images for the DAP-X1860 time to time: