OpenWrt Support for Asus RT-AC88U

I am really stuck with the Wifi enabling: the radio0 2.4Ghz does not want to turn on after installation of 20.3.2 and after reboot the 2.4Ghz radio will even disappear.
Anyone can help me? (HW A5)

Try resetting the nvram, clearing the config and setting up again. On first boot just test the WiFi before anything else.

I had this, and this procedure worked

Do you have a link with the procedure to "Try resetting the nvram, clearing the config and setting up again"
It did not manage to get the CFE web connection

It's on the device page at the "OEM easy installation" section.

If you're frozen out of luci, SSH into the device and issue

The. You should be able to connect to luci again and goto the page as the above reply

So annoying, after factory reset and fresh install, I can activate Radio0 and connect to the wifi 2.4Ghz.
But as soon as I restart the machine, it does not work anymore and I get this message when I try to enable it.

after another factory reset, then the 2.4Ghz completely disappear:

Good morning, thanks for the time spent, good job.
I confirm that I have version 22.03.2 r19803-9a599fee93 running on my RT-AC88U HW A2.
The only problem I have had when passing vlans over the wi-fi. After reinstalling it several times, I have seen in the forum that it is a known bug :). We will wait for the patch.
Additionally, before creating the vlans, I noticed that on two of the three devices I connected to the 2.4 radio, I had to disable the Magament Frame Protection option. It didn't work on the option of optional or required. In the 5 band it worked, both on a mobile phone and on a laptop.
If you need any log or feedback I will be happy to provide it.
Thank you very much again.

This works for my RT-AC88U, HW is A2. There is finally the wireless tab. Almost gave up.

I would like to point out that, versions 22.03.2 and 22.03.1, both don't work for me. I don't get the wireless tab at all, like there is no WiFi at all. I tried many times, resetting the nvram before flashing each time. Tried 22.03.2 first, then 22.03.1, then finally this snapshot works. I wanted to be sure, and flashed to 22.03.1 again, and lost the wireless tab again. Then retried 22.03.2 again, still no wireless tab.

Seems like the hardware is different for the same HW A2, since others have reported success for 22.03.x. Is there something changed that affected the WiFi for my hardware between the snapshot and the release versions? Is it possible to have the next release fixed for my hardware? Thank you so much.

And if it is not too troublesome, could you explain a bit more on the workaround for vlan filtering for wifi? How to create a local vlan, which is to be included in a new bridge? I'm very new to these and trying hard to understand and learn. Does it mean that this workaround will only enable 1 vlan for all/any wifi, but the other physical ports can still be bridged with vlan filtering on?

Thank you very much.

Please read this post:

There's good amount of information around this thread which should be sufficient to do it on your own.

You just need to install brcmfmac-firmware-4366b1-pcie on 22.03.x and it should work.

Exactly, I have that hardware revision, and once the package is installed it detects it. If you haven't reset the nvram you can try re-flashing the factory firmware again, reset to default from the gui and re-flash. I have created the vlans for the wired network by watching this video:
I have created three vlans, one for management with the PVID and two others. The WiFi doesn't work, you have to wait for the patch.

I am having a hard time finding a url link. would you be able to send me one, please?

Would you be able to provide a link to the brcmfmac-firmware-4366b1-pcie download, please?

Just download the latest 22.03 snapshot, it's included.

I flashed the router with this but seems to be in a loop. I know how to flash but new to Openwrt. Was I supposed to flash the snapshot?

Of course. Can you get the boot log in any way?

Also, which file did you download from there?

I cant a boot file cause its stuck in the loop. I did flash back to 22.3.x and then tried flashing the below in the screen shot

opkg update && opkg install brcmfmac-firmware-4366b1-pcie

This topic was intended for adding support for this specific device.
Since official 22.03 images are available now, I will set a timer for this topic to close.


Because specific problems for this device with official releases are better handled in separate topics, in order to make finding relevant information easier. Who is going to read the previous 100-something postings, if he has a specific problem with 22.03 and wifi?

Therefore: Please open new topics for any open issues with this device.

Thanks! :slight_smile:

This worked!!! Thank you!