OpenWrt Support for Armor G5 (NBG7815)

Can you please make an OpenWrt issue in regards to this, thanks for pointing it out.
I think this is related to the fact that NBG is using U-Boot env variables over NVMEM for the MAC while I only have AX3600 and AX9000 that use NVMEM but have no issues as they are just reading from a fixed offset.

1 Like

Hi, thx for your comment/work.

I'm currently building for AX3600. But it's not necessary anymore as you've done the work already.

Ah. I remember that we had some discussion regarding the WIFI MAC's and nvram which is not implemented.

What is the exact reason why u-boot is used for this device?
If I understand the process right u-boot is overwriting any MAC declared and retrieved from nvram within DTS? That's why DTS is using uboot-env directly. Just for understanding it a bit.

I will file an issue.

EDIT: https://github.com/openwrt/openwrt/issues/13831

AFAIK, because this device stores the proper MAC as a U-Boot environment variable and we parse it as such.

Can we stop using the term nvram, it is a Broadcom-only thing and these days tends to be more confusing as it literally can mean any non-volatile storage.

1 Like

Sorry, sure we can. I'm just using this term because my first router were I used custom firmware was the WRT-54G (Broadcom device with nvram). I never thought about using other term.
But I have to say that I'm a bit lost what term using instead? Is PRAM (Parameter-RAM) better? I think Apple is using this term.

No need to apologize, I mean that as a general thing.

Just call it by the function and the underlying storage, there is no RAM of any kind being used here, in 99% of cases its just stored as binary data on the storage medium or as U-Boot environment variable in ASCII again on the storage itself

1 Like

I've played around with an vanilla build to narrow it down a bit und just deleted "816-v6.7-0004-Revert-nvmem-add-new-config-option.patch". It was enough to make it work again. But I don't know if and what sideeffects this could introduce.

EDIT: The bug is fixed and MAC is stable again.

1 Like

OWE problem with wpad-mbedtls seems to be fixed in commit 39341f4

Hello guys today I received this and I was tinkering around with the intention of improving this (add better support for FAN, proper LEDs support for at808x PHY driver, custom uboot without that crap of the zyloader)

Well... long story short, in search of a way to bypass the zyloader, I bricked it hard... First by making it bootlooping (by overwriting the preboot uboot env... don't do that if you don't what a paperweight)
Then by using a soic clip with the wrong voltage and corrupting the entire nor...

Still not sure if I totally fried the nor chip but for sure the data are corrupted...

So I wonder... Can someone PM me the dump of the nor? (not the eemc, the nor)
It does contain minimal private data (serial, mac addr and product id) nothing serious... I will replace them with mine since they are sed based on uboot env.

2 Likes

I'm not good with electronics, but if what you need can be extracted through the serial port, tell me how to do it and I'll send it to you.

Hi Ansuel.

I just placed an order on one of these to replace my last non ipq807X AP. Was going to go with (another) 301W but seeing as I found this for half the price I pulled the trigger on this instead. This last location, I do not need the dual 10gbe or dual USB (although I do need the single USB)... Anyways, rambling aside:

Let me know how to pull what you need. I have a couple of USB to UART if needed... I see this device exposes the UART pins out of factory.

Well I got this device all up and running.

Have to admit it's a bit of a pain in the ass. The main issue for me is the extroot / 40MB partition size... I need docker and the binaries alone take up much more than that. I spent a good 2 hours banging my head against the wall only to find out the need for the block.c patch.

So far running a non NSS build but will probably switch over to a NSS build at some point.

Does anyone know if there is a way to manually resize the partitions to avoid using extroot? And if so, in a way to survives a sysupgrade?

PS : For what it's worth, the IPQ8074A which this device has is faster than the AMD based PC Engines APU2D4 this device replaced. I know the APU2 is now showing its age (5+ years old?) but nonetheless, this device is faster. I am doing the EXACT same set of tasks and load dropped by 2/3.

@Ansuel

While I'm not sure what exactly you need I could offer to send you my device.
I saw that your are located within EU/Italy. So from Germany it isn't so far away.

But as I didn't bought it on "sale" (bought it for ~200EUR) I would want it back so like after a few weeks.

Beside that I didn't inspect the board installing serial cables because everything was hidden and there was no need to do. I cannot find any photos on internet. So I don't know what chips are on the board actually.

Where is the uboot/zloader on? Is it an extra SPI chip? In the past I've used a USB CH341A programmer for bios chips and some routers. I could buy such a programmer (atm I don't have) and read the chip. The nand readers are very pricy and I don't know if they work reliable without soldering (for this chips my solder skills would not be enough).

But maybe that @itorK or @avalentin made already an image?

Np guys thanks, other user already sent some dump

1 Like

Y, the raw power of this device is insane. That's why we have a fan. ^^ Sadly there are only a few devices with the full fleged IPQ8074 available. As I've bought this we had (if I remeber correct) only the RAX120 from Netgear. And I think there are not much more nowdays. Beside one from Asus and a few newer IPQ8078s.

A few final pointers to anyone getting this devices up and running:

  1. Recent builds do not require the block.c patch for extroot to work. You should be able to use extroot without any sort of patches.

  2. I recommended using the NSS build. After switching from the non-nss to the nss build my load dropped even more, doing the exact same tasks.

  3. This device has fairly decent radios. I am basically maxing out my 80mhz channels from 10 or so meters away. I get in excess of 100MB/s doing samba transfers and hit about 450mbits on my 500mbit connection.

  4. Aside from the lack of 160mhz, this device is a fairly solid choice for anyone looking for a powerful openwrt based router. Strictly due to price, unless you REALLY need 2x10gbe or 160mhz, I recommend this device over the Qnap 301w.

1 Like

Also, if anyone wants to lock the NSS cores at their max speed:

printf 1689600000 > /proc/sys/dev/nss/clock/current_freq

Then check dmesg. Your NSS cores should be pinned to their max speed. I've been doing this on my 301Ws for quite some time with no ill effects.

Hi guys, welcome back

As winter approaches, I would like to have more colours at my blackbox,
so I did some experiments based on actually lp5569(LED) module and here is my work:

4 Likes

Can someone check this?

2 Likes

I'll make a build and test it. I'll try to get it done today and let it run until tomorrow to give feedback.

1 Like

Aqr thermal zone does not get exposed to the system:

root@NBG7815:~# cat /sys/class/thermal/thermal_zone*/type
nss-top-thermal
nss0-thermal
wcss-phyb0-thermal
wcss-phyb1-thermal
nss1-thermal
wcss-phya0-thermal
wcss-phya1-thermal
cpu0-thermal
cpu1-thermal
cpu2-thermal
cpu3-thermal
cluster-thermal

--> init.d script is doing nothing.

Cannot see any typo or error in DTS. Beside that aqr113c does not has defined a thermal-sensor-cell. But afair this has no influence on zones. So my guess is that we are missing sth. like a polling-delay-cold for the new trip type?

And if I remember correct: One sensor per thermal zone only. At least this was a restriction until in kernel 5.4 (not documented ^^). I tried it in the past for this target as we were on 5.1x. I don't know if there was a change for 6.1.

Beside that: The fan is doing its on/off thing like every 1-2 minutes for ~1-3 seconds. Without doing anything with the device (no activity).