Openwrt snapshot not allowing me to download packages

Hello all. I am fairly new to openwrt. I recently bought a openwrt 5g router that contains openwrt snapshot 21.02. The router's original firmware doesnt allow me to add openVPN and wireguard. I am able to SSH into router via putty. My main goal is to download openVPN and wireguard via luci gui. My router isnt allowing me to download any packages. My router has internet. I tried opkg update and opkg install. Apparently I am missing SSL support. I tried downloading libustream-openssl and libustream-mbedtls and that didnt work either. I spoke with the manufacturer and they told me this version of openwrt is closed and that I would need another SDK. Any advice on how I could download packages?

Chances are that this is a vendor firmware that is "based on" OpenWrt, but is significantly modified. That generally is not supportable here in any way.

That said, what is the output of:

ubus call system board
1 Like

I appreciate the fast response . I got this.

root@OpenWrt:/# ubus call system board
"kernel": "5.4.257",
"hostname": "OpenWrt",
"system": "ARMv8 Processor rev 4",
"model": "WT7981N",
"board_name": "WT7981N",
"release": {
"distribution": "OpenWrt",
"version": "21.02-SNAPSHOT",
"revision": "2.6.0",
"target": "mediatek/mt7981",
"description": "OpenWrt 21.02-SNAPSHOT 2.6.0"

Yeah, this device is not supported by the official OpenWrt project. It is no surprise that you cannot download and install the packages you are looking for.

You'll have to ask the vendor for support since this is their own custom version.

This probably goes against the licensing terms of OpenWrt, but is unfortunately not an uncommon situation.

1 Like

Ok thanks for all your help. I will eventually get the new Glinet Spitz AX. just waiting for price to go down a bit.