OpenWrt seems easy to corrupt, for inexperienced users

I finally got OpenWrt to install on my Netgear WNDR4500v3. It seems to be easily corruptible - dunno if the router, or OpenWrt.
First occurence: Changed OpenWrt address from default IP to When it displayed the "roll back" message, I said do it anyway. Oops, corrupt.
Reflashed (using nmrpflash) NG level firmware, then OpenWrt.
Managed to change IP to so it could co-exist on my existing LAN for configuration. First want to do DHCP static leases. Read up on UCI, but thought "let's just try changing (deleting one entry) from the /etc/config/dhcp file" and see if that's feasible. OK, did that, did save/apply, reboot, now corrupt and have to reflash. Also had made a couple changes, like enable/configure wireless, enable WAN.

Any idea what's up with this. Does it magically know I changed something and now wants to punish me or what?

I would like to substitute the OpenWrt for my current Tomato on a WRT54g-tm, but this is discouraging and a lot of work.



What does corrupt mean here? Refuses to boot and complains about mangled firmware while doing so? Changes the local IP address again? Is accessible on your chosen IP address but expected services not running?


Corrupt is not the same as a user entering incorrect/invalid configuration settings. It sounds like this falls into the latter category, not the former.

OpenWrt will generally accept most settings that are commanded of it, provided that the syntax is correct for applying those changes. That is not a bug and this doesn't constitute corruption.

The "roll back" message seen in LuCI is there to prevent the user from locking themselves out of the router when changing the LAN IP on the router. You can bypass the automatic rollback feature if you like, just be sure you set the correct address.

If you mess up a specific setting, you can almost always use failsafe mode to regain access and fix the bad setting(s). You don't need to reflash.

Now, what is the specific goal you have that you are having trouble achieving?


What you're saying is, it's the cars fault if it let's you (deliberately) drive it off a cliff...?

But this case, the car is actually a router.

1 Like

Did you read ...

Too old device, too little flash & RAM for the currently supported OpenWrt releases. Especially the 32 MB RAM is tricky.

You might be better off with your old Tomato ketchup with that router.


My goal is to get it working...
All I do is change the LAN IP from to
I try to just let it do it's thing and it ends up rolling back.
If I then do it again and start pinging, it seems to work and I am back in Luci again, and it shows I am at the 1.2 address.

NOW, I reboot by just powering off/on and it is pretty much dead.
Power light is on, LED for port 1 (where plugged in) goes on, then all 4 LAN lights start blinking. Rinse, repeat. It's like its waiting for a reflash.

I don't think the issue is the "former" (invalid config settings). I been doing this with ddwrt, tomato, and different Linuxes for a while. Had a Netscreen router a while 'til it broke after 10 years and decided to try open source cheap routers. My WRT54G-TM works dandy as my router, and my old Buffalo WHR54 is my AP, as is a Cisco Aeronet AP.
Sorry for the CV, but just defending myself.
It's just as easy to reflash with nmrpflash as going thru the headache of failsafe guessing on timing.

So, bottom line, is there any way to figure out this issue, maybe via remote syslog for logging?



If you change the LAN IP with the CLI there is no revert check. Of course after changing the LAN IP you need to shut down the Ethernet port on your PC (or unplug the cable) and then reconnect so it acquires a new DHCP IP in the new network.

Failure to boot is best diagnosed with a serial console connection.

The WRT54G is no longer supported due to small memory. It never was the best unit for OpenWrt due to having a Broadcom wifi chip. Also no one should be using g wifi these days, it uses more airtime and reduces the performance of any co-channel n networks.

1 Like

Did you take the time to read the warning at the top of the page.

Particularly this part which seems to describe your exact problem.

"[1) This device does not have sufficient resources (flash and/or RAM) to provide secure and reliable operation.
This means that even setting a password or changing simple network settings might not be possible any more, rendering the device effectively useless."

1 Like
  1. you mention WRT54G-TM and Netgear WNDR4500v3. which one is not working as you expect?
  2. have you checked the recommended hardware table? are you using a supported hw with a supported release?
  3. what you mean "deleting one entry" and changing from default ip to custom? what and how did you do these changes?
  4. are you following the guides and directly connect a pc to your owrt router and configure before putting it into your network?
  5. are you using other network devices may interfere with the freshly configured owrt instance?

This is a rather unhelpful response. If you provide a serious answer, we can actually help you get going.
For example, you might want this device to...

  • be your main router (replacing whatever is currently in use)
  • serve as a dumb AP (wired to your main network)
  • extend a wifi network wirelessly (using repeater/wds/mesh, etc)
  • provide VPN server functionality
  • act as a VPN client
  • filesharing (i.e. NAS) or print server functions
  • etc.

Yeah, but you seem to be having issues when you make configuration changes on OpenWrt which is a new environment to you. There could be any number of reasons you're having trouble, but you haven't given us much to work with in terms of specifics.

As others have stated, it could be a hardware thing (i.e. underresourced device) or the process/syntax of your changes, or other details that have not, as of yet, provided.

You might benefit from looking over the OpenWRT Quick Start Guide and User Guide.

When using Luci to change the lan ip i change the lan ip, click save and apply, then go to the new ip in a new tab and it’s always worked, so worth a try.

Changing lan ip by luci doesn't work properly, it always reverts, so usually I change by CLI or by editing file.

@j1mw3b , which build are you using? sometimes the latest version doesn't always work as intended on some devices, at least this was a case for me. I'm using 19.07.6 on my device. Try using this build to see if the problem persists.

Flash the device using system upgrade image without keeping any config, and before flashing, remove any extra ethernet cable aside from the device you're flashing from. After flashing change lan ip using CLI

uci set network.lan.ipaddr=''
uci commit network
service network restart

after this, restart router or unplug lan cable from router then plug it back. You should now be able to access the router at Now try setting it up again.

1 Like

Yeah, cli is the better method, but next time you need to do it try changing the ip in luci then go to the new ip in a new tab right after clicking save and apply, before the rollback message appears, and see if it works, it’s always worked for me.

ok, will try that. thanks

OK, I set the lan addr using uci as mentioned by alpha1096.
Switched browser to, logged in, went to network settings and all seems great - almost ready to declare victory, but...
to make sure, I powered off/on the router.
No joy.
It cycles between power light, lan 1 led soilid for a sec or 2, blinking lan1, all 4 leds solid, repeat.

I can only conclude I have a bad piece of hardware (Netgear WNDR4500v3), or buggy OpenWrt version (21.02.1).
Will try one more time with 21.02.0 (this seems to be version first supporting this hardware).
Thanks alpha1096. Best advice.


Again, reinstalled factory NG firmware, then used it to install OpenWrt 20.02.0.
After installing OpenWrt, after a bit, the luci login screen showed up. I waited a bit, no typing, then powered off/on router.
Failed again with the same cycling as above.
Ya' think it might not be a configuration error when changing the LAN IP????
I give up. Back to the trusty WRT54G-TM/tomato.
Gonna re-install the Netgear firmware, use it awhile just to play with like it was going to be my router; power on/off a few times and see how it goes with it.

Too much flashing, Scotty.

When I need to make "risky" or complicated changes to the network on a console-less device I do something like this:

cd /etc/config
cp network network-ok
vi network

(make changes)

cp network network-new
service network restart; cp network-ok network

I then wait a moment and check to see if the device is available as expected. If it doesn't come back properly, I reboot: that last command means it will restore old settings. If the results are as expected, I copy network-new back to network and call it good.

1 Like

Maybe not.

Do you have a way to connect to the serial port on the board to see what happens?

Unfortunately not. Never tried it. If it entails soldering, it's a nogo. My kid could do it but he's in Colorado.