OpenWrt + Samba + 5GHz Wifi = USB speed ~5MB


I have USB(WD My Passport) 2TB connected over 3.0 USB on Wrt32x.
FileSystem: EXT3

I have WiFi 5GHz 866Mbps and when I was transferring file speed was constantly 5MB/s.
Over LAN cable max speed ~11MB/s
What issue could be, last time I solved it by disabling IPv6 on OpenWrt, and it is started working faster over IPv4.
Now I updated to latest OpenWrt 22.03.2 r19803-9a599fee93 , and it is very slow :frowning:

root@xxx:~# hdparm -tT /dev/sda1

 Timing cached reads:   1364 MB in  2.00 seconds = 682.08 MB/sec
 Timing buffered disk reads: 340 MB in  3.00 seconds = 113.33 MB/sec

iperf3 tests or the internet speedtest over wifi are normal (above 5MB/s) ?

Almost good, upload should be 100Mbps

so only samba if affected.
could you check load during wifi transfer (ssh and issue uptime command ) ?

Looks like yes only samba and WiFi 5GHz also speed 2x less, by cable speed test ~95/95
root@XXX:~# uptime
08:39:53 up 1 day, 8:47, load average: 0.00, 0.00, 0.00

MB = MegaByte?

1 Like

yes we should use mbps for bandwidth and MB/s for file transfers

1 Like

It looks like that I have issue with WiFi, and when i transfer to local NAS USB speed is limited to same speed as i have over WiFi.
So based on speed test 40Mbps ~ 5MB/s, now it looks like that I need to find why my WiFi speed is limited.
Just tried 2.4Ghz and got 68/32Mbps, and NAS speed ~ 3.8MB

so issue is wifi or samba ? we need to isolate it

I think WiFi, because I have same upload speed to Samba as SpeedTest show, so I need firstly to find why OpenWrt limits WiFi Speed, and then solve issue with sabma if it is not solved.

1 Like