OpenWrt running at 144 Mbps instead of 300

Hi, I installed OpenWRT 22.03 on a TP-Link TL-WDR4300 v1, and configured it as a 2,4 GHz repeater.
All good.
I notice now that it is running at a maximum speed of 144Mbps, whereas I expected to see it running at least 300Mbps.
My PC also connects to the router at 144 mbps via a D-Link DWA-582.
How can I fix it?

2.4GHz 802.11n with 2 antennas can give you at most 144Mbps with 20MHz channel, so what you see is correct. You can check out the 2 spatial stream 64-QAM speed here.

40MHz (300Mbps) is available but this is more likely to be something on paper only, in real world there exists too much collisions so basically 40MHz for 2.4GHz 802.11n is not usable.

Your router has 5GHz wifi, is there any reason you don't use it with your DLink DWA-582??


Hi, I am setting a repeater and I can't connect my TP-Link TL-WDR4300 v1 to other 5GHz routers, because there seems to be authentication problems. So, I am using DLink DWA-582 to connect over 2,4 GHz now.
I will open another thread for this.
Thank you.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.