OpenWrt/Router a bottleneck to higher ISP speeds?

I have a TP-LINK Archer C7 running OpenWrt.

My max throughput when the cable modem is connected to the router is ~150mbps. If I disconnect the router and directly connect cable modem to a computer, I get 500mbps. After some investigations, apparently the culprit may be the router. Specifically, OpenWRT is causing the bottleneck (some sources online suggest that returning the C7 to stock firmware resulted in max throughput of ~600 mbps)

  1. Is that true? Is the router the most likely cause of my speed bottleneck?

  2. If so, can you suggest a price-conscious router that will work with OpenWRT but that will be able to handle gigabit internet speeds?

Have a read at So you have 500Mbps-1Gbps fiber and need a router READ THIS FIRST.

tl;dr, the archer c7 is indeed way too slow for your (new-) needs.

thanks much. i'll read this post.

ok i read it. so, uhhh, what router should i get? :smiley:

i should rephrase this a bit:

i do have some spare computers laying around, so if i'm getting this post correctly, i should essentially be building a "comptuer-router" and then tying the whole thing together with a switch?

I wouldn't go that far, older x86_64 systems (unless carefully selected) tend to have a rather high idle power consumption (75-130 watts, 24/7), getting a low-power device (can be x86_64, but doesn't need to be) quickly pays for itself (6-15 months, due to lower electricity costs).

thanks. i'm intrigued by doing this by getting a second raspberry PI, but i probably will wind up opening the wallet and posting for a recco for an off-the-shelf router.

Any recommendations on low-power but high-performance (up to gigabit w/SQM, even though I don't presently have the need for that)? I think I've seen RPI, ODROID H-2, and APU2.

Many of these threads end up recommending something very powerful but not very power-efficient.

The apu2 can barely route at 1 GBit/s, it can't do SQM at that throughput (at all).

That's good to know, and it's not exactly cheap... Is there something relatively power efficient that does?

I have not done it but... If you feel like rolling your own, I have seen a recommendation for the Seeed two-Ethernet board attached to a Raspberry Pi Compute module.

Put it in an enclosure, and add a power supply to get a two-port Ethernet router that can run OpenWrt at GBit speed (according to the original 500Mbit+ post). You can keep your Archer C7 as a dumb access point since it has decent Wi-Fi.

This gives you a pretty high-performance router with relatively low power consumption at a very modest price. Have fun!

1 Like

A simple Pi 4 + UE300 will achieve the same thing without the freakishness of the Compute Module, but either way you'll also need a (preferably smart) switch. It will indeed do shaped gigabit and gigabit Wireguard.

Hi, for comparison ... I have a 1/1 Gbps line and a WRT3200ACM router. My iperf speed is:

Raw (unencrypted) 930/930 Mbps
Wireguard encrypted 725/725 Mbps
WIFI 5 Wireguard, up to 650/650 Mbps

So the WRT is doing a pretty good job!

The WRT is only handling policy routing and encryption assisted by two APs

A cheap Ubiquiti EdgeRouter X with OpenWrt 21.02.0-rc1 might do the trick.

Depends where you live. That's because availability of anything OpenWRT varies from region to region. In my case i have the same router as a dumb access point with the original firmware, and a RPI4 2GB model routing, doing SQM, print server and small file share unit, although i don't use the RPI4 WIFI capabilities. I never got more than 25-30% usage and consistently reach 900+ mbps (on the Archer C7 i usually use only the N network capability, due to smartphone usage here). Can't tell how well will perform with VPN enabled, since all RPI's have a Broadcom processor without hardware accelerated encryption.

If you can't find a good replacement for your Archer C7, maybe you can give this setup a try. (Caveat emptor: i did wrote a guide for a custom build, that can be used for the 21.xx release, but still you need a usb-ethernet gigabit dongle compatible with linux.)

Have you tried enabling flow offloading?

Basically, go into Firewall -> General settings, tick Enable SW offloading and reboot. Test again, you should be able to use full 500Mbit (test with cable though, not via WiFi).